aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-05 04:47:11 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-05 04:47:11 +0000
commit94215cee3ce85d77611083944a45767f811ea994 (patch)
tree946e1fc14579cc5b8f8763984c8bae7ba90399cf /net
parent562cc6f40338ce650bba4e94ee4add6a941aa48e (diff)
downloadports-94215cee3ce85d77611083944a45767f811ea994.tar.gz
ports-94215cee3ce85d77611083944a45767f811ea994.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/jabber-xdb_ldap/Makefile36
-rw-r--r--net/jabber-xdb_ldap/distinfo1
-rw-r--r--net/jabber-xdb_ldap/files/patch-Makefile13
-rw-r--r--net/jabber-xdb_ldap/pkg-descr6
-rw-r--r--net/jabber-xdb_ldap/pkg-plist3
6 files changed, 60 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 0c9b01d10cf6..541038bf4991 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -256,6 +256,7 @@
SUBDIR += jabber-conference
SUBDIR += jabber-jud
SUBDIR += jabber-msn
+ SUBDIR += jabber-xdb_ldap
SUBDIR += jabber-yahoo
SUBDIR += jabberd
SUBDIR += jags
diff --git a/net/jabber-xdb_ldap/Makefile b/net/jabber-xdb_ldap/Makefile
new file mode 100644
index 000000000000..93e577ca5491
--- /dev/null
+++ b/net/jabber-xdb_ldap/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: jabber-xdb_ldap
+# Date created: 03 January 2004
+# Whom: Martijn Lina <martijn@pacno.net>
+#
+# $FreeBSD$
+
+PORTNAME= xdb_ldap
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= http://www.jabberstudio.org/files/xdb_ldap/
+PKGNAMEPREFIX= jabber-
+DIST_SUBDIR= jabber
+
+MAINTAINER= martijn@pacno.net
+COMMENT= Jabber xdb backend for an LDAP directory
+
+BUILD_DEPENDS= ${NON_EXISTENT}:${PORTSDIR}/net/jabber:configure
+
+USE_GMAKE= yes
+USE_OPENLDAP= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+
+.include <bsd.port.pre.mk>
+
+JABBER_SRC!= cd ${PORTSDIR}/net/jabber && make -V WRKSRC
+MAKE_ENV= JABBER_SRC=${JABBER_SRC}
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/jabber
+ ${INSTALL_DATA} ${WRKSRC}/xdb_ldap.so ${PREFIX}/lib/jabber/
+ ${INSTALL_DATA} ${WRKSRC}/../jabber-xdb.xml ${PREFIX}/etc/jabber-xdb.xml.sample
+ ${MKDIR} ${PREFIX}/etc/openldap/schema
+ ${INSTALL_DATA} ${WRKSRC}/../jabber.schema ${PREFIX}/etc/openldap/schema/jabber.schema.default
+
+.include <bsd.port.post.mk>
diff --git a/net/jabber-xdb_ldap/distinfo b/net/jabber-xdb_ldap/distinfo
new file mode 100644
index 000000000000..3ef859e2c7c2
--- /dev/null
+++ b/net/jabber-xdb_ldap/distinfo
@@ -0,0 +1 @@
+MD5 (jabber/xdb_ldap-1.0.tar.gz) = 373f0f780c725cc06c824e322fc694ff
diff --git a/net/jabber-xdb_ldap/files/patch-Makefile b/net/jabber-xdb_ldap/files/patch-Makefile
new file mode 100644
index 000000000000..e7a56d1a5505
--- /dev/null
+++ b/net/jabber-xdb_ldap/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Wed Jul 24 17:42:25 2002
++++ Makefile Sat Nov 29 18:35:35 2003
+@@ -1,7 +1,7 @@
+-include ../../platform-settings
++include ${JABBER_SRC}/platform-settings
+
+-CFLAGS:=$(CFLAGS) -I../../jabberd -I../include
+-LIBS:=$(LIBS) -lresolv -lldap -llber
++CFLAGS:=$(CFLAGS) -I${JABBER_SRC}/jabberd -I../include -I/usr/local/include
++LIBS:=$(LIBS) -L/usr/local/lib -lldap -llber
+ xdb_ldap_OBJECTS = xdb_ldap.o \
+ xdb_ldap_common.o \
+ xdb_ldap_auth.o \
diff --git a/net/jabber-xdb_ldap/pkg-descr b/net/jabber-xdb_ldap/pkg-descr
new file mode 100644
index 000000000000..8a8bf540873f
--- /dev/null
+++ b/net/jabber-xdb_ldap/pkg-descr
@@ -0,0 +1,6 @@
+The Jabber server (jabberd) is a daemon for Jabber clients to connect
+and communicate with. xdb_ldap allows you to store the jabber data in
+an LDAP directory
+
+You can learn more about Jabber at:
+WWW: http://www.jabber.org/
diff --git a/net/jabber-xdb_ldap/pkg-plist b/net/jabber-xdb_ldap/pkg-plist
new file mode 100644
index 000000000000..066d0461a80c
--- /dev/null
+++ b/net/jabber-xdb_ldap/pkg-plist
@@ -0,0 +1,3 @@
+lib/jabber/xdb_ldap.so
+etc/jabber-xdb.xml.sample
+etc/openldap/schema/jabber.schema.default