aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-01-15 09:12:07 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-01-15 09:12:07 +0000
commita674a8a8fc4d692a989d2fa41edd351ffe000a3a (patch)
tree556ca79de8f2ac5fc21273e524a08142e4ae0557 /net
parent8c356b8ce8212c616595095bff822a1a612c112b (diff)
downloadports-a674a8a8fc4d692a989d2fa41edd351ffe000a3a.tar.gz
ports-a674a8a8fc4d692a989d2fa41edd351ffe000a3a.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/yptransitd/Makefile33
-rw-r--r--net/yptransitd/pkg-plist6
2 files changed, 25 insertions, 14 deletions
diff --git a/net/yptransitd/Makefile b/net/yptransitd/Makefile
index 255b2a219ebc..d2244f2dd491 100644
--- a/net/yptransitd/Makefile
+++ b/net/yptransitd/Makefile
@@ -3,27 +3,44 @@
PORTNAME= yptransitd
PORTVERSION= 0.5
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
-COMMENT= A replacement for nss_ldap
+COMMENT= Replacement for nss_ldap
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
-USE_OPENLDAP= yes
USES= bison
-USE_LDCONFIG= yes
+USE_OPENLDAP= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-ldap-prefix=${LOCALBASE}
+CONFIGURE_ARGS= --with-ldap-prefix=${LOCALBASE}
+USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE= yes
+
+PLIST_FILES= %%ETCDIR%%/ldap.conf %%ETCDIR%%/modules/ldap.so \
+ %%ETCDIR%%/yptransitd.conf sbin/yptransitd
+PLIST_DIRS= %%ETCDIR%%/modules %%ETCDIR%%
-NO_STAGE= yes
post-patch:
+ @${REINPLACE_CMD} -e 's, $$(CONFDIR), $${DESTDIR}$$(CONFDIR),' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's,=gcc,=@CC@,' \
+ ${WRKSRC}/lib/Makefile.in
+ @${REINPLACE_CMD} -e 's,-O2 -g,@CFLAGS@, ; \
+ s, $${BINDIR}, $${DESTDIR}$${BINDIR},' \
+ ${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -E 's,^([[:blank:]]+)\([^\)]+\) ,\1,' \
${WRKSRC}/src/modules.c
+ @${REINPLACE_CMD} -e 's,-O2 -g,@CFLAGS@, ; \
+ s, $$(CONFDIR), $${DESTDIR}$$(CONFDIR),' \
+ ${WRKSRC}/src/modules/ldap/Makefile.in
@${REINPLACE_CMD} -e 's,(void \*) ,,g' \
${WRKSRC}/src/modules/ldap/cache.c
-post-install:
- @${CAT} ${PKGMESSAGE}
+pre-install:
+ @${MKDIR} ${STAGEDIR}${ETCDIR}/modules
.include <bsd.port.mk>
diff --git a/net/yptransitd/pkg-plist b/net/yptransitd/pkg-plist
index cb0ebf6fff1f..e69de29bb2d1 100644
--- a/net/yptransitd/pkg-plist
+++ b/net/yptransitd/pkg-plist
@@ -1,6 +0,0 @@
-etc/yptransitd/yptransitd.conf
-sbin/yptransitd
-etc/yptransitd/modules/ldap.so
-etc/yptransitd/ldap.conf
-@dirrm etc/yptransitd/modules
-@dirrm etc/yptransitd