aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-12 13:29:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-12 13:29:46 +0000
commitafe70d85bb34ac7e4d02a479c3f395ed70654413 (patch)
tree5058cfe8cbe16c7abbb3d0aec97423fe6ba6bcc3 /net
parent0676261fcab875ad22e99cc2de3807f5dc135545 (diff)
downloadports-afe70d85bb34ac7e4d02a479c3f395ed70654413.tar.gz
ports-afe70d85bb34ac7e4d02a479c3f395ed70654413.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Test-URI/Makefile27
-rw-r--r--net/p5-Test-URI/distinfo3
-rw-r--r--net/p5-Test-URI/pkg-descr3
-rw-r--r--net/p5-Test-URI/pkg-plist5
5 files changed, 39 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index a49591cdd54b..55ebbb2925bc 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -585,6 +585,7 @@
SUBDIR += p5-Socks
SUBDIR += p5-Spread-Message
SUBDIR += p5-Spread-Session
+ SUBDIR += p5-Test-URI
SUBDIR += p5-URI
SUBDIR += p5-URI-FromHash
SUBDIR += p5-URI-OpenURL
diff --git a/net/p5-Test-URI/Makefile b/net/p5-Test-URI/Makefile
new file mode 100644
index 000000000000..252d7fa8b7f4
--- /dev/null
+++ b/net/p5-Test-URI/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Test-URI
+# Date created: 2007-10-30
+# Whom: TAKAHASHI Kaoru <kaoru@kaisei.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-URI
+PORTVERSION= 1.07
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kaoru@kaisei.org
+COMMENT= Perl module for check URI
+
+RUN_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Simple
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::URI.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Test-URI/distinfo b/net/p5-Test-URI/distinfo
new file mode 100644
index 000000000000..81fbfc72c83f
--- /dev/null
+++ b/net/p5-Test-URI/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-URI-1.07.tar.gz) = d63eefcb9e9e8e05bd625c910fe75edc
+SHA256 (Test-URI-1.07.tar.gz) = bb50e8318a39aa875d3dd0aab73bf9d1e33f5106682ea0109881153c8755a205
+SIZE (Test-URI-1.07.tar.gz) = 5035
diff --git a/net/p5-Test-URI/pkg-descr b/net/p5-Test-URI/pkg-descr
new file mode 100644
index 000000000000..4a25b077518e
--- /dev/null
+++ b/net/p5-Test-URI/pkg-descr
@@ -0,0 +1,3 @@
+Perl module for check various parts of Uniform Resource Locators.
+
+WWW: http://search.cpan.org/dist/Test-URI/
diff --git a/net/p5-Test-URI/pkg-plist b/net/p5-Test-URI/pkg-plist
new file mode 100644
index 000000000000..d6170de3d7c0
--- /dev/null
+++ b/net/p5-Test-URI/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/URI/.packlist
+%%SITE_PERL%%/Test/URI.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/URI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test