aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-09 14:53:25 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-09 14:53:25 +0000
commitc73857fa150902e008a918b4bb62baf45d9b2a92 (patch)
tree34ffbfbccc334399d61eddb7949400e5ca77160c /net
parent1d4c6669273e33f1d5cc7291751f89e56b52a830 (diff)
downloadports-c73857fa150902e008a918b4bb62baf45d9b2a92.tar.gz
ports-c73857fa150902e008a918b4bb62baf45d9b2a92.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/ipgrab/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/net/ipgrab/Makefile b/net/ipgrab/Makefile
index b8abeb92d18a..4d214199ffea 100644
--- a/net/ipgrab/Makefile
+++ b/net/ipgrab/Makefile
@@ -14,28 +14,25 @@ BUILD_DEPENDS= ${LOCALBASE}/include/pcap.h:${PORTSDIR}/net/libpcap
GNU_CONFIGURE= yes
USE_CSTD= gnu89
INFO= ipgrab
-MAN8= ipgrab.8
DOCS= README AUTHORS COPYING ChangeLog \
DEVELOPER-HOWTO INSTALL NEWS TODO
-PLIST_FILES= bin/ipgrab
+PLIST_FILES= bin/ipgrab man/man8/ipgrab.8.gz
PORTDOCS= README AUTHORS COPYING ChangeLog DEVELOPER-HOWTO \
INSTALL NEWS TODO
-NO_STAGE= yes
-
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
do-install:
- ${INSTALL_MAN} ${MAN8:S,^,${WRKSRC}/doc/,} ${MANPREFIX}/man/man8/
- ${INSTALL_DATA} ${WRKSRC}/doc/ipgrab.info ${PREFIX}/info/
- ${INSTALL_PROGRAM} ${WRKSRC}/src/ipgrab ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/doc/ipgrab.8 ${STAGEDIR}${MANPREFIX}/man/man8/
+ ${INSTALL_DATA} ${WRKSRC}/doc/ipgrab.info ${STAGEDIR}${PREFIX}/info/
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/ipgrab ${STAGEDIR}${PREFIX}/bin/
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
.endif
.include <bsd.port.mk>