aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-04-08 17:06:58 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-04-08 17:06:58 +0000
commitc7d659d4f8cf2176f6493156ce58b924d3f54e27 (patch)
tree3127f7082150094e9309b5366c5f5bbf47263a4c /net
parent5737569545341845c7e72042c21cc5407426ba12 (diff)
downloadports-c7d659d4f8cf2176f6493156ce58b924d3f54e27.tar.gz
ports-c7d659d4f8cf2176f6493156ce58b924d3f54e27.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/chrony/Makefile41
-rw-r--r--net/chrony/distinfo2
-rw-r--r--net/chrony/files/chronyd.in19
-rw-r--r--net/chrony/files/patch-examples-chrony.conf.example45
-rw-r--r--net/chrony/files/patch-examples-chrony.conf.example233
-rw-r--r--net/chrony/pkg-descr16
-rw-r--r--net/chrony/pkg-message5
-rw-r--r--net/chrony/pkg-plist10
9 files changed, 172 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index e7face3d8ecc..8d9a2b5be3a5 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -67,6 +67,7 @@
SUBDIR += cagibi
SUBDIR += callweaver
SUBDIR += ccxstream
+ SUBDIR += chrony
SUBDIR += citrix_ica
SUBDIR += clamz
SUBDIR += click
diff --git a/net/chrony/Makefile b/net/chrony/Makefile
new file mode 100644
index 000000000000..4e9c07d42836
--- /dev/null
+++ b/net/chrony/Makefile
@@ -0,0 +1,41 @@
+# Created by: Masaki TAGAWA <masaki@club.kyutech.ac.jp>
+# $FreeBSD$
+
+PORTNAME= chrony
+PORTVERSION= 1.29.1
+CATEGORIES= net
+MASTER_SITES= http://download.tuxfamily.org/chrony/
+
+MAINTAINER= masaki@club.kyutech.ac.jp
+COMMENT= System clock synchronization client and server
+
+LICENSE= GPLv2
+
+# XXX: should theoretically work on others, but at least on PowerPC it dies
+# with ``Could not open any NTP socket'' message :(
+ONLY_FOR_ARCHS= i386 amd64
+
+USES= gmake
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc --mandir=${MANPREFIX}/man \
+ --datarootdir=${DATADIR} --docdir=${DOCSDIR}
+USE_RC_SUBR= chronyd
+
+PORTDOCS= README chrony.txt
+
+# XXX: there are also other potentially useful options worth looking into:
+# --without-nss Don't use NSS even if it is available
+# --without-tomcrypt Don't use libtomcrypt even if it is available
+# --disable-pps Disable PPS API support
+OPTIONS_DEFINE= IPV6
+OPTIONS_DEFAULT= IPV6
+
+IPV6_CATEGORIES= ipv6
+IPV6_CONFIGURE_OFF= --disable-ipv6
+
+post-install:
+.for f in chrony.conf.example chrony.conf.example2 chrony.keys.example
+ ${INSTALL_DATA} ${WRKSRC}/examples/${f} ${STAGEDIR}${PREFIX}/etc
+.endfor
+
+.include <bsd.port.mk>
diff --git a/net/chrony/distinfo b/net/chrony/distinfo
new file mode 100644
index 000000000000..5a43c272e035
--- /dev/null
+++ b/net/chrony/distinfo
@@ -0,0 +1,2 @@
+SHA256 (chrony-1.29.1.tar.gz) = 658c9bb4d8c8d8ec7d0908429aa266e5f8413ba86bd4acbfd2f9669f6065af27
+SIZE (chrony-1.29.1.tar.gz) = 392889
diff --git a/net/chrony/files/chronyd.in b/net/chrony/files/chronyd.in
new file mode 100644
index 000000000000..21e18431747d
--- /dev/null
+++ b/net/chrony/files/chronyd.in
@@ -0,0 +1,19 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: chronyd
+# REQUIRE: DAEMON
+#
+
+. /etc/rc.subr
+
+name=chronyd
+rcvar=chronyd_enable
+command=%%PREFIX%%/sbin/${name}
+
+load_rc_config ${name}
+
+: ${chronyd_enable="NO"}
+
+run_rc_command "$1"
diff --git a/net/chrony/files/patch-examples-chrony.conf.example b/net/chrony/files/patch-examples-chrony.conf.example
new file mode 100644
index 000000000000..e2a7c21f36b0
--- /dev/null
+++ b/net/chrony/files/patch-examples-chrony.conf.example
@@ -0,0 +1,45 @@
+--- examples/chrony.conf.example.orig 2014-01-31 20:12:59 +0800
++++ examples/chrony.conf.example
+@@ -42,6 +42,13 @@
+ # Failing that, there are a lot of public NTP servers. There is a list
+ # you can access at http://support.ntp.org/bin/view/Servers/WebHome or
+ # you can use servers from the pool.ntp.org project.
++#
++# The option `iburst' is used for faster initial synchronization.
++
++server 0.freebsd.pool.ntp.org iburst
++server 1.freebsd.pool.ntp.org iburst
++server 2.freebsd.pool.ntp.org iburst
++#server 3.freebsd.pool.ntp.org iburst
+
+ ! server 0.pool.ntp.org iburst
+ ! server 1.pool.ntp.org iburst
+@@ -98,7 +105,7 @@ driftfile /var/lib/chrony/drift
+ # exchanges between cooperating machines.) Again, this option is
+ # assumed by default.
+
+-keyfile /etc/chrony.keys
++keyfile /usr/local/etc/chrony.keys
+
+ # Tell chronyd which numbered key in the file is used as the password
+ # for chronyc. (You can pick any integer up to 2**32-1. '1' is just a
+@@ -129,7 +136,7 @@ commandkey 1
+ # still running and bail out. If you want to change the path to the PID
+ # file, uncomment this line and edit it. The default path is shown.
+
+-! pidfile /var/run/chronyd.pid
++pidfile /var/run/chronyd.pid
+
+ #######################################################################
+ ### INITIAL CLOCK CORRECTION
+@@ -152,8 +159,8 @@ commandkey 1
+ # produce some graphs of your system's timekeeping performance, or you
+ # need help in debugging a problem.
+
+-! logdir /var/log/chrony
+-! log measurements statistics tracking
++logdir /var/log/chrony
++log measurements statistics tracking
+
+ # If you have real time clock support enabled (see below), you might want
+ # this line instead:
diff --git a/net/chrony/files/patch-examples-chrony.conf.example2 b/net/chrony/files/patch-examples-chrony.conf.example2
new file mode 100644
index 000000000000..c7ec6af9426f
--- /dev/null
+++ b/net/chrony/files/patch-examples-chrony.conf.example2
@@ -0,0 +1,33 @@
+--- examples/chrony.conf.example2.orig 2014-01-31 20:12:59 +0800
++++ examples/chrony.conf.example2
+@@ -1,9 +1,17 @@
+ # Use public servers from the pool.ntp.org project.
+ # Please consider joining the pool (http://www.pool.ntp.org/join.html).
+-server 0.pool.ntp.org iburst
+-server 1.pool.ntp.org iburst
+-server 2.pool.ntp.org iburst
+-server 3.pool.ntp.org iburst
++#
++# The option `iburst' is used for faster initial synchronization.
++#
++server 0.freebsd.pool.ntp.org iburst
++server 1.freebsd.pool.ntp.org iburst
++server 2.freebsd.pool.ntp.org iburst
++#server 3.freebsd.pool.ntp.org iburst
++
++#server 0.pool.ntp.org iburst
++#server 1.pool.ntp.org iburst
++#server 2.pool.ntp.org iburst
++#server 3.pool.ntp.org iburst
+
+ # Ignore stratum in source selection.
+ stratumweight 0
+@@ -28,7 +36,7 @@ bindcmdaddress ::1
+ # Serve time even if not synchronized to any NTP server.
+ #local stratum 10
+
+-keyfile /etc/chrony.keys
++keyfile /usr/local/etc/chrony.keys
+
+ # Specify the key used as password for chronyc.
+ commandkey 1
diff --git a/net/chrony/pkg-descr b/net/chrony/pkg-descr
new file mode 100644
index 000000000000..09c45739a2bb
--- /dev/null
+++ b/net/chrony/pkg-descr
@@ -0,0 +1,16 @@
+chrony is a pair of programs which are used to maintain the accuracy of the
+system clock on a computer; the two programs are called chronyd and chronyc.
+
+chronyd is a daemon which runs in background on the system. It obtains
+measurements via the network of the system clock's offset relative to time
+servers on other systems and adjusts the system time accordingly. For
+isolated systems, the user can periodically enter the correct time by hand
+(using chronyc). In either case, chronyd determines the rate at which the
+computer gains or loses time, and compensates for this. chronyd implements
+the NTP protocol and can act as either a client or a server.
+
+chronyc provides a user interface to chronyd for monitoring its performance
+and configuring various settings. It can do so while running on the same
+computer as the chronyd instance it is controlling or a different computer.
+
+WWW: http://chrony.tuxfamily.org/
diff --git a/net/chrony/pkg-message b/net/chrony/pkg-message
new file mode 100644
index 000000000000..f9d73bb93540
--- /dev/null
+++ b/net/chrony/pkg-message
@@ -0,0 +1,5 @@
+Unfortunately, this software has shameful history of several vulnerabilities
+previously discovered. FreeBSD Project cannot guarantee that this spree had
+come to an end. It is further complicated, as chronyd(8) requires superuser
+permissions to operate; please type ``make deinstall'' to deinstall the port
+if tight security is a concern.
diff --git a/net/chrony/pkg-plist b/net/chrony/pkg-plist
new file mode 100644
index 000000000000..eca8030645ac
--- /dev/null
+++ b/net/chrony/pkg-plist
@@ -0,0 +1,10 @@
+bin/chronyc
+etc/chrony.conf.example
+etc/chrony.conf.example2
+etc/chrony.keys.example
+man/man1/chrony.1.gz
+man/man1/chronyc.1.gz
+man/man5/chrony.conf.5.gz
+man/man8/chronyd.8.gz
+@mode 4755
+sbin/chronyd