aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-11 18:38:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-11 18:38:41 +0000
commit3221adb21b385c7a2bf877d37afa24516a154221 (patch)
treea7a475b51c49dc667146ce852afa2c67fb611b87 /net
parent754a2d44860aef3cffdb95c80128d788b0bbb8a5 (diff)
downloadports-3221adb21b385c7a2bf877d37afa24516a154221.tar.gz
ports-3221adb21b385c7a2bf877d37afa24516a154221.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/cvsupchk/Makefile39
-rw-r--r--net/cvsupchk/pkg-descr4
3 files changed, 44 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 12045fc189ad..d8dac687fcad 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -86,6 +86,7 @@
SUBDIR += cvsup
SUBDIR += cvsup-mirror
SUBDIR += cvsup-without-gui
+ SUBDIR += cvsupchk
SUBDIR += cvsync
SUBDIR += cyphesis
SUBDIR += danamics
diff --git a/net/cvsupchk/Makefile b/net/cvsupchk/Makefile
new file mode 100644
index 000000000000..c9035870de13
--- /dev/null
+++ b/net/cvsupchk/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: cvsupchk
+# Date created: 07 Nov 2005
+# Whom: matthias.andree@gmx.de
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvsupchk
+PORTVERSION= 19990209
+CATEGORIES= net
+DISTFILES=
+
+MAINTAINER= matthias.andree@gmx.de
+COMMENT= Check a CVSup directory hierarchy against the checkouts file
+
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/cvsup:extract
+
+PLIST_FILES= bin/cvsupchk
+PORTDOCS= *
+
+USE_PYTHON= yes
+
+.include <bsd.port.pre.mk>
+
+src!= cd ${PORTSDIR}/net/cvsup && make -V WRKSRC
+
+do-build:
+ ${MKDIR} ${WRKSRC}
+ ${SED} 's:^#!/usr/local/bin/python:#!${PYTHON_CMD}:' <${src}/contrib/cvsupchk/cvsupchk >${WRKSRC}/cvsupchk
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/cvsupchk ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${src}/contrib/cvsupchk/README ${DOCSDIR}/
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/cvsupchk/pkg-descr b/net/cvsupchk/pkg-descr
new file mode 100644
index 000000000000..bae2f56f769d
--- /dev/null
+++ b/net/cvsupchk/pkg-descr
@@ -0,0 +1,4 @@
+cvsupchk is a python script that checks a CVSup maintained directory hierarchy
+against the corresponding CVSup checkouts file. It looks for a number of
+anomalies: missing checked out files, deleted files being present, extra RCS
+files, 'dead' directories being present and so on.