aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-12-11 23:06:14 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-12-11 23:06:14 +0000
commita770b14f8eba194c3a5c77710f374934dd79647e (patch)
tree5de8c49af08f44b6ea5d1c155a465ef0a1ee884e /net
parent51ef8cc1d1e8ddb1cab31958938f4ca53f4632b7 (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/megatools/Makefile40
-rw-r--r--net/megatools/distinfo2
-rw-r--r--net/megatools/pkg-descr10
-rw-r--r--net/megatools/pkg-plist48
5 files changed, 101 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index c69dfce683aa..cbb2a3f3f9bc 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -355,6 +355,7 @@
SUBDIR += mcast-tools
SUBDIR += mediastreamer
SUBDIR += mediatomb
+ SUBDIR += megatools
SUBDIR += mgen
SUBDIR += micro_inetd
SUBDIR += micro_proxy
diff --git a/net/megatools/Makefile b/net/megatools/Makefile
new file mode 100644
index 000000000000..7b4fb3d2939f
--- /dev/null
+++ b/net/megatools/Makefile
@@ -0,0 +1,40 @@
+# Created by: Max V. Kostikov <max@kostikov.co>
+# $FreeBSD$
+
+PORTNAME= megatools
+PORTVERSION= 1.9.93
+CATEGORIES= net
+MASTER_SITES= http://megatools.megous.com/builds/
+
+MAINTAINER= max@kostikov.co
+COMMENT= Tools for MEGA.CO.NZ cloud drive
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+RUN_DEPENDS= glib-networking>=2.29.18:${PORTSDIR}/net/glib-networking
+
+USES= gmake pkgconfig libtool
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USE_GNOME= glib20
+USE_OPENSSL= yes
+
+LIBS+= -lssl -lcrypto
+
+INSTALL_TARGET= install-strip
+CONFIGURE_ARGS= --enable-introspection=no
+
+OPTIONS_DEFINE= FUSE
+OPTIONS_DEFAULT= FUSE
+OPTIONS_SUB= yes
+
+FUSE_USES= fuse
+FUSE_CONFIGURE_WITH= fuse
+
+post-patch:
+ @${REINPLACE_CMD} -e '/MEGA_REQUIRES=/ s|openssl||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|$$(prefix)/libdata/pkgconfig|' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/net/megatools/distinfo b/net/megatools/distinfo
new file mode 100644
index 000000000000..fd861749c1ac
--- /dev/null
+++ b/net/megatools/distinfo
@@ -0,0 +1,2 @@
+SHA256 (megatools-1.9.93.tar.gz) = 89d2d580bcda9e47a4ba47a734f2c7b06fd08d66797b5a64c02eba2ddf3da576
+SIZE (megatools-1.9.93.tar.gz) = 464353
diff --git a/net/megatools/pkg-descr b/net/megatools/pkg-descr
new file mode 100644
index 000000000000..24c4865c95be
--- /dev/null
+++ b/net/megatools/pkg-descr
@@ -0,0 +1,10 @@
+Megatools is a collection of programs for accessing Mega
+service from a command line of your desktop or server.
+
+Megatools allow you to copy individual files as well as
+entire directory trees to and from the cloud. You can also
+perform streaming downloads for example to preview videos
+and audio files, without needing to download the entire
+file.
+
+WWW: http://megatools.megous.com/
diff --git a/net/megatools/pkg-plist b/net/megatools/pkg-plist
new file mode 100644
index 000000000000..f83543364629
--- /dev/null
+++ b/net/megatools/pkg-plist
@@ -0,0 +1,48 @@
+bin/megadf
+bin/megadl
+%%FUSE%%bin/megafs
+bin/megaget
+bin/megals
+bin/megamkdir
+bin/megamv
+bin/megaput
+bin/megareg
+bin/megarm
+bin/megasync
+include/mega/mega-aes-ctr-encryptor.h
+include/mega/mega-aes-key.h
+include/mega/mega-chunked-cbc-mac.h
+include/mega/mega-enum-types.h
+include/mega/mega-http-client.h
+include/mega/mega-http-input-stream.h
+include/mega/mega-http-io-stream.h
+include/mega/mega-http-output-stream.h
+include/mega/mega-rsa-key.h
+include/mega/mega.h
+include/mega/megatypes.h
+include/mega/utils.h
+lib/libmega.a
+lib/libmega.so
+lib/libmega.so.0
+lib/libmega.so.0.0.0
+libdata/pkgconfig/libmega.pc
+man/man1/megadf.1.gz
+man/man1/megadl.1.gz
+%%FUSE%%man/man1/megafs.1.gz
+man/man1/megaget.1.gz
+man/man1/megals.1.gz
+man/man1/megamkdir.1.gz
+man/man1/megamv.1.gz
+man/man1/megaput.1.gz
+man/man1/megareg.1.gz
+man/man1/megarm.1.gz
+man/man1/megasync.1.gz
+man/man5/megarc.5.gz
+man/man7/megatools.7.gz
+%%PORTDOCS%%%%DOCSDIR%%/HACKING
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+share/gjs-1.0/mega.js