aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-02-01 22:59:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-02-01 22:59:59 +0000
commitf681f499c26e943dc9f428b3fc1f265d260379bc (patch)
treedf7a25c7f16c0b8b099c789e973b142d0e3888cb /net
parent6cc0afafb100afe8cea98ccbd64978435c0f218b (diff)
downloadports-f681f499c26e943dc9f428b3fc1f265d260379bc.tar.gz
ports-f681f499c26e943dc9f428b3fc1f265d260379bc.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/sipxregistry/Makefile41
-rw-r--r--net/sipxregistry/distinfo3
-rw-r--r--net/sipxregistry/files/patch-doc-Makefile.am11
-rw-r--r--net/sipxregistry/files/patch-doc-Makefile.in11
-rw-r--r--net/sipxregistry/files/pkg-deinstall.in19
-rw-r--r--net/sipxregistry/pkg-descr6
-rw-r--r--net/sipxregistry/pkg-plist20
8 files changed, 112 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index a07a86cecad0..edf8f047ac12 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -753,6 +753,7 @@
SUBDIR += sipxportlib
SUBDIR += sipxproxy
SUBDIR += sipxpublisher
+ SUBDIR += sipxregistry
SUBDIR += sipxtacklib
SUBDIR += sipxvxml
SUBDIR += sixxs-aiccu
diff --git a/net/sipxregistry/Makefile b/net/sipxregistry/Makefile
new file mode 100644
index 000000000000..073255c6107e
--- /dev/null
+++ b/net/sipxregistry/Makefile
@@ -0,0 +1,41 @@
+# Ports collection makefile for: sipxregistry
+# Date created: Jan 8, 2007
+# Whom: Michael Durian <durian@shadetreesoftware.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sipxregistry
+PORTVERSION= 3.6.0
+CATEGORIES= net
+MASTER_SITES= http://www.sipfoundry.org/pub/sipX/3.6/SRC/
+
+MAINTAINER= durian@shadetreesoftware.com
+COMMENT= sipX server for handling SIP UA registrations
+
+BUILD_DEPENDS= ginstall:${PORTSDIR}/sysutils/coreutils \
+ cppunit-config:${PORTSDIR}/devel/cppunit
+LIB_DEPENDS= sipXport:${PORTSDIR}/net/sipxportlib \
+ sipXtack:${PORTSDIR}/net/sipxtacklib \
+ sipXcommserver:${PORTSDIR}/net/sipxcommserverlib \
+ pcre.0:${PORTSDIR}/devel/pcre
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= autoconf:259:env automake:19:env
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+LOCALSTATEDIR=${DESTDIR}/var
+CONFIGURE_ENV+= wwwdir=${PREFIX}/www/sipX \
+ INSTALL=`which ginstall`
+CONFIGURE_ARGS+= --enable-sip-tls \
+ --prefix=${PREFIX} \
+ --localstatedir=${LOCALSTATEDIR}
+SUB_LIST= LOCALSTATEDIR=${LOCALSTATEDIR}
+SUB_FILES= pkg-deinstall
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipregistrar.sh.in
+
+.include <bsd.port.mk>
diff --git a/net/sipxregistry/distinfo b/net/sipxregistry/distinfo
new file mode 100644
index 000000000000..699da8de253a
--- /dev/null
+++ b/net/sipxregistry/distinfo
@@ -0,0 +1,3 @@
+MD5 (sipxregistry-3.6.0.tar.bz2) = 395fae8a0be2219fe9802fed4c45fe60
+SHA256 (sipxregistry-3.6.0.tar.bz2) = f2428839a3d13ec91fc2ba95cd3333c4626dabec09ec11601c206ce7b1ae2282
+SIZE (sipxregistry-3.6.0.tar.bz2) = 361982
diff --git a/net/sipxregistry/files/patch-doc-Makefile.am b/net/sipxregistry/files/patch-doc-Makefile.am
new file mode 100644
index 000000000000..830dc3e01865
--- /dev/null
+++ b/net/sipxregistry/files/patch-doc-Makefile.am
@@ -0,0 +1,11 @@
+--- Makefile.am.orgi Mon Jan 29 14:57:26 2007
++++ doc/Makefile.am Mon Jan 29 14:57:35 2007
+@@ -35,7 +35,7 @@
+ rm -rf $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ @INSTALL@ -d $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ find @PACKAGE@ -type f -print \
+- | xargs -i% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
++ | xargs -I% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
+
+ clean: clean-doc
+
diff --git a/net/sipxregistry/files/patch-doc-Makefile.in b/net/sipxregistry/files/patch-doc-Makefile.in
new file mode 100644
index 000000000000..e88f6db3aec2
--- /dev/null
+++ b/net/sipxregistry/files/patch-doc-Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orgi Mon Jan 29 14:57:16 2007
++++ doc/Makefile.in Mon Jan 29 14:57:48 2007
+@@ -479,7 +479,7 @@
+ rm -rf $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ @INSTALL@ -d $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ find @PACKAGE@ -type f -print \
+- | xargs -i% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
++ | xargs -I% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
+
+ clean: clean-doc
+
diff --git a/net/sipxregistry/files/pkg-deinstall.in b/net/sipxregistry/files/pkg-deinstall.in
new file mode 100644
index 000000000000..e1437d2e3f50
--- /dev/null
+++ b/net/sipxregistry/files/pkg-deinstall.in
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+PATH=/bin:/usr/sbin:/usr/bin:/usr/sbin
+
+LOCALSTATEDIR="%%LOCALSTATEDIR%%"
+
+post-deinstall() {
+ echo "WARNING: If you will *NOT* use this package anymore, please remove
+ the"
+ echo " following file manually:"
+ echo " ${LOCALSTATEDIR}/sipxdata/upgrade/sipxregistry-previous.tgz"
+ echo
+}
+
+case $2 in
+ POST-DEINSTALL)
+ post-deinstall
+ ;;
+esac
diff --git a/net/sipxregistry/pkg-descr b/net/sipxregistry/pkg-descr
new file mode 100644
index 000000000000..92794efa322f
--- /dev/null
+++ b/net/sipxregistry/pkg-descr
@@ -0,0 +1,6 @@
+sipXregistry is the registry/redirect server component of the sipX
+family. It shares a number of common components with the rest of the
+family, but can be used alone. It implements several powerful address
+mapping capabilities in addtion to supporting UAC registration.
+
+WWW: http://sipx-wiki.calivia.com/index.php/Main_Page
diff --git a/net/sipxregistry/pkg-plist b/net/sipxregistry/pkg-plist
new file mode 100644
index 000000000000..cf27da08d786
--- /dev/null
+++ b/net/sipxregistry/pkg-plist
@@ -0,0 +1,20 @@
+bin/sipregistrar
+bin/sipregistrar.sh
+bin/sipxregistry-config
+etc/sipxpbx/fallbackrules.xml.in
+etc/sipxpbx/mappingrules.xml.in
+etc/sipxpbx/process.d/sipregistrar.process.xml
+etc/sipxpbx/registrar-config.in
+include/registry/RegisterPlugin.h
+lib/libRegistrarImpliedMWI.a
+lib/libRegistrarImpliedMWI.la
+lib/libRegistrarImpliedMWI.so
+lib/libRegistrarImpliedMWI.so.1
+share/sipx/schema/alias.xsd
+share/sipx/schema/caller-alias.xsd
+share/sipx/schema/huntgroup.xsd
+@dirrm share/sipx/schema
+@dirrm share/sipx
+@dirrm include/registry
+@dirrm etc/sipxpbx/process.d
+@dirrm etc/sipxpbx