aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2005-02-18 19:03:22 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2005-02-18 19:03:22 +0000
commit1860d1b25a20007ff70521b319e7df6d5cb71031 (patch)
treeedca78327b4e3e96b11e9b95e29f3bbdaae6d4c5 /net
parent8bf909de6315ef809e36df9551251a0651e86746 (diff)
downloadports-1860d1b25a20007ff70521b319e7df6d5cb71031.tar.gz
ports-1860d1b25a20007ff70521b319e7df6d5cb71031.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/bindtest/Makefile28
-rw-r--r--net/bindtest/distinfo2
-rw-r--r--net/bindtest/pkg-descr3
-rw-r--r--net/bindtest/pkg-plist3
5 files changed, 37 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index e0ecb26b8894..95e8b2659514 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -41,6 +41,7 @@
SUBDIR += beacon
SUBDIR += beacon-server
SUBDIR += bfilter
+ SUBDIR += bindtest
SUBDIR += bing
SUBDIR += binkd
SUBDIR += blam
diff --git a/net/bindtest/Makefile b/net/bindtest/Makefile
new file mode 100644
index 000000000000..4dd03cdbc70a
--- /dev/null
+++ b/net/bindtest/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: bindtest
+# Date created: 2004-08-19
+# Whom: Janos Mohacsi <janos.mohacsi@bsd.hu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bindtest
+PORTVERSION= 1.56
+CATEGORIES= net ipv6
+MASTER_SITES= ftp://ftp.kame.net/pub/kame/misc/ \
+ ftp://sunsite.cnlab-switch.ch/mirror/kame/misc/ \
+ ftp://ftp.pasta.cs.uit.no/pub/IPv6/kame/misc/ \
+ ftp://ftp.ipv6.uni-leipzig.de/pub/ftp.kame.net/pub/kame/misc/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= Test bind() semantics of IPv6 sockets
+
+MAN1= bindtest.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bindtest ${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/test.sh ${PREFIX}/bin/bindtest.sh
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/net/bindtest/distinfo b/net/bindtest/distinfo
new file mode 100644
index 000000000000..c94edb5018b8
--- /dev/null
+++ b/net/bindtest/distinfo
@@ -0,0 +1,2 @@
+MD5 (bindtest.tgz) = 34da012b719dc07913197d9beea9e71b
+SIZE (bindtest.tgz) = 9569
diff --git a/net/bindtest/pkg-descr b/net/bindtest/pkg-descr
new file mode 100644
index 000000000000..bd61777bd91c
--- /dev/null
+++ b/net/bindtest/pkg-descr
@@ -0,0 +1,3 @@
+Test bind() semantics of IPv6 sockets.
+
+WWW: http://www.kame.net/newsletter/20010504/
diff --git a/net/bindtest/pkg-plist b/net/bindtest/pkg-plist
new file mode 100644
index 000000000000..5e9329b003e8
--- /dev/null
+++ b/net/bindtest/pkg-plist
@@ -0,0 +1,3 @@
+@comment $FreeBSD$
+bin/bindtest
+bin/bindtest.sh