aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-08-12 13:58:50 +0000
committerChris Rees <crees@FreeBSD.org>2011-08-12 13:58:50 +0000
commit231b57aaf4972a6287f68154e9513b2da0fa0f86 (patch)
treea354249908d75f93ea85189841e6685a4cb22deb /net
parentfb9dc5db380dfc7509c6b7024262b6a6004f014f (diff)
downloadports-231b57aaf4972a6287f68154e9513b2da0fa0f86.tar.gz
ports-231b57aaf4972a6287f68154e9513b2da0fa0f86.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/gini/Makefile5
-rw-r--r--net/gini/pkg-install37
2 files changed, 2 insertions, 40 deletions
diff --git a/net/gini/Makefile b/net/gini/Makefile
index 193e93346a3e..1ac6c1a7ed7f 100644
--- a/net/gini/Makefile
+++ b/net/gini/Makefile
@@ -21,13 +21,12 @@ USE_GNOME= glib12
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
+USERS= ${PORTNAME}
+GROUPS= ${USERS}
MAN1= ginicon.1 ginifeed.1
MAN8= gini.8
-pre-install:
- @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
post-install:
${INSTALL_SCRIPT} ${FILESDIR}/gini.sh.sample ${PREFIX}/etc/rc.d
.if !defined(NOPORTDOCS)
diff --git a/net/gini/pkg-install b/net/gini/pkg-install
deleted file mode 100644
index 1024c4cc7230..000000000000
--- a/net/gini/pkg-install
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh
-
-LOGDIR=/var/log/gini
-
-case $2 in
-PRE-INSTALL)
- USER=gini
- GROUP=${USER}
-
- if pw group show "${GROUP}" 2>/dev/null; then
- echo "You already have a group \"${GROUP}\", so I will use it."
- else
- if pw groupadd ${GROUP}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- exit 1
- fi
- fi
-
- if pw user show "${USER}" 2>/dev/null; then
- echo "You already have a user \"${USER}\", so I will use it."
- else
- if pw useradd ${USER} -g ${GROUP} -h - \
- -s /sbin/nologin -d /nonexistent -c 'GINI streaming server'
- then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- exit 1
- fi
- fi
-
- mkdir -p ${LOGDIR}
- chown -R gini:gini ${LOGDIR}
- ;;
-esac