aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-09-01 14:55:47 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-09-01 14:55:47 +0000
commit813f7318433d49808573454bc49bf99e3c2a5f93 (patch)
tree54832561656204ba7fdcbc78e15f39e3cc5d62e5 /net
parent862706673087fab50f9b50317405efe4cc3f2b3a (diff)
downloadports-813f7318433d49808573454bc49bf99e3c2a5f93.tar.gz
ports-813f7318433d49808573454bc49bf99e3c2a5f93.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/freerdp1/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/net/freerdp1/Makefile b/net/freerdp1/Makefile
index 56a2682c89df..887188b8e095 100644
--- a/net/freerdp1/Makefile
+++ b/net/freerdp1/Makefile
@@ -32,7 +32,9 @@ OPTIONS_DEFAULT= CUPS GSTREAMER X11
OPTIONS_SUB= yes
OPTIONS_DEFINE_armv6= NEON
+OPTIONS_DEFINE_armv7= NEON
OPTIONS_EXCLUDE_armv6= SSE
+OPTIONS_EXCLUDE_armv7= SSE
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
ALSA_CMAKE_BOOL= WITH_ALSA
@@ -67,11 +69,11 @@ X11_USE= xorg=x11,xkbfile,xcursor,xextproto,xv,xinerama,xext,xrandr,xi,xfixes,x
.include <bsd.port.pre.mk>
-.if ${OPSYS} == "FreeBSD" && ${ARCH} == "armv6"
+.if ${OPSYS} == FreeBSD && (${ARCH} == armv6 || ${ARCH} == armv7)
.if ${OSVERSION} < 1100500 || \
(${OSVERSION} >= 1100500 && ${OSVERSION} < 1100504) || \
(${OSVERSION} >= 1200000 && ${OSVERSION} < 1200008)
-BROKEN= Fails to build on ARMv6 (libm bug). See: r305380 (HEAD), r305971 (stable/11) [\#199422, \#211965] \
+BROKEN= Fails to build on ARMv6/7 (libm bug). See: r305380 (HEAD), r305971 (stable/11) [\#199422, \#211965] \
Please update to a later (fixed) version.
.endif
.endif