aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-10-17 21:30:33 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-10-17 21:30:33 +0000
commit97ed3d8e12181d8bd871ed3653fdf2e8a14dfbc1 (patch)
treedc82761ea9e8fbecaa4f2aaa032789d93b75d2ac /net
parent4ab3087fc455b76e28c8c9ecc47f71aa3f39956a (diff)
downloadports-97ed3d8e12181d8bd871ed3653fdf2e8a14dfbc1.tar.gz
ports-97ed3d8e12181d8bd871ed3653fdf2e8a14dfbc1.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/gaim-snapshot/Makefile1
-rw-r--r--net/gaim-snapshot/files/patch-src_buddy.c17
-rw-r--r--net/gaim/Makefile1
-rw-r--r--net/gaim/files/patch-src_buddy.c17
4 files changed, 36 insertions, 0 deletions
diff --git a/net/gaim-snapshot/Makefile b/net/gaim-snapshot/Makefile
index 050e635bb70c..9baabaa753d7 100644
--- a/net/gaim-snapshot/Makefile
+++ b/net/gaim-snapshot/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gaim
PORTVERSION= 0.59.5
+PORTREVISION= 1
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net/gaim-snapshot/files/patch-src_buddy.c b/net/gaim-snapshot/files/patch-src_buddy.c
new file mode 100644
index 000000000000..e2d13a254362
--- /dev/null
+++ b/net/gaim-snapshot/files/patch-src_buddy.c
@@ -0,0 +1,17 @@
+--- src/buddy.c.orig Thu Oct 17 12:11:51 2002
++++ src/buddy.c Thu Oct 17 16:58:49 2002
+@@ -2231,7 +2231,13 @@
+ if (blist_options & OPT_BLIST_SHOW_IDLETIME)
+ gtk_widget_show(bs->idle);
+
+- style = gtk_style_copy( gtk_rc_get_style(bs->label) );
++ if (gtk_rc_get_style(bs->label) != NULL) {
++ style = gtk_style_copy( gtk_rc_get_style(bs->label) );
++ } else {
++ style = gtk_style_new();
++ gdk_font_unref(gtk_style_get_font(style));
++ gtk_style_set_font(style, gdk_font_ref(gtk_style_get_font(bs->label->style)));
++ }
+ for (i = 0; i < 5; i++)
+ style->fg[i] = bs->idle->style->fg[i];
+ if ((blist_options & OPT_BLIST_GREY_IDLERS) && (b->idle)) {
diff --git a/net/gaim/Makefile b/net/gaim/Makefile
index 050e635bb70c..9baabaa753d7 100644
--- a/net/gaim/Makefile
+++ b/net/gaim/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gaim
PORTVERSION= 0.59.5
+PORTREVISION= 1
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net/gaim/files/patch-src_buddy.c b/net/gaim/files/patch-src_buddy.c
new file mode 100644
index 000000000000..e2d13a254362
--- /dev/null
+++ b/net/gaim/files/patch-src_buddy.c
@@ -0,0 +1,17 @@
+--- src/buddy.c.orig Thu Oct 17 12:11:51 2002
++++ src/buddy.c Thu Oct 17 16:58:49 2002
+@@ -2231,7 +2231,13 @@
+ if (blist_options & OPT_BLIST_SHOW_IDLETIME)
+ gtk_widget_show(bs->idle);
+
+- style = gtk_style_copy( gtk_rc_get_style(bs->label) );
++ if (gtk_rc_get_style(bs->label) != NULL) {
++ style = gtk_style_copy( gtk_rc_get_style(bs->label) );
++ } else {
++ style = gtk_style_new();
++ gdk_font_unref(gtk_style_get_font(style));
++ gtk_style_set_font(style, gdk_font_ref(gtk_style_get_font(bs->label->style)));
++ }
+ for (i = 0; i < 5; i++)
+ style->fg[i] = bs->idle->style->fg[i];
+ if ((blist_options & OPT_BLIST_GREY_IDLERS) && (b->idle)) {