aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2019-02-28 20:12:38 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2019-02-28 20:12:38 +0000
commit040096a5e2077d9bbb53646175989aefcbd70e3a (patch)
tree8dbb020e77bc70911361e3c13808af44546ec4d6 /net
parent32e2b763b13357b3ed475e39e4eec3a614ce95ab (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/wireguard/Makefile1
-rw-r--r--net/wireguard/files/patch-wg-quick_freebsd.bash31
2 files changed, 32 insertions, 0 deletions
diff --git a/net/wireguard/Makefile b/net/wireguard/Makefile
index 8491e0af09a1..7eb96aefa859 100644
--- a/net/wireguard/Makefile
+++ b/net/wireguard/Makefile
@@ -2,6 +2,7 @@
PORTNAME= wireguard
PORTVERSION= 0.0.20190227
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://git.zx2c4.com/WireGuard/snapshot/
DISTNAME= WireGuard-${PORTVERSION}
diff --git a/net/wireguard/files/patch-wg-quick_freebsd.bash b/net/wireguard/files/patch-wg-quick_freebsd.bash
new file mode 100644
index 000000000000..1a3da59f7343
--- /dev/null
+++ b/net/wireguard/files/patch-wg-quick_freebsd.bash
@@ -0,0 +1,31 @@
+From cba99f16a4ec9a229358ce1ed96080bd5ae04a7e Mon Sep 17 00:00:00 2001
+From: "Jason A. Donenfeld" <Jason@zx2c4.com>
+Date: Thu, 28 Feb 2019 19:03:11 +0100
+Subject: wg-quick: freebsd: rebreak interface loopback, while fixing localhost
+
+The commit 7c833642 ("wg-quick: freebsd: allow loopback to work") was
+supposed to make things better, but actually it just started sending
+legitimate localhost traffic over the WireGuard interface, which is
+really quite bad.
+
+This reverts commit 7c833642dfa342218602ab18e7091e86408d2982.
+---
+ src/tools/wg-quick/freebsd.bash | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/tools/wg-quick/freebsd.bash b/src/tools/wg-quick/freebsd.bash
+index 93f1a3b7..e83dbef0 100755
+--- wg-quick/freebsd.bash
++++ wg-quick/freebsd.bash
+@@ -158,7 +158,7 @@ add_addr() {
+ if [[ $1 == *:* ]]; then
+ cmd ifconfig "$INTERFACE" inet6 "$1" alias
+ else
+- cmd ifconfig "$INTERFACE" inet "$1" 127.0.0.1 alias
++ cmd ifconfig "$INTERFACE" inet "$1" "${1%%/*}" alias
+ fi
+ }
+
+--
+cgit v1.2.1-20-gc37e
+