aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-18 18:57:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-18 18:57:11 +0000
commit18733b2e0e89771b9a0edd7a0e8b3b3ca86459dd (patch)
tree3dcc51080cdc1de8ed29605c51c38ea593db2045 /net
parent300aa08dd8e31cce3c6a11bb35d51a0dfb4ae7c9 (diff)
downloadports-18733b2e0e89771b9a0edd7a0e8b3b3ca86459dd.tar.gz
ports-18733b2e0e89771b9a0edd7a0e8b3b3ca86459dd.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/bcusdk-eibd/Makefile6
-rw-r--r--net/bcusdk-eibd/files/patch-eibd_libserver_eibnetip.cpp11
2 files changed, 9 insertions, 8 deletions
diff --git a/net/bcusdk-eibd/Makefile b/net/bcusdk-eibd/Makefile
index b03ec7ae9b31..7292176d4a9a 100644
--- a/net/bcusdk-eibd/Makefile
+++ b/net/bcusdk-eibd/Makefile
@@ -25,9 +25,9 @@ CONFIGURE_ARGS+=--enable-onlyeibd \
--enable-eibnetip \
--enable-eibnetipserver \
--enable-eibnetiptunnel \
- --enable-groupcache
-CPPFLAGS= "-I${LOCALBASE}/include -L${LOCALBASE}/lib"
-CFLAGS= "-I${LOCALBASE}/include -L${LOCALBASE}/lib ${CFLAGS}"
+ --enable-groupcache \
+ CPPFLAGS="-I${LOCALBASE}/include -L${LOCALBASE}/lib" \
+ CFLAGS="-I${LOCALBASE}/include -L${LOCALBASE}/lib ${CFLAGS}"
OPTIONS= JAVA "Install Java client library" off \
EXAMPLES "Install example client applications" on
diff --git a/net/bcusdk-eibd/files/patch-eibd_libserver_eibnetip.cpp b/net/bcusdk-eibd/files/patch-eibd_libserver_eibnetip.cpp
index 1c587e906ea7..4d9c3f20f4c3 100644
--- a/net/bcusdk-eibd/files/patch-eibd_libserver_eibnetip.cpp
+++ b/net/bcusdk-eibd/files/patch-eibd_libserver_eibnetip.cpp
@@ -1,5 +1,5 @@
--- eibd/libserver/eibnetip.cpp.orig Thu Nov 8 16:31:33 2007
-+++ eibd/libserver/eibnetip.cpp Tue Dec 11 10:11:47 2007
++++ eibd/libserver/eibnetip.cpp Tue Dec 18 14:36:10 2007
@@ -17,11 +17,9 @@
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
@@ -32,7 +32,7 @@
sock->sin_family = h->h_addrtype;
sock->sin_addr.s_addr = (*((unsigned long *) h->h_addr_list[0]));
return 1;
-@@ -144,6 +148,53 @@
+@@ -144,6 +148,54 @@
}
#endif
@@ -73,6 +73,7 @@
+ struct sockaddr *sa = (struct sockaddr *) cp;
+ if (i == RTA_IFA)
+ {
++ src->sin_len = sizeof (*src);
+ src->sin_family = AF_INET;
+ src->sin_addr.s_addr = ((struct sockaddr_in *)sa)->sin_addr.s_addr;
+ return 1;
@@ -86,7 +87,7 @@
EIBNetIPPacket::EIBNetIPPacket ()
{
service = 0;
-@@ -208,6 +259,7 @@
+@@ -208,6 +260,7 @@
return 1;
ip = (buf[2] << 24) | (buf[3] << 16) | (buf[4] << 8) | (buf[5]);
port = (buf[6] << 8) | (buf[7]);
@@ -94,7 +95,7 @@
a->sin_family = AF_INET;
a->sin_port = htons (port);
a->sin_addr.s_addr = htonl (ip);
-@@ -254,7 +306,7 @@
+@@ -254,7 +307,7 @@
if (fd != -1)
{
if (multicast)
@@ -103,7 +104,7 @@
close (fd);
}
}
-@@ -265,7 +317,7 @@
+@@ -265,7 +318,7 @@
if (multicast)
throw Exception (DEV_OPEN_FAIL);
maddr = multicastaddr;