aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2011-11-01 07:10:07 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2011-11-01 07:10:07 +0000
commit44c1cfa9de944bd02202bb2191802f2d713aa239 (patch)
tree3979d366287558bfb85769e2b23e14126e1ab8e7 /net
parent467720cf409afb961f078ae7ef00341de59af5c1 (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-tweepy/Makefile22
-rw-r--r--net/py-tweepy/distinfo2
-rw-r--r--net/py-tweepy/pkg-descr4
4 files changed, 29 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 1e994accede9..626fb0227042 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -885,6 +885,7 @@
SUBDIR += py-spreadmodule
SUBDIR += py-suds
SUBDIR += py-tofu
+ SUBDIR += py-tweepy
SUBDIR += py-twistedPair
SUBDIR += py-twitter
SUBDIR += py-txamqp
diff --git a/net/py-tweepy/Makefile b/net/py-tweepy/Makefile
new file mode 100644
index 000000000000..eed93e390b7e
--- /dev/null
+++ b/net/py-tweepy/Makefile
@@ -0,0 +1,22 @@
+# Ports collection makefile for: py-tweepy
+# Date created: Tue Nov 1 14:27:14 CST 2011
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tweepy
+PORTVERSION= 1.8
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= A library for accessing the Twitter.com API
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.mk>
diff --git a/net/py-tweepy/distinfo b/net/py-tweepy/distinfo
new file mode 100644
index 000000000000..9a62d8cf7c37
--- /dev/null
+++ b/net/py-tweepy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tweepy-1.8.tar.gz) = 8492f2e8ee5055b8fe6f075fdf2ff4a3396efe5458053f0a5e8632f1202ac2bb
+SIZE (tweepy-1.8.tar.gz) = 21393
diff --git a/net/py-tweepy/pkg-descr b/net/py-tweepy/pkg-descr
new file mode 100644
index 000000000000..8f474fdf7901
--- /dev/null
+++ b/net/py-tweepy/pkg-descr
@@ -0,0 +1,4 @@
+A Python library for accessing the Twitter.com API.
+Supports OAuth, covers the entire API, and streaming API.
+
+WWW: https://github.com/tweepy/tweepy