aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-07-22 03:26:34 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-07-22 03:26:34 +0000
commit45a0048d648a0494f26cd232aa2a8357ea8580bc (patch)
treeaf044c02e9409857f30dedf2877989acd710e917 /net
parenta5989a768f803d80de5ba0d0e7a3f342f5dd4e33 (diff)
net/py-libnet: Update to 3.0rc1, Remove/fix BROKEN_*
Switch port to use autoplist to preclude having to manually construct shared library names based on ARCH/uname manipulations. While I'm here: - Switch to latest upstream release: 3.0rc1, via CHEESESHOP - Remove patch that was fixed upstream [1] - Match COMMENT to setup.py:description - Strip shared library [1] https://github.com/allfro/pylibnet/commit/67cd7b84179def8b7d88ce1456dec3984aa9ea59 Reviewed by: loader, sbz Approved by: sbz (maintainer) Tested by: loader (armv6, armv7, aarch64, mips64) MFH: 2019Q3 (blanket(s): bugfix releases, bugfixes) Differential Revision: D20754
Notes
Notes: svn path=/head/; revision=507127
Diffstat (limited to 'net')
-rw-r--r--net/py-libnet/Makefile32
-rw-r--r--net/py-libnet/distinfo5
-rw-r--r--net/py-libnet/files/patch-src__builders.c15
-rw-r--r--net/py-libnet/pkg-descr2
-rw-r--r--net/py-libnet/pkg-plist1
5 files changed, 12 insertions, 43 deletions
diff --git a/net/py-libnet/Makefile b/net/py-libnet/Makefile
index 6c619be9b7cf..9ae5ae591198 100644
--- a/net/py-libnet/Makefile
+++ b/net/py-libnet/Makefile
@@ -2,49 +2,33 @@
# $FreeBSD$
PORTNAME= libnet
-PORTVERSION= 1.1
-PORTREVISION= 3
+DISTVERSION= 3.0rc1
CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pylibnet-${DISTVERSION}
MAINTAINER= sbz@FreeBSD.org
-COMMENT= Python module for the libnet packet construction library
+COMMENT= Python extension for the Libnet packet injection library
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libnet.so:net/libnet
-BROKEN_aarch64= fails to package: lib.freebsd-11.0-RELEASE-p1-aarch64-2.7/libnet.so: No such file or directory
-BROKEN_armv6= fails to package: lib.freebsd-11.0-RELEASE-p1-armv6-2.7/libnet.so: No such file or directory
-BROKEN_armv7= fails to package: lib.freebsd-11.0-RELEASE-p1-armv7-2.7/libnet.so: No such file or directory
-BROKEN_mips64= fails to package: lib.freebsd-11.0-RELEASE-p1-mips64-2.7/libnet.so: No such file or directory
-
USES= python:-2.7
-USE_PYTHON= distutils pythonprefix
-
-USE_GITHUB= yes
-GH_ACCOUNT= allfro
-GH_PROJECT= pylibnet
-GH_TAGNAME= b2fa552
-
-EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+USE_PYTHON= autoplist concurrent distutils
OPTIONS_DEFINE= EXAMPLES
-LIBNET_ARCH= ${ARCH:S/powerpc64/powerpc/}
-OSVER= uname -r
post-patch:
@${REINPLACE_CMD} 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/setup.py
-do-install:
- ${MKDIR} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
- ${INSTALL_LIB} \
- ${WRKSRC}/build/lib.${OPSYS:tl}-$$(${OSVER})-${LIBNET_ARCH}-${PYTHON_VER}/${PORTNAME}.so \
- ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
-
do-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/libnet.so
+
.include <bsd.port.mk>
diff --git a/net/py-libnet/distinfo b/net/py-libnet/distinfo
index c09b56b07906..3a8d0940b72d 100644
--- a/net/py-libnet/distinfo
+++ b/net/py-libnet/distinfo
@@ -1,2 +1,3 @@
-SHA256 (allfro-pylibnet-1.1-b2fa552_GH0.tar.gz) = a9cc100ea911edcc45144df41c7a7783db64e03cb2cb664b06258657b418aed9
-SIZE (allfro-pylibnet-1.1-b2fa552_GH0.tar.gz) = 73736
+TIMESTAMP = 1561462994
+SHA256 (pylibnet-3.0rc1.tar.gz) = 9fc2b9190bce2ce42ab6569debe41f4ff94824fa2447da8044b1a8097ba9cc5a
+SIZE (pylibnet-3.0rc1.tar.gz) = 75395
diff --git a/net/py-libnet/files/patch-src__builders.c b/net/py-libnet/files/patch-src__builders.c
deleted file mode 100644
index 4b49fd685f3d..000000000000
--- a/net/py-libnet/files/patch-src__builders.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- ./src/builders.c.orig 2014-05-30 12:55:10.000000000 +0200
-+++ ./src/builders.c 2014-05-30 13:00:15.000000000 +0200
-@@ -722,9 +722,9 @@
- u_int16_t sum = 0;
- u_int16_t id = PYLIBNET_RANDOM_U16;
- u_int16_t seq = PYLIBNET_RANDOM_U16;
-- n_time otime = PYLIBNET_RANDOM_U32;
-- n_time rtime = PYLIBNET_RANDOM_U32;
-- n_time ttime = PYLIBNET_RANDOM_U32;
-+ u_int32_t otime = PYLIBNET_RANDOM_U32;
-+ u_int32_t rtime = PYLIBNET_RANDOM_U32;
-+ u_int32_t ttime = PYLIBNET_RANDOM_U32;
- u_int8_t *payload = NULL;
- u_int32_t payload_s = 0;
- libnet_ptag_t ptag = 0;
diff --git a/net/py-libnet/pkg-descr b/net/py-libnet/pkg-descr
index 8bf2a18feaba..35924eff280b 100644
--- a/net/py-libnet/pkg-descr
+++ b/net/py-libnet/pkg-descr
@@ -1,3 +1,3 @@
Python module for the libnet packet construction library
-WWW: http://pylibnet.sourceforge.net/
+WWW: https://pylibnet.sourceforge.net/
diff --git a/net/py-libnet/pkg-plist b/net/py-libnet/pkg-plist
index 6374676e7761..ab73aca40b3e 100644
--- a/net/py-libnet/pkg-plist
+++ b/net/py-libnet/pkg-plist
@@ -1,4 +1,3 @@
-%%PYTHON_SITELIBDIR%%/libnet.so
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dnsv4.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/icmp4echo.py