aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-05 12:51:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-05 12:51:05 +0000
commit91cb18c6037b48b4c87983855f80550fcc574178 (patch)
tree413f7b40f311ee16bcc0b96d6884ec01be654394 /net
parenteae6ba083dffd03d27a1b3dfd1fd2a9f263bf9d2 (diff)
downloadports-91cb18c6037b48b4c87983855f80550fcc574178.tar.gz
ports-91cb18c6037b48b4c87983855f80550fcc574178.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/asterisk14-addons/Makefile13
-rw-r--r--net/asterisk14/Makefile64
-rw-r--r--net/bcusdk-eibd/Makefile21
-rw-r--r--net/bird-devel/Makefile5
-rw-r--r--net/c3270/Makefile75
-rw-r--r--net/callweaver/Makefile56
-rw-r--r--net/csync2/Makefile13
-rw-r--r--net/ekiga/Makefile18
-rw-r--r--net/freedbd/Makefile12
-rw-r--r--net/fspd/Makefile13
-rw-r--r--net/hawknl-devel/Makefile12
-rw-r--r--net/hawknl/Makefile12
12 files changed, 141 insertions, 173 deletions
diff --git a/net/asterisk14-addons/Makefile b/net/asterisk14-addons/Makefile
index 41fea6e8e2a6..c953ca541a06 100644
--- a/net/asterisk14-addons/Makefile
+++ b/net/asterisk14-addons/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: asterisk-addons
-# Date created: 23 March 2006
-# Whom: Fabian Gast <fgast@only640k.org>
-#
+# Created by: Fabian Gast <fgast@only640k.org>
# $FreeBSD$
-#
PORTNAME= asterisk14
PORTVERSION= 1.4.13
@@ -20,7 +16,8 @@ COMMENT= GPL modules for the Asterisk Open Source PBX
BUILD_DEPENDS= asterisk:${PORTSDIR}/net/asterisk14
RUN_DEPENDS= asterisk:${PORTSDIR}/net/asterisk14
-OPTIONS= SAMPLE_CONFIG "Install sample configuration files" off
+OPTIONS_DEFINE= SAMPLE_CONFIG
+SAMPLE_CONFIG_DESC= Install sample configuration files
ONLY_FOR_ARCHS= i386 amd64 powerpc
USE_AUTOTOOLS= libtool
@@ -30,7 +27,7 @@ GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
-.if defined(WITH_SAMPLE_CONFIG)
+.if ${PORT_OPTIONS:MSAMPLE_CONFIG}
PLIST_SUB+= SAMPLE_CONFIG=""
.else
PLIST_SUB+= SAMPLE_CONFIG="@comment "
@@ -43,7 +40,7 @@ pre-configure:
fi
post-install:
-.if defined(WITH_SAMPLE_CONFIG)
+.if ${PORT_OPTIONS:MSAMPLE_CONFIG}
@cd ${WRKSRC} && ${GMAKE} samples
.endif
diff --git a/net/asterisk14/Makefile b/net/asterisk14/Makefile
index 6674a712dd3c..e4e498bb66bc 100644
--- a/net/asterisk14/Makefile
+++ b/net/asterisk14/Makefile
@@ -40,18 +40,19 @@ MAKE_ENV= MKDIR="${MKDIR}" \
MAN8= asterisk.8 astgenkey.8 autosupport.8 safe_asterisk.8
CONFLICTS= asterisk*-1.2* asterisk*-1.6* asterisk*-1.8*
-OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
- ODBC "Enable ODBC support" on \
- POSTGRES "Enable PostgreSQL support" on \
- RADIUS "Enable RADIUS accounting support" on \
- SNMP "Enable SNMP support" on \
- H323 "Enable H.323 support" on \
- FREETDS "Enable FreeTDS support" on \
- JABBER "Enable Jabber and Gtalk support" on \
- SQLITE "Enable SQLITE support" on \
- CODEC_PATCH "Apply codec negotiation patch" off \
- ILBC "Enable iLBC codec" off \
- MISC_PATCHES "Apply additional patches" off
+OPTIONS_DEFINE= VORBIS ODBC PGSQL RADIUS SNMP H323 FREETDS JABBER SQLITE \
+ CODEC_PATCH ILBC MISC_PATCHES
+OPTIONS_DEFAULT= VORBIS ODBC PGSQL RADIUS SNMP H323 FREETFS JABBER SQLITE
+MISC_PATCHES_DESC= Apply additional patches
+ILBC_DESC= iLBC codec
+DAHDI_DESC= DAHDI support
+
+OPTIONS_DEFINE_i386= DAHDI
+OPTIONS_DEFAULT_i386= DAHDI
+OPTIONS_DEFINE_amd64= DAHDI
+OPTIONS_DEFAULT_amd64= DAHDI
+OPTIONS_DEFINE_sparc64= DAHDI
+OPTIONS_DEFAULT_sparc64= DAHDI
.include <bsd.port.pre.mk>
@@ -59,14 +60,7 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
CONFIGURE_ARGS+=--localstatedir=/var
.endif
-.if ${ARCH} == "i386" || ${ARCH} == "amd64" || ${ARCH} == "sparc64"
-OPTIONS+= DAHDI "Enable DAHDI support" on
-
-# Include this since we have altered OPTIONS.
-.include <bsd.port.options.mk>
-.endif
-
-.if !defined(WITH_H323)
+.if ! ${PORT_OPTIONS:MH323}
PLIST_SUB+= WITH_H323="@comment "
CONFIGURE_ARGS+= --without-h323
.else
@@ -76,7 +70,7 @@ LIB_DEPENDS+= pt_r.1:${PORTSDIR}/devel/pwlib \
h323_r.1:${PORTSDIR}/net/openh323
.endif
-.if !defined(WITH_DAHDI)
+.if ! ${PORT_OPTIONS:MDAHDI}
PLIST_SUB+= WITH_DAHDI="@comment "
CONFIGURE_ARGS+= --without-dahdi
.else
@@ -91,7 +85,7 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/dahdi/dahdi.ko:${PORTSDIR}/misc/dahdi-kmod
#
# WITH_FREETDS, WITH_PGSQL and WITH_SQLITE can also be added to MAKE_ENV
# similarly
-.if !defined(WITH_ODBC)
+.if ! ${PORT_OPTIONS:MODBC}
PLIST_SUB+= WITH_ODBC="@comment "
CONFIGURE_ARGS+= --without-odbc
.else
@@ -101,7 +95,7 @@ USE_AUTOTOOLS+= libltdl
LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
.endif
-.if !defined(WITH_FREETDS)
+.if ! ${PORT_OPTIONS:MFREETDS}
PLIST_SUB+= WITH_FREETDS="@comment "
CONFIGURE_ARGS+= --without-tds
.else
@@ -110,7 +104,7 @@ CONFIGURE_ARGS+= --with-tds=${LOCALBASE}
LIB_DEPENDS+= tds.5:${PORTSDIR}/databases/freetds
.endif
-.if !defined(WITH_POSTGRES)
+.if ! ${PORT_OPTIONS:MPGSQL}
PLIST_SUB+= WITH_POSTGRES="@comment "
CONFIGURE_ARGS+= --without-postgres
.else
@@ -119,16 +113,16 @@ USE_PGSQL= yes
CONFIGURE_ARGS+= --with-postgres
.endif
-.if !defined(WITH_OGGVORBIS)
-PLIST_SUB+= WITH_OGGVORBIS="@comment "
+.if ! ${PORT_OPTIONS:MVORBIS}
+PLIST_SUB+= WITH_VORBIS="@comment "
CONFIGURE_ARGS+= --without-ogg
.else
-PLIST_SUB+= WITH_OGGVORBIS=""
+PLIST_SUB+= WITH_VORBIS=""
CONFIGURE_ARGS+= --with-ogg
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
.endif
-.if !defined(WITH_RADIUS)
+.if ! ${PORT_OPTIONS:MRADIUS}
PLIST_SUB+= WITH_RADIUS="@comment "
CONFIGURE_ARGS+= --without-radius
.else
@@ -137,7 +131,7 @@ CONFIGURE_ARGS+= --with-radius
LIB_DEPENDS+= radiusclient-ng.2:${PORTSDIR}/net/radiusclient
.endif
-.if !defined(WITH_SNMP)
+.if ! ${PORT_OPTIONS:MSNMP}
PLIST_SUB+= WITH_SNMP="@comment "
CONFIGURE_ARGS+= --without-netsnmp
.else
@@ -146,7 +140,7 @@ CONFIGURE_ARGS+= --with-netsnmp
LIB_DEPENDS+= netsnmp:${PORTSDIR}/net-mgmt/net-snmp
.endif
-.if !defined(WITH_JABBER)
+.if ! ${PORT_OPTIONS:MJABBER}
PLIST_SUB+= WITH_JABBER="@comment "
CONFIGURE_ARGS+= --without-iksemel
.else
@@ -155,7 +149,7 @@ CONFIGURE_ARGS+= --with-iksemel
LIB_DEPENDS+= iksemel.4:${PORTSDIR}/textproc/iksemel
.endif
-.if !defined(WITH_SQLITE)
+.if ! ${PORT_OPTIONS:MSQLITE}
PLIST_SUB+= WITH_SQLITE="@comment "
CONFIGURE_ARGS+= --without-sqlite
.else
@@ -164,14 +158,14 @@ CONFIGURE_ARGS+= --with-sqlite
LIB_DEPENDS+= sqlite:${PORTSDIR}/databases/sqlite2
.endif
-.if !defined(WITH_ILBC)
+.if ! ${PORT_OPTIONS:MILBC}
PLIST_SUB+= WITH_ILBC="@comment "
.else
PLIST_SUB+= WITH_ILBC=""
EXTRA_PATCHES+= ${PATCHDIR}/ilbc_enable.diff
.endif
-.if defined(WITH_CODEC_PATCH)
+.if ${PORT_OPTIONS:MCODEC_PATCH}
PATCHFILES= asterisk-1.4.42-codec-negotiation-20111017.diff.gz
PATCH_SITES= ${MASTER_SITE_LOCAL}
PATCH_SITE_SUBDIR= fjoe/
@@ -180,11 +174,11 @@ EXTRA_PATCHES+= ${PATCHDIR}/codecnego-patch-Makefile
EXTRA_PATCHES+= ${PATCHDIR}/nocodecnego-patch-Makefile
.endif
-.if defined(WITH_MISC_PATCHES)
+.if ${PORT_OPTIONS:MMISC_PATCHES}
EXTRA_PATCHES+= ${PATCHDIR}/dtmf_debug.diff
EXTRA_PATCHES+= ${PATCHDIR}/sip_force_callid.diff
EXTRA_PATCHES+= ${PATCHDIR}/sip_set_auth.diff
-.if defined(WITH_CODEC_PATCH)
+.if ${PORT_OPTIONS:MCODEC_PATCH}
EXTRA_PATCHES+= ${PATCHDIR}/rtp_force_dtmf-codecnego.diff
.else
EXTRA_PATCHES+= ${PATCHDIR}/rtp_force_dtmf-nocodecnego.diff
diff --git a/net/bcusdk-eibd/Makefile b/net/bcusdk-eibd/Makefile
index f2c37fd0fdf2..911ebfbec5ff 100644
--- a/net/bcusdk-eibd/Makefile
+++ b/net/bcusdk-eibd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bcusdk-eibd
-# Date Created: 6 December 2007
-# Whom: Björn König <bkoenig@alpha-tierchen.de>
-#
+# Created by: Björn König <bkoenig@alpha-tierchen.de>
# $FreeBSD$
-#
PORTNAME= bcusdk
PORTVERSION= 0.0.4
@@ -29,12 +25,11 @@ CONFIGURE_ARGS+=--enable-onlyeibd \
CPPFLAGS="-I${LOCALBASE}/include -L${LOCALBASE}/lib" \
CFLAGS="-I${LOCALBASE}/include -L${LOCALBASE}/lib ${CFLAGS}"
-OPTIONS= JAVA "Install Java client library" off \
- EXAMPLES "Install example client applications" on
+OPTIONS_DEFINE= JAVA EXAMPLES
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_JAVA)
+.if ${PORT_OPTIONS:MJAVA}
CONFIGURE_ARGS+=--enable-java
USE_JAVA= yes
PLIST_SUB+= JAVA=""
@@ -42,7 +37,7 @@ PLIST_SUB+= JAVA=""
PLIST_SUB+= JAVA="@comment "
.endif
-.if defined(WITH_EXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
PLIST_SUB+= EXAMPLES=""
.else
PLIST_SUB+= EXAMPLES="@comment "
@@ -52,15 +47,15 @@ pre-patch:
@${REINPLACE_CMD} "s,-ri,-Ei.bak," ${WRKSRC}/eibd/client/php/Makefile.in
@${REINPLACE_CMD} "s, bcu,," ${WRKSRC}/eibd/Makefile.in
@${REINPLACE_CMD} "s, php,," ${WRKSRC}/eibd/client/Makefile.in
-.if !defined(WITH_EXAMPLES)
+.if ! ${PORT_OPTIONS:MEXAMPLES}
@${REINPLACE_CMD} "s, examples,," ${WRKSRC}/eibd/Makefile.in
.else
@${REINPLACE_CMD} -e "s,^\(examplesdir = \).*,\1${EXAMPLESDIR}," \
-e "s,^\(bindir = \).*,\1${EXAMPLESDIR}/bin," \
${WRKSRC}/eibd/examples/Makefile.in
.endif
-.if defined(WITH_JAVA)
+.if ${PORT_OPTIONS:MJAVA}
@${REINPLACE_CMD} "s,^\(javadir = \).*,\1${JAVASHAREDIR}," ${WRKSRC}/eibd/client/java/Makefile.in
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/bird-devel/Makefile b/net/bird-devel/Makefile
index 8421380086e5..3957cb8d5090 100644
--- a/net/bird-devel/Makefile
+++ b/net/bird-devel/Makefile
@@ -18,7 +18,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --enable-mpls
USE_CSTD= gnu89
-OPTIONS= KMPLS "Enable kernel MPLS support" Off
+OPTIONS_DEFINE= KMPLS
+KMPLS_DESC= kernel MPLS support
MAKE_JOBS_UNSAFE= yes
@@ -26,7 +27,7 @@ USE_RC_SUBR= bird
.include <bsd.port.pre.mk>
-.if defined(WITH_KMPLS)
+.if ${PORT_OPTIONS:MKMPLS}
CONFIGURE_ARGS+= --enable-kmpls
.endif
diff --git a/net/c3270/Makefile b/net/c3270/Makefile
index 7b9b7e8dbebd..7eb5e55f6862 100644
--- a/net/c3270/Makefile
+++ b/net/c3270/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: c3270
-# Date created: 04 October 2004
-# Whom: pdseniura@techie.com
-#
+# Created by: pdseniura@techie.com
# $FreeBSD$
-#
PORTNAME= c3270
PORTVERSION= 3.3.12ga13
@@ -19,7 +15,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/([0-9]\.[0-9])(\..*)/\1/}
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USES= iconv
+USES= iconv readline
USE_OPENSSL= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
@@ -31,80 +27,83 @@ MAN1= c3270.1 \
MAN5= ibm_hosts.5
MANCOMPRESSED= no
-.if !defined(NOPORTDOCS)
-PORTDOCS= *
-.endif
-
# c3270's ./configure script supports these.
# Within it all options except DBCS are enabled by default.
-OPTIONS=OPENSSL "Build with OpenSSL support" on \
- READLINE "Use system Readline library" on \
- PR3287 "Build pr3287 component" on \
- ANSI "Include NVT (ANSI) support" on \
- APL "Include APL support" on \
- DBCS "Include EBCDIC DBCS support" off \
- FT "Include IND\$$FILE support" on \
- LOCAL_PROCESS "Include Local Process support" on \
- PRINTER "Include printer session support" on \
- SCRIPT "Include scripting support" on \
- TN3270E "Include TN3270-Extended support" on \
- TRACE "Include trace support" on
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITHOUT_OPENSSL) && !defined(WITH_OPENSSL)
+OPTIONS_DEFINE= OPENSSL READLINE PR3287 ANSI APL DBCS FT LOCAL_PROCESS \
+ PRINTER SCRIPT TN3270E TRACE
+OPTIONS_DEFAULT= OPENSSL READLINE PR3287 ANSI APL FT LOCAL_PROCESS \
+ PRINTER SCRIPT TN3270E TRACE
+PR3287_DESC= Build pr3287 component
+ANSI_DESC= Include NVT (ANSI) support
+APL_DESC= Include APL support
+DBCS_DESC= Include EBCDIC DBCS support
+FT_DESC= Include IND\$$FILE support
+LOCAL_PROCESS_DESC= Include Local Process support
+PRINTER_DESC= Include printer session support
+SCRIPT_DESC= Include scripting support
+TN3270E_DESC= Include TN3270-Extended support
+TRACE_DESC= Include trace support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+PORTDOCS= *
+.endif
+
+.if ! ${PORT_OPTIONS:MOPENSSL}
CONFIGURE_ARGS+= --disable-ssl
.undef USE_OPENSSL
.endif
-.if defined(WITHOUT_READLINE) && !defined(WITH_READLINE)
+.if ! ${PORT_OPTIONS:MREADLINE}
CONFIGURE_ARGS+= --without-readline
+.undef USE_READLINE
.endif
-.if defined(WITHOUT_ANSI) && !defined(WITH_ANSI)
+.if ! ${PORT_OPTIONS:MANSI}
CONFIGURE_ARGS+= --disable-ansi
.endif
-.if defined(WITHOUT_APL) && !defined(WITH_APL)
+.if ! ${PORT_OPTIONS:MAPL}
CONFIGURE_ARGS+= --disable-apl
.endif
# EBCDIC double-byte character set support is disabled by default
-.if defined(WITH_DBCS) && !defined(WITHOUT_DBCS)
+.if ${PORT_OPTIONS:MDBCS}
CONFIGURE_ARGS+= --enable-dbcs
PLIST_SUB+= DBCS=""
.else
PLIST_SUB+= DBCS="@comment "
.endif
-.if defined(WITHOUT_FT) && !defined(WITH_FT)
+.if ! ${PORT_OPTIONS:MFT}
CONFIGURE_ARGS+= --disable-ft
.endif
-.if defined(WITHOUT_LOCAL_PROCESS) && !defined(WITH_LOCAL_PROCESS)
+.if ! ${PORT_OPTIONS:MLOCAL_PROCESS}
CONFIGURE_ARGS+= --disable-local-process
.endif
-.if defined(WITHOUT_PRINTER) && !defined(WITH_PRINTER)
+.if ! ${PORT_OPTIONS:MPRINTER}
CONFIGURE_ARGS+= --disable-printer
.endif
-.if defined(WITHOUT_SCRIPT) && !defined(WITH_SCRIPT)
+.if ! ${PORT_OPTIONS:MSCRIPT}
CONFIGURE_ARGS+= --disable-script
.endif
-.if defined(WITHOUT_TN3270E) && !defined(WITH_TN3270E)
+.if ! ${PORT_OPTIONS:MTN3270E}
CONFIGURE_ARGS+= --disable-tn3270e
.endif
-.if defined(WITHOUT_TRACE) && !defined(WITH_TRACE)
+.if ! ${PORT_OPTIONS:MTRACE}
CONFIGURE_ARGS+= --disable-trace
.endif
post-install:
@( cd ${WRKSRC} && ${GMAKE} ${MAKE_FLAGS} Makefile install.man )
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${MKDIR} ${DOCSDIR}/html
.for i in ${PORTDOCS}
@@ -113,4 +112,4 @@ post-install:
@${ECHO_MSG} "===> Extra Documentation installed in ${DOCSDIR}/html ."
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/callweaver/Makefile b/net/callweaver/Makefile
index 480a2e4d475b..e3403879e153 100644
--- a/net/callweaver/Makefile
+++ b/net/callweaver/Makefile
@@ -1,8 +1,5 @@
-# New ports collection makefile for: callweaver
-# Date created: 28 June 2009
-# Whom: Alexander V. Chernikov <melifaro@ipfw.ru>
+# Created by: Alexander V. Chernikov <melifaro@ipfw.ru>
# $FreeBSD$
-#
PORTNAME= callweaver
PORTVERSION= 1.2.1
@@ -33,28 +30,25 @@ PLIST_SUB+= CWUSER=${CWUSER} CWGROUP=${CWGROUP}
MAN8= callweaver.8 safe_callweaver.8
-OPTIONS= SIPTCP "Enable SIP TCP/TLS support" on \
- POSTGRES "Enable PostgreSQL support" off \
- MYSQL "Enable MySQL support" off \
- EXTUDP "Enable extented UDP support for multi-homed" off \
- ZAPTEL "Enable Zapata Telefony" off \
- FAX "Enable audio/T.38 app_fax/chan_fax/FaxGateway/etc" on \
- SPEEX "Build speex codec" on \
- VORBIS "Enable VORBIS/Vorbis format support" on \
- MEETME "Build app_meetme (requires ZAPTEL)" off \
- LDAP "Build app_ldap application" off \
- SNMP "Enable SNMP support (broken)" off \
- DEBUG "Enable debug support" off
+OPTIONS_DEFINE= SIPTCP PGSQL MYSQL EXTUDP ZAPTEL FAX SPEEX VORBIS MEETME LDAP SNMP DEBUG
+OPTIONS_DEFAULT= SIPTCP FAX SPEEX VORBIS
+SIPTCP_DESC= SIP TCP/TLS support
+EXTUDP_DESC= extented UDP support for multi-homed
+ZAPTEL_DESC= Zapata Telefony
+FAX_DESC= audio/T.38 app_fax/chan_fax/FaxGateway/etc
+MEETME_DESC= Build app_meetme (requires ZAPTEL)
+LDAP_DESC= Build app_ldap application
+SNMP_DESC= SNMP support (broken)
.include <bsd.port.pre.mk>
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+= --with-readme --with-license --with-credits
.else
CONFIGURE_ARGS+= --without-readme --without-license --without-credits
.endif
-.if defined(WITH_SIPTCP)
+.if ${PORT_OPTIONS:MSIPTCP}
CONFIGURE_ARGS+= --enable-sip-tcp-support
PLIST_SUB+= TLS=""
.else
@@ -62,7 +56,7 @@ CONFIGURE_ARGS+= --disable-sip-tcp-support
PLIST_SUB+= TLS="@comment "
.endif
-.if defined(WITH_POSTGRES)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
PG_INC= `${LOCALBASE}/bin/pg_config --includedir`
PG_LIB= `${LOCALBASE}/bin/pg_config --libdir`
@@ -72,7 +66,7 @@ PLIST_SUB+= PGSQL=""
PLIST_SUB+= PGSQL="@comment "
.endif
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
CONFIGURE_ARGS+= --enable-mysql --with-cdr_mysql
USE_MYSQL= yes
PLIST_SUB+= MYSQL=""
@@ -80,11 +74,11 @@ PLIST_SUB+= MYSQL=""
PLIST_SUB+= MYSQL="@comment "
.endif
-.if defined(WITH_EXTUDP)
+.if ${PORT_OPTIONS:MEXTUDP}
CONFIGURE_ARGS+= --enable-udpfromto
.endif
-.if defined(WITH_MEETME)
+.if ${PORT_OPTIONS:MMEETME}
WITH_ZAPTEL=yes
CONFIGURE_ARGS+= --with-app_meetme
PLIST_SUB+= MEETME=""
@@ -93,7 +87,7 @@ CONFIGURE_ARGS+= --without-app_meetme
PLIST_SUB+= MEETME="@comment "
.endif
-.if defined(WITH_ZAPTEL)
+.if ${PORT_OPTIONS:MZAPTEL}
CONFIGURE_ARGS+= --enable-zaptel --with-chan_zap
BUILD_DEPENDS+= libpri>=1.2.0:${PORTSDIR}/misc/libpri \
${LOCALBASE}/include/zaptel/zaptel.h:${PORTSDIR}/misc/zaptel
@@ -105,7 +99,7 @@ CONFIGURE_ARGS+= --disable-zaptel --without-chan_zap
PLIST_SUB+= ZAPTEL="@comment "
.endif
-.if defined(WITH_FAX)
+.if ${PORT_OPTIONS:MFAX}
FAXDEV_PATH= /var/run/fax
CONFIGURE_ARGS+= --with-app_t38gateway --with-app_txfax --with-app_rxfax --with-chan_fax --with-app_faxdetect --with-tiff-includes="${LOCALBASE}/include/" --with-tiff-libs="${LOCALBASE}/lib"
LIB_DEPENDS+= tiff:${PORTSDIR}/graphics/tiff
@@ -115,14 +109,14 @@ CONFIGURE_ARGS+= --without-app_t38gateway --without-app_txfax --without-app_rxfa
PLIST_SUB+= FAX="@comment "
.endif
-#.if defined(WITH_ODBC)
+#.if ${PORT_OPTIONS:MODBC}
#CONFIGURE_ARGS+= --enable-odbc
#LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
#.else
#CONFIGURE_ARGS+= --disable-odbc
#.endif
-.if defined(WITH_SPEEX)
+.if ${PORT_OPTIONS:MSPEEX}
CONFIGURE_ARGS+= --with-codec_speex
LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex
PLIST_SUB+= SPEEX=""
@@ -131,7 +125,7 @@ CONFIGURE_ARGS+= --without-codec_speex
PLIST_SUB+= SPEEX="@comment "
.endif
-.if defined(WITH_VORBIS)
+.if ${PORT_OPTIONS:MVORBIS}
CONFIGURE_ARGS+= --with-format_oggvorbis
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
PLIST_SUB+= VORBIS=""
@@ -140,7 +134,7 @@ CONFIGURE_ARGS+= --without-format_oggvorbis
PLIST_SUB+= VORBIS="@comment "
.endif
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
CONFIGURE_ARGS+= --enable-openldap --with-ldap-dir="${LOCALBASE}"
PLIST_SUB+= LDAP=""
@@ -149,7 +143,7 @@ CONFIGURE_ARGS+= --disable-openldap
PLIST_SUB+= LDAP="@comment "
.endif
-.if defined(WITH_SNMP)
+.if ${PORT_OPTIONS:MSNMP}
LIB_DEPENDS+= netsnmp.30:${PORTSDIR}/net-mgmt/net-snmp
CONFIGURE_ARGS+= --with-res_snmp
PLIST_SUB+= SNMP=""
@@ -158,12 +152,12 @@ CONFIGURE_ARGS+= --without-res_snmp
PLIST_SUB+= SNMP="@comment "
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --disable-optimization --enable-debug
.endif
post-install:
-.if defined(WITH_FAX)
+.if ${PORT_OPTIONS:MFAX}
@${MKDIR} ${FAXDEV_PATH}
@${CHOWN} ${CWUSER}:${CWGROUP} ${FAXDEV_PATH}
@${REINPLACE_CMD} -i "" -e 's?/dev/fax/?${FAXDEV_PATH}?' ${PREFIX}/etc/${PORTNAME}/chan_fax.conf*
diff --git a/net/csync2/Makefile b/net/csync2/Makefile
index e990d2d6191d..dcbc10dc8160 100644
--- a/net/csync2/Makefile
+++ b/net/csync2/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://oss.linbit.com/csync2/ \
http://people.freebsd.org/~aaron/distfiles/
MAINTAINER= alexey@renatasystems.org
-COMMENT= A cluster synchronization tool
+COMMENT= Cluster synchronization tool
LIB_DEPENDS= rsync.1:${PORTSDIR}/net/librsync \
tasn1.5:${PORTSDIR}/security/libtasn1 \
@@ -18,9 +18,12 @@ LIB_DEPENDS= rsync.1:${PORTSDIR}/net/librsync \
gcrypt:${PORTSDIR}/security/libgcrypt \
gpg-error.0:${PORTSDIR}/security/libgpg-error
-OPTIONS= CSYNC2_COMPARE "Install csync2-compare script" off
+OPTIONS_DEFINE= CSYNC2_COMPARE
+CSYNC2_COMPARE_DESC= Install csync2-compare script
-.include <bsd.port.pre.mk>
+USES= pkgconfig
+
+.include <bsd.port.options.mk>
MAN1= csync2.1
@@ -35,7 +38,7 @@ USE_RC_SUBR= csync2
PLIST_FILES= etc/csync2.cfg-dist \
sbin/csync2
-.if defined(WITH_CSYNC2_COMPARE)
+.if ${PORT_OPTIONS:MCSYNC2_COMPARE}
RUN_DEPENDS+= bash>=0:${PORTSDIR}/shells/bash
PLIST_FILES+= sbin/csync2-compare
CSYNC2_COMPARE= csync2-compare
@@ -51,4 +54,4 @@ post-patch:
post-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/ekiga/Makefile b/net/ekiga/Makefile
index 84ba453deff8..0e5b9d1d7da3 100644
--- a/net/ekiga/Makefile
+++ b/net/ekiga/Makefile
@@ -1,9 +1,5 @@
-# Ports collection Makefile for: gnomemeeting
-# Date created: 24/07/2001
-# Whom: roger@FreeBSD.org
-#
+# Created by: roger@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= ekiga
PORTVERSION= 2.0.11
@@ -16,8 +12,8 @@ COMMENT= VoIP phone for GNOME
LIB_DEPENDS= opal_r:${PORTSDIR}/net/opal
-OPTIONS= AVAHI "Support Avahi for service discovery on LAN" on \
- DBUS "Use D-BUS for interprocess communication" on
+OPTIONS_DEFINE= AVAHI DBUS
+OPTIONS_DEFAULT= AVAHI DBUS
CONFLICTS= ekiga-3.*
@@ -46,16 +42,16 @@ pre-configure:
{printf $$NF}' ${LOCALBASE}/include/opal/opal/buildopts.h`," \
${WRKSRC}/configure
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.ifndef (WITHOUT_AVAHI)
+.if ${PORT_OPTIONS:MAVAHI}
LIB_DEPENDS+= avahi-core:${PORTSDIR}/net/avahi-app
CONFIGURE_ARGS+=--enable-avahi
.else
CONFIGURE_ARGS+=--disable-avahi
.endif
-.ifndef (WITHOUT_DBUS)
+.if ${PORT_OPTIONS:MDBUS}
LIB_DEPENDS+= dbus-1:${PORTSDIR}/devel/dbus
CONFIGURE_ARGS+=--enable-dbus
PLIST_SUB+= DBUS:=""
@@ -64,4 +60,4 @@ CONFIGURE_ARGS+=--disable-dbus
PLIST_SUB+= DBUS:="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/freedbd/Makefile b/net/freedbd/Makefile
index 658536b50e1f..ac1cca896268 100644
--- a/net/freedbd/Makefile
+++ b/net/freedbd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: freedbd
-# Date created: 25 Aug 2005
-# Whom: Ed Schouten <ed@fxq.nl>
-#
+# Created by: Ed Schouten <ed@fxq.nl>
# $FreeBSD$
-#
PORTNAME= freedbd
PORTVERSION= 0.1
@@ -20,11 +16,11 @@ USE_PERL5_RUN= yes
PLIST_FILES= bin/freedbd bin/freedbd-txt2xml %%EXAMPLESDIR%%/sample_db.txt
PLIST_DIRS= %%EXAMPLESDIR%%
-OPTIONS= XML "XML support" off
+OPTIONS_DEFINE= XML
.include <bsd.port.pre.mk>
-.if defined(WITH_XML)
+.if ${PORT_OPTIONS:MXML}
USE_GNOME+= libxml2
CONFIGURE_ARGS+=--with-xml
RUN_DEPENDS+= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
@@ -35,7 +31,7 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/tools/txt2xml.pl ${PREFIX}/bin/freedbd-txt2xml
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/sample_db.txt ${EXAMPLESDIR}
-.if defined(WITH_XML)
+.if ${PORT_OPTIONS:MXML}
${INSTALL_SCRIPT} ${WRKSRC}/tools/db_parse.pl ${PREFIX}/bin/freedbd-parse
${INSTALL_DATA} ${WRKSRC}/examples/sample_db.xml ${EXAMPLESDIR}
.endif
diff --git a/net/fspd/Makefile b/net/fspd/Makefile
index db23b0950082..04c4f46ed03a 100644
--- a/net/fspd/Makefile
+++ b/net/fspd/Makefile
@@ -34,16 +34,17 @@ USE_SCONS= yes
USE_BZIP2= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
-OPTIONS= NOCLIENTS "Omit client commands" off \
- INFINITE "Infinite retry in client commands" off
+OPTIONS_DEFINE= NOCLIENTS INFINITE
+NOCLIENTS_DESC= Omit client commands
+INFINITE_DESC= Infinite retry in client commands
.include <bsd.port.pre.mk>
-.if defined(WITH_INFINITE)
+.if ${PORT_OPTIONS:MINFINITE}
SCONS_ARGS+= disable-timeout=yes
.endif
-.if !defined(WITH_NOCLIENTS)
+.if ! ${PORT_OPTIONS:MNOCLIENTS}
.for command in ${CLIENTS}
PLIST_FILES+= bin/${command}
.endfor
@@ -61,13 +62,13 @@ post-build:
@${CP} ${WRKSRC}/doc/*.html ${WRKSRC}
do-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for doc in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
.endfor
.endif
-.if !defined(WITH_NOCLIENTS)
+.if ! ${PORT_OPTIONS:MNOCLIENTS}
.for command in ${CLIENTS}
${INSTALL_PROGRAM} ${WRKSRC}/clients/${command} ${PREFIX}/bin
.endfor
diff --git a/net/hawknl-devel/Makefile b/net/hawknl-devel/Makefile
index 46d40a42a6b3..fda2e69cf638 100644
--- a/net/hawknl-devel/Makefile
+++ b/net/hawknl-devel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: hawknl
-# Date created: 2006-03-04
-# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
-#
+# Created by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
# $FreeBSD$
-#
PORTNAME= hawknl
PORTVERSION= 1.70
@@ -29,7 +25,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
WRKSRC= ${WRKDIR}/HawkNL1.70
-OPTIONS= OPTIMIZATION "Enable optimization" off
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS
.include <bsd.port.pre.mk>
@@ -37,7 +33,7 @@ OPTIONS= OPTIMIZATION "Enable optimization" off
BROKEN= does not compile on ${ARCH}
.endif
-.if defined(WITH_OPTIMIZATION)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CFLAGS+= -funroll-all-loops -ffast-math -fomit-frame-pointer -D_GNU_SOURCE -D_REENTRANT
.endif
@@ -46,7 +42,7 @@ post-patch:
${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|g' ${WRKSRC}/src/nlinternal.h ${WRKSRC}/src/htinternal.h
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for FILE in readme.txt NLchanges.txt
@${INSTALL_DATA} ${WRKSRC}/src/${FILE} ${DOCSDIR}
diff --git a/net/hawknl/Makefile b/net/hawknl/Makefile
index 8c9970bf149b..a62d455fe5dc 100644
--- a/net/hawknl/Makefile
+++ b/net/hawknl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: hawknl
-# Date created: 2006-03-04
-# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
-#
+# Created by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
# $FreeBSD$
-#
PORTNAME= hawknl
PORTVERSION= 1.68
@@ -25,7 +21,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
-OPTIONS= OPTIMIZATION "Enable optimization" off
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS
.include <bsd.port.pre.mk>
@@ -33,7 +29,7 @@ OPTIONS= OPTIMIZATION "Enable optimization" off
CFLAGS+= -fPIC -DPIC
.endif
-.if defined(WITH_OPTIMIZATION)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CFLAGS+= -funroll-all-loops -ffast-math -fomit-frame-pointer -D_GNU_SOURCE -D_REENTRANT
.endif
@@ -42,7 +38,7 @@ post-patch:
${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|g' ${WRKSRC}/src/nlinternal.h
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for FILE in readme.txt nlchanges.txt
${INSTALL_DATA} ${WRKSRC}/src/${FILE} ${DOCSDIR}