aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-23 15:21:58 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-23 15:21:58 +0000
commitfb23a6f08714a3bc31b5728472ae960c7a68a04b (patch)
treed40e52ef66a8a3ef919f5458544ec910c3fcdb94 /net
parent78faace909187a8ca42d762e4a44bcfdaeaffdd0 (diff)
downloadports-fb23a6f08714a3bc31b5728472ae960c7a68a04b.tar.gz
ports-fb23a6f08714a3bc31b5728472ae960c7a68a04b.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/pecl-apn/Makefile25
-rw-r--r--net/pecl-apn/distinfo2
-rw-r--r--net/pecl-apn/files/patch-config.m431
-rw-r--r--net/pecl-apn/pkg-descr4
5 files changed, 63 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 1c4053e6cad2..61b7793504f9 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -855,6 +855,7 @@
SUBDIR += pear-XML_RPC
SUBDIR += pear-XML_RPC2
SUBDIR += pecl-amqp
+ SUBDIR += pecl-apn
SUBDIR += pecl-cvsclient
SUBDIR += pecl-geoip
SUBDIR += pecl-gupnp
diff --git a/net/pecl-apn/Makefile b/net/pecl-apn/Makefile
new file mode 100644
index 000000000000..bfc096bc4cae
--- /dev/null
+++ b/net/pecl-apn/Makefile
@@ -0,0 +1,25 @@
+# Created by: Gasol Wu <gasol.wu@gmail.com>
+# $FreeBSD$
+
+PORTNAME= apn
+PORTVERSION= 1.0.3
+CATEGORIES= net pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= gasol.wu@gmail.com
+COMMENT= Extension to interact with Apple Push Notification Service
+
+LICENSE= PHP301
+
+LIB_DEPENDS= libcapn.so:${PORTSDIR}/net/libcapn
+
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHPEXT= yes
+CONFIGURE_ARGS= --with-apn=${LOCALBASE}
+IGNORE_WITH_PHP=52
+
+.include <bsd.port.mk>
diff --git a/net/pecl-apn/distinfo b/net/pecl-apn/distinfo
new file mode 100644
index 000000000000..8131466045f0
--- /dev/null
+++ b/net/pecl-apn/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PECL/apn-1.0.3.tgz) = 1d554f1a79dbc86212e0abd97b380ae9ee66e073969deb522941bc7866a3c3ca
+SIZE (PECL/apn-1.0.3.tgz) = 14406
diff --git a/net/pecl-apn/files/patch-config.m4 b/net/pecl-apn/files/patch-config.m4
new file mode 100644
index 000000000000..98c4a00f6b33
--- /dev/null
+++ b/net/pecl-apn/files/patch-config.m4
@@ -0,0 +1,31 @@
+--- ./config.m4.orig 2014-02-20 16:43:19.000000000 +0800
++++ ./config.m4 2014-02-21 09:06:40.000000000 +0800
+@@ -37,16 +37,16 @@
+ AC_MSG_ERROR([libcapn is not found. Please visit to http://www.libcapn.org/php-apn for more information])
+ fi
+
+- APN_INCDIR=$APN_DIR/include/capn
++ APN_INCDIR=$APN_DIR/include
+
+ SEARCH_LIBS_PATH="/usr/local/lib /usr/lib /usr/lib64 /usr/local/lib64"
+ SEARCH_LIB_FILE=libcapn.$SHLIB_SUFFIX_NAME
+- if test -r $PHP_APN/capn/$SEARCH_LIB_FILE; then
++ if test -r $PHP_APN/$SEARCH_LIB_FILE; then
+ APN_LIBDIR=$PHP_APN
+ else
+ AC_MSG_CHECKING([for $SEARCH_LIB_FILE in default path])
+ for i in $SEARCH_LIBS_PATH; do
+- if test -r $i/capn/$SEARCH_LIB_FILE; then
++ if test -r $i/$SEARCH_LIB_FILE; then
+ APN_LIBDIR=$i
+ AC_MSG_RESULT(found in $i)
+ break
+@@ -59,7 +59,7 @@
+ AC_MSG_ERROR([libcapn is not found. Please visit to http://www.libcapn.org/php-apn for more information])
+ fi
+
+- APN_LIBDIR=$APN_LIBDIR/capn
++ APN_LIBDIR=$APN_LIBDIR
+
+ PHP_ADD_INCLUDE($APN_INCDIR)
+ PHP_ADD_LIBRARY_WITH_PATH(capn, $APN_LIBDIR, APN_SHARED_LIBADD)
diff --git a/net/pecl-apn/pkg-descr b/net/pecl-apn/pkg-descr
new file mode 100644
index 000000000000..074c09996f72
--- /dev/null
+++ b/net/pecl-apn/pkg-descr
@@ -0,0 +1,4 @@
+apn is a PHP extension to introduce simple yet powerful interface for sending
+push notifications to iOS and OS X devices from within your PHP code.
+
+WWW: http://libcapn.org/php-apn/