aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-16 05:08:43 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-16 05:08:43 +0000
commit0dc6e9ece016b405fe97a315015058248887e277 (patch)
tree11454eb70689e0adb4ae1acfaaaab679ac5720fc /net
parent30a485e20d88ff1c13132efee6d710a45b7def57 (diff)
downloadports-0dc6e9ece016b405fe97a315015058248887e277.tar.gz
ports-0dc6e9ece016b405fe97a315015058248887e277.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/trackerbt/Makefile60
-rw-r--r--net/trackerbt/distinfo2
-rw-r--r--net/trackerbt/files/patch-Makefile20
-rw-r--r--net/trackerbt/files/patch-tracker.cpp22
-rw-r--r--net/trackerbt/pkg-descr20
6 files changed, 125 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index d44f22da6018..cd4412121d74 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -759,6 +759,7 @@
SUBDIR += torrentsniff
SUBDIR += tptest
SUBDIR += traceroute
+ SUBDIR += trackerbt
SUBDIR += trafshow
SUBDIR += trafshow4
SUBDIR += tramp
diff --git a/net/trackerbt/Makefile b/net/trackerbt/Makefile
new file mode 100644
index 000000000000..8c10f1523597
--- /dev/null
+++ b/net/trackerbt/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: trackerbt
+# Date created: Sun Jan 16 03:28:23 UTC 2005
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= trackerbt
+PORTVERSION= 0.1
+CATEGORIES= net
+MASTER_SITES= http://www.alhem.net/project/trackerbt/
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= A BitTorrent tracker with additional distributed functionality
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libSockets.a:${PORTSDIR}/net/Sockets
+
+USE_GMAKE= yes
+USE_GNOME= libxml2
+USE_ICONV= yes
+USE_OPENSSL= yes
+WITH_OPENSSL_BASE= yes
+MAKE_ENV= CXX="${CXX}"
+USE_REINPLACE= yes
+
+# ssl support
+CFLAGS+= ${PTHREAD_CFLAGS} -DHAVE_OPENSSL
+
+PLIST_DIRS= \
+ %%EXAMPLESDIR%%
+PLIST_FILES= \
+ bin/${PORTNAME} \
+ %%EXAMPLESDIR%%/config.xml
+
+post-patch:
+# CXX safeness
+# CXXFLAGS safeness
+# SSL include safeness
+ @${REINPLACE_CMD} -E \
+ -e 's|g\+\+|${CXX}|' \
+ -e 's|^INCLUDE.+$$|INCLUDE=-I${OPENSSLINC} -I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2 -I${LOCALBASE}/include/Sockets|' \
+ -e 's|^LIBS.+$$|LIBS=-L${OPENSSLLIB} ${PTHREAD_LIBS} -L${LOCALBASE}/lib \\|' \
+ ${BUILD_WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -E \
+ -e 's|\(__sighandler_t\)||' \
+ ${WRKSRC}/tracker.cpp
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/config.xml ${EXAMPLESDIR}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= FreeBSD prior to 500000 does not support uuid(3) required\
+ for building
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/trackerbt/distinfo b/net/trackerbt/distinfo
new file mode 100644
index 000000000000..ad53beea639f
--- /dev/null
+++ b/net/trackerbt/distinfo
@@ -0,0 +1,2 @@
+MD5 (trackerbt-0.1.tar.gz) = b5a8138116412987b45add469aa06931
+SIZE (trackerbt-0.1.tar.gz) = 9197
diff --git a/net/trackerbt/files/patch-Makefile b/net/trackerbt/files/patch-Makefile
new file mode 100644
index 000000000000..8b3070aa6766
--- /dev/null
+++ b/net/trackerbt/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig Sun Jan 16 01:33:44 2005
++++ Makefile Sun Jan 16 01:34:27 2005
+@@ -1,14 +1,11 @@
+ VERSION = 0.1
+
+-INCLUDE = -I/usr/local/include/Sockets \
+- -I/usr/local/include/libxml2 \
+- -I/usr/local/ssl/include
++INCLUDE =
+ CFLAGS = -Wall -g $(INCLUDE) -MD -D_VERSION='"$(VERSION)"'
+ CPPFLAGS = $(CFLAGS)
+
+-LIBS = -L/usr/local/lib -lSocketsEx -lSockets \
+- -L/usr/local/ssl/lib \
+- -lssl -lcrypto -luuid -lxml2
++LIBS = -L/usr/local/lib \
++ -lSocketsEx -lSockets -lssl -lcrypto -lxml2
+
+ PROGS = trackerbt
+
diff --git a/net/trackerbt/files/patch-tracker.cpp b/net/trackerbt/files/patch-tracker.cpp
new file mode 100644
index 000000000000..71014509b0cd
--- /dev/null
+++ b/net/trackerbt/files/patch-tracker.cpp
@@ -0,0 +1,22 @@
+--- tracker.cpp.orig Sun Jan 16 02:18:36 2005
++++ tracker.cpp Sun Jan 16 02:19:42 2005
+@@ -19,6 +19,10 @@
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ */
++#if (defined(__unix__) || defined(unix)) && !defined(USG)
++#include <sys/param.h>
++#endif
++
+ #include <ListenSocket.h>
+ #include <signal.h>
+ #include "MyHandler.h"
+@@ -43,6 +47,8 @@
+ fprintf(fil,"\tedge [arrowhead=open]\n");
+ #ifdef _WIN32
+ std::string os = "Win32";
++#elif defined __FreeBSD__
++ std::string os = "FreeBSD";
+ #else
+ std::string os = "Linux";
+ #endif
diff --git a/net/trackerbt/pkg-descr b/net/trackerbt/pkg-descr
new file mode 100644
index 000000000000..cb59a77de1d1
--- /dev/null
+++ b/net/trackerbt/pkg-descr
@@ -0,0 +1,20 @@
+[ excerpt from developer's web site with modifications ]
+
+One crucial component of the BitTorrent structure is the tracker.
+This is a small program which is hosted by someone who wants to
+share a file using BitTorrent. Anyone that wants to download that
+file needs to connect to the tracker to receive a list of other
+peers already participating in the download of the file. The tracker
+is a standalone program. If the tracker goes offline, new peers
+will not be able to join the download. This makes the tracker the
+weak link of the BitTorrent solution.
+
+What if the tracker were able to share its peer list with other
+trackers? This would create a redundant network of trackers, all
+aware of all peers participating in the download. Peak load would
+be reduced, and if one tracker goes offline new peers would still
+be able to contact one of the other trackers and join the download.
+
+WWW: http://www.alhem.net/project/trackerbt/index.html
+
+-- lioux@FreeBSD.org