aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-04-04 21:36:10 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-04-04 21:36:10 +0000
commit1499cd457997653ec03ec629aa513d7f72d84dda (patch)
treec70625ca1a5a9bdfb1ff4507bef1113de1fbd094 /net
parente000b568098a41647b681e9cf8c7835a7f26665a (diff)
downloadports-1499cd457997653ec03ec629aa513d7f72d84dda.tar.gz
ports-1499cd457997653ec03ec629aa513d7f72d84dda.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/zebra-server/Makefile21
-rw-r--r--net/zebra-server/distinfo6
-rw-r--r--net/zebra-server/files/patch-configure10
-rw-r--r--net/zebra-server/files/patch-dfa-Makefile.in11
-rw-r--r--net/zebra-server/files/patch-dict-Makefile.in11
-rw-r--r--net/zebra-server/files/patch-tab-Makefile.in11
-rw-r--r--net/zebra-server/files/patch-util-Makefile.in11
-rw-r--r--net/zebra-server/pkg-plist263
8 files changed, 194 insertions, 150 deletions
diff --git a/net/zebra-server/Makefile b/net/zebra-server/Makefile
index 138515d9e461..24706ff95ba5 100644
--- a/net/zebra-server/Makefile
+++ b/net/zebra-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= zebra-server
-PORTVERSION= 1.3.24
+PORTVERSION= 2.0.28
CATEGORIES= net
MASTER_SITES= http://ftp.indexdata.dk/pub/zebra/
DISTNAME= idzebra-${PORTVERSION}
@@ -14,17 +14,22 @@ DISTNAME= idzebra-${PORTVERSION}
MAINTAINER= demon@FreeBSD.org
COMMENT= Z39.50/SR server software
-BUILD_DEPENDS= ${LOCALBASE}/bin/tclsh8.4:${PORTSDIR}/lang/tcl84
-LIB_DEPENDS= yaz.2:${PORTSDIR}/net/yaz
-RUN_DEPENDS= ${LOCALBASE}/bin/tclsh8.4:${PORTSDIR}/lang/tcl84
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
+ yaz.3:${PORTSDIR}/net/yaz
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-yaz=${LOCALBASE}/bin \
- --with-tclconfig=${LOCALBASE}/lib/tcl8.4 \
+ --with-tclconfig=${TCL_LIBDIR} \
--with-iconv=${LOCALBASE} --with-expat=${LOCALBASE}
-CONFIGURE_ENV+= PTHREAD_LIBS=${PTHREAD_LIBS}
-MAN1= zebraidx.1
-MAN8= zebrasrv.8
+USE_ICONV= yes
+USE_LDCONFIG= yes
+USE_TCL= 84
+
+MAN1= idzebra-config-2.0.1 zebraidx-2.0.1
+MAN8= zebrasrv-2.0.8
+MLINKS= idzebra-config-2.0.1 idzebra-config.1 \
+ zebraidx-2.0.1 zebraidx.1 \
+ zebrasrv-2.0.8 zebrasrv.8
.include <bsd.port.mk>
diff --git a/net/zebra-server/distinfo b/net/zebra-server/distinfo
index 397cfa215b94..774ad0666b3f 100644
--- a/net/zebra-server/distinfo
+++ b/net/zebra-server/distinfo
@@ -1,3 +1,3 @@
-MD5 (idzebra-1.3.24.tar.gz) = a3316d5e5bc83bc925d56b4aefa49ae8
-SHA256 (idzebra-1.3.24.tar.gz) = 731d36281e9a6927495898ba1eabc74a81a8b90350cd4705b14579521eb31b73
-SIZE (idzebra-1.3.24.tar.gz) = 1044122
+MD5 (idzebra-2.0.28.tar.gz) = 06f402e338fc4098aab8de7790a8ee78
+SHA256 (idzebra-2.0.28.tar.gz) = 72ea628246b2fd7972d980618ff3c418ecd3af84a73765bacac2e3fe286473ca
+SIZE (idzebra-2.0.28.tar.gz) = 1719205
diff --git a/net/zebra-server/files/patch-configure b/net/zebra-server/files/patch-configure
deleted file mode 100644
index d5d978e87010..000000000000
--- a/net/zebra-server/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Tue Aug 17 11:00:14 2004
-+++ configure Thu Aug 19 15:15:49 2004
-@@ -6262,6 +6262,7 @@
- s,@ECHO_N@,$ECHO_N,;t t
- s,@ECHO_T@,$ECHO_T,;t t
- s,@LIBS@,$LIBS,;t t
-+s%@PTHREAD_LIBS@%$PTHREAD_LIBS%g
- s,@INSTALL_PROGRAM@,$INSTALL_PROGRAM,;t t
- s,@INSTALL_SCRIPT@,$INSTALL_SCRIPT,;t t
- s,@INSTALL_DATA@,$INSTALL_DATA,;t t
diff --git a/net/zebra-server/files/patch-dfa-Makefile.in b/net/zebra-server/files/patch-dfa-Makefile.in
deleted file mode 100644
index e6002088ae96..000000000000
--- a/net/zebra-server/files/patch-dfa-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- dfa/Makefile.in.orig Tue Aug 17 11:00:25 2004
-+++ dfa/Makefile.in Thu Aug 19 15:16:58 2004
-@@ -91,7 +91,7 @@
- noinst_PROGRAMS = agrep lexer grepper
-
- AM_CPPFLAGS = -I$(srcdir)/../include $(YAZINC)
--LDADD = libdfa.a ../util/libutil.a $(YAZLIB) $(TCL_LIB)
-+LDADD = libdfa.a ../util/libutil.a $(YAZLIB) $(TCL_LIB) @PTHREAD_LIBS@
-
- agrep_SOURCES = agrep.c
-
diff --git a/net/zebra-server/files/patch-dict-Makefile.in b/net/zebra-server/files/patch-dict-Makefile.in
deleted file mode 100644
index d5d4d38e2ab0..000000000000
--- a/net/zebra-server/files/patch-dict-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- dict/Makefile.in.orig Sat Aug 17 14:58:12 2002
-+++ dict/Makefile.in Sat Aug 17 14:58:39 2002
-@@ -113,7 +113,7 @@
- CFLAGS = @CFLAGS@
- COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
- CCLD = $(CC)
--LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
-+LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) @PTHREAD_LIBS@ -o $@
- DIST_COMMON = Makefile.am Makefile.in
-
-
diff --git a/net/zebra-server/files/patch-tab-Makefile.in b/net/zebra-server/files/patch-tab-Makefile.in
deleted file mode 100644
index a84cad35aed6..000000000000
--- a/net/zebra-server/files/patch-tab-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- tab/Makefile.in.orig Thu Aug 19 15:18:29 2004
-+++ tab/Makefile.in Thu Aug 19 15:18:37 2004
-@@ -86,7 +86,7 @@
- ZPERL_LIBS = @ZPERL_LIBS@
- yazconfig = @yazconfig@
-
--tabdatadir = $(pkgdatadir)/tab
-+tabdatadir = $(datadir)/@PACKAGE@/tab
- tabdata_DATA = bib1.att dan1.att danbib.abs danmarc.abs danmarc.mar default.idx explain.abs explain.att explain.tag generic.tag gils.abs gils-a.est gils.att gils-b.est gils-f.est gils-g.est gils-summary.map gils.tag gils-usmarc.map gils-variant.est hci.flt mail.flt meta.abs meta-b.est meta.tag meta-usmarc.map news.flt numeric.chr nwi.flt refer.flt scan.chr sgml.flt soif.flt string.chr summary.abs summary.tag tagsetg.tag tagsetm.tag urx.chr usmarc.abs usmarc-b.est usmarc.flt usmarc.mar usmarc.tag var1.var wais.abs wais-b.est wais-variant.est
-
-
diff --git a/net/zebra-server/files/patch-util-Makefile.in b/net/zebra-server/files/patch-util-Makefile.in
deleted file mode 100644
index 0d0e099c54f6..000000000000
--- a/net/zebra-server/files/patch-util-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- util/Makefile.in.orig Wed Dec 26 11:42:17 2001
-+++ util/Makefile.in Wed Dec 26 11:42:51 2001
-@@ -108,7 +108,7 @@
- CFLAGS = @CFLAGS@
- COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
- CCLD = $(CC)
--LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
-+LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) @PTHREAD_LIBS@ -o $@
- DIST_COMMON = Makefile.am Makefile.in
-
-
diff --git a/net/zebra-server/pkg-plist b/net/zebra-server/pkg-plist
index 4a565ed89bce..e0adf0d010ce 100644
--- a/net/zebra-server/pkg-plist
+++ b/net/zebra-server/pkg-plist
@@ -1,87 +1,180 @@
+bin/idzebra-config-2.0
bin/zebraidx
-bin/zebrash
+bin/zebraidx-2.0
bin/zebrasrv
-include/zebraapi.h
-include/zebraver.h
-share/doc/idzebra/zebra.html
-share/doc/idzebra/zebra.pdf
-share/doc/idzebra/zebra.png
-share/doc/idzebra/administration.html
-share/doc/idzebra/apps.html
-share/doc/idzebra/example1.html
-share/doc/idzebra/example2.html
-share/doc/idzebra/examples.html
-share/doc/idzebra/support.html
-share/doc/idzebra/configuration-file.html
-share/doc/idzebra/data-model.html
-share/doc/idzebra/features.html
-share/doc/idzebra/file-ids.html
-share/doc/idzebra/formats.html
-share/doc/idzebra/future.html
-share/doc/idzebra/generic-ids.html
-share/doc/idzebra/indexdata.html
-share/doc/idzebra/installation.html
-share/doc/idzebra/installation.win32.html
-share/doc/idzebra/internal-representation.html
-share/doc/idzebra/introduction.html
-share/doc/idzebra/license.html
-share/doc/idzebra/locating-records.html
-share/doc/idzebra/protocol-support.html
-share/doc/idzebra/quick-start.html
-share/doc/idzebra/record-model.html
-share/doc/idzebra/register-location.html
-share/doc/idzebra/server.html
-share/doc/idzebra/shadow-registers.html
-share/doc/idzebra/simple-indexing.html
-share/doc/idzebra/zebraidx.html
-share/idzebra/tab/danbib.abs
-share/idzebra/tab/default.idx
-share/idzebra/tab/hci.flt
-share/idzebra/tab/mail.flt
-share/idzebra/tab/news.flt
-share/idzebra/tab/numeric.chr
-share/idzebra/tab/nwi.flt
-share/idzebra/tab/refer.flt
-share/idzebra/tab/scan.chr
-share/idzebra/tab/sgml.flt
-share/idzebra/tab/soif.flt
-share/idzebra/tab/string.chr
-share/idzebra/tab/urx.chr
-share/idzebra/tab/usmarc.flt
-share/idzebra/tab/bib1.att
-share/idzebra/tab/dan1.att
-share/idzebra/tab/danmarc.abs
-share/idzebra/tab/danmarc.mar
-share/idzebra/tab/explain.abs
-share/idzebra/tab/explain.att
-share/idzebra/tab/explain.tag
-share/idzebra/tab/generic.tag
-share/idzebra/tab/gils-a.est
-share/idzebra/tab/gils-b.est
-share/idzebra/tab/gils-f.est
-share/idzebra/tab/gils-g.est
-share/idzebra/tab/gils-summary.map
-share/idzebra/tab/gils-usmarc.map
-share/idzebra/tab/gils-variant.est
-share/idzebra/tab/gils.abs
-share/idzebra/tab/gils.att
-share/idzebra/tab/gils.tag
-share/idzebra/tab/meta-b.est
-share/idzebra/tab/meta-usmarc.map
-share/idzebra/tab/meta.abs
-share/idzebra/tab/meta.tag
-share/idzebra/tab/summary.abs
-share/idzebra/tab/summary.tag
-share/idzebra/tab/tagsetg.tag
-share/idzebra/tab/tagsetm.tag
-share/idzebra/tab/usmarc-b.est
-share/idzebra/tab/usmarc.abs
-share/idzebra/tab/usmarc.mar
-share/idzebra/tab/usmarc.tag
-share/idzebra/tab/var1.var
-share/idzebra/tab/wais-b.est
-share/idzebra/tab/wais-variant.est
-share/idzebra/tab/wais.abs
-@dirrm share/doc/idzebra
-@dirrm share/idzebra/tab
-@dirrm share/idzebra
+bin/zebrasrv-2.0
+include/idzebra-2.0/idzebra/api.h
+include/idzebra-2.0/idzebra/bfile.h
+include/idzebra-2.0/idzebra/data1.h
+include/idzebra-2.0/idzebra/dict.h
+include/idzebra-2.0/idzebra/flock.h
+include/idzebra-2.0/idzebra/isamb.h
+include/idzebra-2.0/idzebra/isamc.h
+include/idzebra-2.0/idzebra/isams.h
+include/idzebra-2.0/idzebra/isam-codec.h
+include/idzebra-2.0/idzebra/recctrl.h
+include/idzebra-2.0/idzebra/recgrs.h
+include/idzebra-2.0/idzebra/res.h
+include/idzebra-2.0/idzebra/snippet.h
+include/idzebra-2.0/idzebra/util.h
+include/idzebra-2.0/idzebra/version.h
+lib/idzebra-2.0/modules/mod-alvis.a
+lib/idzebra-2.0/modules/mod-alvis.la
+lib/idzebra-2.0/modules/mod-alvis.so
+lib/idzebra-2.0/modules/mod-dom.a
+lib/idzebra-2.0/modules/mod-dom.la
+lib/idzebra-2.0/modules/mod-dom.so
+lib/idzebra-2.0/modules/mod-grs-marc.a
+lib/idzebra-2.0/modules/mod-grs-marc.la
+lib/idzebra-2.0/modules/mod-grs-marc.so
+lib/idzebra-2.0/modules/mod-grs-regx.a
+lib/idzebra-2.0/modules/mod-grs-regx.la
+lib/idzebra-2.0/modules/mod-grs-regx.so
+lib/idzebra-2.0/modules/mod-grs-xml.a
+lib/idzebra-2.0/modules/mod-grs-xml.la
+lib/idzebra-2.0/modules/mod-grs-xml.so
+lib/idzebra-2.0/modules/mod-safari.a
+lib/idzebra-2.0/modules/mod-safari.la
+lib/idzebra-2.0/modules/mod-safari.so
+lib/idzebra-2.0/modules/mod-text.a
+lib/idzebra-2.0/modules/mod-text.la
+lib/idzebra-2.0/modules/mod-text.so
+lib/libidzebra-2.0.a
+lib/libidzebra-2.0.la
+lib/libidzebra-2.0.so
+lib/libidzebra-2.0.so.0
+share/aclocal/idzebra-2.0.m4
+share/doc/idzebra-2.0/administration.html
+share/doc/idzebra-2.0/administration-extended-services.html
+share/doc/idzebra-2.0/administration-ranking.html
+share/doc/idzebra-2.0/architecture.html
+share/doc/idzebra-2.0/architecture-maincomponents.html
+share/doc/idzebra-2.0/architecture-workflow.html
+share/doc/idzebra-2.0/common/id.png
+share/doc/idzebra-2.0/common/style1.css
+share/doc/idzebra-2.0/domfilter.png
+share/doc/idzebra-2.0/features.html
+share/doc/idzebra-2.0/fields-and-charsets.html
+share/doc/idzebra-2.0/file-ids.html
+share/doc/idzebra-2.0/generic-ids.html
+share/doc/idzebra-2.0/grs.html
+share/doc/idzebra-2.0/grs-conf.html
+share/doc/idzebra-2.0/grs-exchange-formats.html
+share/doc/idzebra-2.0/grs-extended-marc-indexing.html
+share/doc/idzebra-2.0/grs-internal-representation.html
+share/doc/idzebra-2.0/character-map-files.html
+share/doc/idzebra-2.0/icuchain-files.html
+share/doc/idzebra-2.0/idzebra-config.html
+share/doc/idzebra-2.0/indexdata.html
+share/doc/idzebra-2.0/index.html
+share/doc/idzebra-2.0/installation.html
+share/doc/idzebra-2.0/installation-debian.html
+share/doc/idzebra-2.0/installation-upgrade.html
+share/doc/idzebra-2.0/installation-win32.html
+share/doc/idzebra-2.0/introduction.html
+share/doc/idzebra-2.0/introduction-apps.html
+share/doc/idzebra-2.0/introduction-support.html
+share/doc/idzebra-2.0/license.html
+share/doc/idzebra-2.0/locating-records.html
+share/doc/idzebra-2.0/querymodel.html
+share/doc/idzebra-2.0/querymodel-cql-to-pqf.html
+share/doc/idzebra-2.0/querymodel-rpn.html
+share/doc/idzebra-2.0/querymodel-zebra.html
+share/doc/idzebra-2.0/record-model-alvisxslt.html
+share/doc/idzebra-2.0/record-model-alvisxslt-conf.html
+share/doc/idzebra-2.0/record-model-domxml.html
+share/doc/idzebra-2.0/record-model-domxml-conf.html
+share/doc/idzebra-2.0/record-model-domxml-pipeline.html
+share/doc/idzebra-2.0/reference.html
+share/doc/idzebra-2.0/register-location.html
+share/doc/idzebra-2.0/shadow-registers.html
+share/doc/idzebra-2.0/simple-indexing.html
+share/doc/idzebra-2.0/special-retrieval.html
+share/doc/idzebra-2.0/tutorial.html
+share/doc/idzebra-2.0/tutorial-oai-sru-pqf.html
+share/doc/idzebra-2.0/tutorial-oai-sru-present.html
+share/doc/idzebra-2.0/tutorial-oai-sru-searches.html
+share/doc/idzebra-2.0/tutorial-oai-sru-yazfrontend.html
+share/doc/idzebra-2.0/tutorial-oai-sru-zebra-indexess.html
+share/doc/idzebra-2.0/tutorial-oai-z3950.html
+share/doc/idzebra-2.0/zebraidx.html
+share/doc/idzebra-2.0/zebrasrv.html
+share/doc/idzebra-2.0/zebra.png
+share/doc/idzebra-2.0/zebra-cfg.html
+share/idzebra-2.0-examples/oai-pmh/conf/cql2pqf.txt
+share/idzebra-2.0-examples/oai-pmh/conf/explain2cqlpqftxt.xsl
+share/idzebra-2.0-examples/oai-pmh/conf/explain.xml
+share/idzebra-2.0-examples/oai-pmh/conf/oai2dc.xsl
+share/idzebra-2.0-examples/oai-pmh/conf/oai2index.xsl
+share/idzebra-2.0-examples/oai-pmh/conf/oai2zebra.xsl
+share/idzebra-2.0-examples/oai-pmh/conf/yazserver.xml
+share/idzebra-2.0-examples/oai-pmh/conf/zebra.cfg
+share/idzebra-2.0-examples/oai-pmh/data/debug-record.xml
+share/idzebra-2.0-examples/oai-pmh/data/debug-utf8-record.xml
+share/idzebra-2.0-examples/oai-pmh/data/oai-caltech.xml
+share/idzebra-2.0-examples/oai-pmh/README
+share/idzebra-2.0/tab/bib1.att
+share/idzebra-2.0/tab/danmarc.abs
+share/idzebra-2.0/tab/danmarc.mar
+share/idzebra-2.0/tab/dan1.att
+share/idzebra-2.0/tab/default.idx
+share/idzebra-2.0/tab/explain.abs
+share/idzebra-2.0/tab/explain.att
+share/idzebra-2.0/tab/explain.tag
+share/idzebra-2.0/tab/generic.tag
+share/idzebra-2.0/tab/gils.abs
+share/idzebra-2.0/tab/gils.att
+share/idzebra-2.0/tab/gils.tag
+share/idzebra-2.0/tab/gils-a.est
+share/idzebra-2.0/tab/gils-b.est
+share/idzebra-2.0/tab/gils-f.est
+share/idzebra-2.0/tab/gils-g.est
+share/idzebra-2.0/tab/gils-summary.map
+share/idzebra-2.0/tab/gils-usmarc.map
+share/idzebra-2.0/tab/gils-variant.est
+share/idzebra-2.0/tab/hci.flt
+share/idzebra-2.0/tab/icu.idx
+share/idzebra-2.0/tab/idxpath.att
+share/idzebra-2.0/tab/mail.flt
+share/idzebra-2.0/tab/marc21.abs
+share/idzebra-2.0/tab/meta.abs
+share/idzebra-2.0/tab/meta.tag
+share/idzebra-2.0/tab/meta-b.est
+share/idzebra-2.0/tab/meta-usmarc.map
+share/idzebra-2.0/tab/news.flt
+share/idzebra-2.0/tab/numeric.chr
+share/idzebra-2.0/tab/nwi.flt
+share/idzebra-2.0/tab/phrases-icu.xml
+share/idzebra-2.0/tab/refer.flt
+share/idzebra-2.0/tab/scan.chr
+share/idzebra-2.0/tab/sgml.flt
+share/idzebra-2.0/tab/soif.flt
+share/idzebra-2.0/tab/string.chr
+share/idzebra-2.0/tab/summary.abs
+share/idzebra-2.0/tab/summary.tag
+share/idzebra-2.0/tab/tagsetg.tag
+share/idzebra-2.0/tab/tagsetm.tag
+share/idzebra-2.0/tab/urx.chr
+share/idzebra-2.0/tab/usmarc.abs
+share/idzebra-2.0/tab/usmarc.flt
+share/idzebra-2.0/tab/usmarc.mar
+share/idzebra-2.0/tab/usmarc.tag
+share/idzebra-2.0/tab/usmarc-b.est
+share/idzebra-2.0/tab/var1.var
+share/idzebra-2.0/tab/wais.abs
+share/idzebra-2.0/tab/wais-b.est
+share/idzebra-2.0/tab/wais-variant.est
+share/idzebra-2.0/tab/words-icu.xml
+share/idzebra-2.0/tab/words-icu-da.xml
+@dirrm share/idzebra-2.0/tab
+@dirrm share/idzebra-2.0-examples/oai-pmh/data
+@dirrm share/idzebra-2.0-examples/oai-pmh/conf
+@dirrm share/idzebra-2.0-examples/oai-pmh
+@dirrm share/idzebra-2.0-examples
+@dirrm share/idzebra-2.0
+@dirrm share/doc/idzebra-2.0/common
+@dirrm share/doc/idzebra-2.0
+@dirrm lib/idzebra-2.0/modules
+@dirrm lib/idzebra-2.0
+@dirrm include/idzebra-2.0/idzebra
+@dirrm include/idzebra-2.0