aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-02-21 20:12:10 +0000
committerClement Laforet <clement@FreeBSD.org>2004-02-21 20:12:10 +0000
commitb86ecbf5fa704f7ad55d794ce316617d8dbac41c (patch)
treeb66a12d9160252ebb37c1d2779581fb5438e2dc0 /net
parentbd88a3e9d456011a614beedc00cc11d285ee46d5 (diff)
downloadports-b86ecbf5fa704f7ad55d794ce316617d8dbac41c.tar.gz
ports-b86ecbf5fa704f7ad55d794ce316617d8dbac41c.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/delegate/Makefile25
-rw-r--r--net/delegate/pkg-message9
2 files changed, 34 insertions, 0 deletions
diff --git a/net/delegate/Makefile b/net/delegate/Makefile
index 60709d690eb5..be38989a7bad 100644
--- a/net/delegate/Makefile
+++ b/net/delegate/Makefile
@@ -20,6 +20,31 @@ IS_INTERACTIVE= YES
PORTDOCS= Manual.htm tutor-jp.htm tutor-en.htm
PLIST_FILES= sbin/delegated etc/rc.d/delegated.sh-dist
+pre-everything::
+.if !defined(FORCE_BUILD) || ${FORCE_BUILD}!="YES"
+ @${ECHO_MSG} "*********************************************************************"
+ @${ECHO_MSG} "* WARNING! WARNING! WARNING! WARNING! WARNING! *"
+ @${ECHO_MSG} "* This program has known security problems which may allow a remote *"
+ @${ECHO_MSG} "* attacker to take control of your machine. *"
+ @${ECHO_MSG} "* See FreeBSD security advisory 00:04 for more information. *"
+ @${ECHO_MSG} "* *"
+ @${ECHO_MSG} "* It is strongly recommended that you avoid using this program. *"
+ @${ECHO_MSG} "* *"
+ @${ECHO_MSG} "* If you would like to use this program despite the danger, run *"
+ @${ECHO_MSG} "* make with \`\`FORCE_BUILD=YES'' *"
+ @${ECHO_MSG} "* WARNING! WARNING! WARNING! WARNING! WARNING! *"
+ @${ECHO_MSG} "*********************************************************************"
+ @${FALSE}
+.else
+ @${ECHO_MSG} "*********************************************************************"
+ @${ECHO_MSG} "* WARNING! WARNING! WARNING! WARNING! WARNING! *"
+ @${ECHO_MSG} "* You have chosen to build an insecure program. *"
+ @${ECHO_MSG} "* This program has known security problems which may allow a remote *"
+ @${ECHO_MSG} "* attacker to take control of your machine. *"
+ @${ECHO_MSG} "* See FreeBSD security advisory 00:04 for more information. *"
+ @${ECHO_MSG} "*********************************************************************"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/delegated ${PREFIX}/sbin
${INSTALL_SCRIPT} ${FILESDIR}/delegated.sh \
diff --git a/net/delegate/pkg-message b/net/delegate/pkg-message
index 45e96402731b..fda910d96560 100644
--- a/net/delegate/pkg-message
+++ b/net/delegate/pkg-message
@@ -1,3 +1,12 @@
+*********************************************************************
+* WARNING! WARNING! WARNING! WARNING! WARNING! *
+* You have installed an insecure program. *
+* This program has known security problems which may allow a remote *
+* attacker to take control of your machine. *
+* Use with great caution! *
+* See FreeBSD security advisory 00:04 for more information. *
+*********************************************************************
+
----------------------------------------------------------------------
Now, edit the sample script in /usr/local/share/examples/delegate directory
and copy it into /usr/local/etc/rc.d.