aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2003-12-07 05:34:23 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2003-12-07 05:34:23 +0000
commit8912357fcfa17b75661517a6922e6bde0c7b31ce (patch)
treec91d3ec63bbc07a4088742d3989c7dee8c43dc08 /net
parent390f3adbe8febdb397204b37ad01a68f37d820eb (diff)
downloadports-8912357fcfa17b75661517a6922e6bde0c7b31ce.tar.gz
ports-8912357fcfa17b75661517a6922e6bde0c7b31ce.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/nvnet/.Makefile.swpbin0 -> 12288 bytes
-rw-r--r--net/nvnet/Makefile60
-rw-r--r--net/nvnet/distinfo2
-rw-r--r--net/nvnet/pkg-descr7
-rw-r--r--net/nvnet/pkg-message7
-rw-r--r--net/nvnet/pkg-plist8
7 files changed, 85 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index bfa56d7dd5b3..dd8e11bb6ef1 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -389,6 +389,7 @@
SUBDIR += ntp
SUBDIR += ntp-devel
SUBDIR += nttcp
+ SUBDIR += nvnet
SUBDIR += nylon
SUBDIR += obnc
SUBDIR += ocaml-jabbr
diff --git a/net/nvnet/.Makefile.swp b/net/nvnet/.Makefile.swp
new file mode 100644
index 000000000000..145f1c8ebe77
--- /dev/null
+++ b/net/nvnet/.Makefile.swp
Binary files differ
diff --git a/net/nvnet/Makefile b/net/nvnet/Makefile
new file mode 100644
index 000000000000..1c77a94097c6
--- /dev/null
+++ b/net/nvnet/Makefile
@@ -0,0 +1,60 @@
+# Ports collection makefile for: nvnet
+#
+# Date created: 1 Oct 2003
+# Whom: Quinton Dolan <q@onthenet.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nvnet
+PORTVERSION= 1.0.${NVVERSION}
+PORTREVISION?= 0
+CATEGORIES= net
+MASTER_SITES= http://download.nvidia.com/XFree86/nforce/1.0-${NVVERSION}/:nvidia \
+ ftp://download.nvidia.com/XFree86/nforce/1.0-${NVVERSION}/:nvidia \
+ http://download1.nvidia.com/XFree86/nforce/1.0-${NVVERSION}/:nvidia \
+ ftp://download1.nvidia.com/XFree86/nforce/1.0-${NVVERSION}/:nvidia \
+ http://www.onthenet.com.au/~q/nvnet/:nvnet
+DISTFILES= NVIDIA_nforce-1.0-${NVVERSION}${EXTRACT_SUFX}:nvidia \
+ nvnet-src-${NVNETVERSION}${EXTRACT_SUFX}:nvnet
+
+MAINTAINER= q@onthenet.com.au
+COMMENT= Driver for NVIDIA MCP Ethernet adapter
+
+NVVERSION= 0261
+NVNETVERSION= 20031108
+
+ONLY_FOR_ARCHS= i386
+WRKSRC= ${WRKDIR}/nvnet
+MAN4= nvnet.4
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 480100 || ${OSVERSION} >= 500000 && ${OSVERSION} < 501000
+BROKEN= "Systems prior to FreeBSD 4.9 & 5.1 are not supported"
+.endif
+
+.if ${OSVERSION} < 500000
+PLIST_SUB+= FREEBSD5="@comment " FREEBSD4=""
+.else
+PLIST_SUB+= FREEBSD5="" FREEBSD4="@comment "
+.endif
+
+pre-fetch:
+.if !exists(${SRC_BASE}/sys/Makefile)
+ @${ECHO} "*************************************************"; \
+ ${ECHO} "This port requires the kernel source be available"; \
+ ${ECHO} "*************************************************"; \
+ exit 1
+.endif
+
+port-install:
+.if !defined(NOPORTSDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALLMAN} ${WRKSRC}/doc/README ${WRKSRC}/doc/nvidia_pci.c.diff \
+ ${DOCSDIR}
+.endif
+ ${INSTALLMAN} ${WRKSRC}/man/nvnet.4 ${PREFIX}/man/man4
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/net/nvnet/distinfo b/net/nvnet/distinfo
new file mode 100644
index 000000000000..8c501b53be3e
--- /dev/null
+++ b/net/nvnet/distinfo
@@ -0,0 +1,2 @@
+MD5 (NVIDIA_nforce-1.0-0261.tar.gz) = 19e9c6592e8db6ba55c08d42dc49163f
+MD5 (nvnet-src-20031108.tar.gz) = 7d404d47cbbd5a4fb9fba9fab121dbc6
diff --git a/net/nvnet/pkg-descr b/net/nvnet/pkg-descr
new file mode 100644
index 000000000000..313028893f36
--- /dev/null
+++ b/net/nvnet/pkg-descr
@@ -0,0 +1,7 @@
+This port contains a driver for the NVIDIA nForce MCP Ethernet adapter.
+It contains a wrapper that replaces the Linux nvnet.c, and links against
+the Linux binary only object file (nvnetlib.o) included in the NVIDIA
+driver source distribution.
+
+This should work on all nForce and nForce2 based motherboards that have
+the onboard MCP MAC enabled.
diff --git a/net/nvnet/pkg-message b/net/nvnet/pkg-message
new file mode 100644
index 000000000000..ce8efb6b10c8
--- /dev/null
+++ b/net/nvnet/pkg-message
@@ -0,0 +1,7 @@
+
+*******************************************************************************
+* This port contains a prebuilt kernel module. Due to the ever changing *
+* nature of FreeBSD it may be necessary to rebuild the module after a kernel *
+* source update. To do this reinstall the port. *
+*******************************************************************************
+
diff --git a/net/nvnet/pkg-plist b/net/nvnet/pkg-plist
new file mode 100644
index 000000000000..65f01f95b9e3
--- /dev/null
+++ b/net/nvnet/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+@comment We just copy the file in the kernel module dir.
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/nvidia_pci.c.diff
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%FREEBSD4%%@cwd /modules
+%%FREEBSD5%%@cwd /boot/kernel
+if_nv.ko