aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2009-10-01 12:31:37 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2009-10-01 12:31:37 +0000
commitd5569569b0adb2a5d094cd6311e345e77d976969 (patch)
tree23c000439e6066a2fd77aef1b147a4019d29a1c1 /net
parent8d6523908473f35120ca3f4d41a0775d78aebc5a (diff)
downloadports-d5569569b0adb2a5d094cd6311e345e77d976969.tar.gz
ports-d5569569b0adb2a5d094cd6311e345e77d976969.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/tcpdump398/Makefile34
-rw-r--r--net/tcpdump398/distinfo3
-rw-r--r--net/tcpdump398/pkg-descr6
4 files changed, 44 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index cc207a201916..33fd8dbdb5f8 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -959,6 +959,7 @@
SUBDIR += tcpcat
SUBDIR += tcpdstat
SUBDIR += tcpdump
+ SUBDIR += tcpdump398
SUBDIR += tcpflow
SUBDIR += tcpick
SUBDIR += tcpillust
diff --git a/net/tcpdump398/Makefile b/net/tcpdump398/Makefile
new file mode 100644
index 000000000000..0ea2c1ef90a0
--- /dev/null
+++ b/net/tcpdump398/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: tcpdump398
+# Date created: 1 October 2009
+# Whom: Edwin Groothuis <edwin@mavetju.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcpdump398
+PORTVERSION= 1.0
+CATEGORIES= net ipv6
+MASTER_SITES= http://www.mavetju.org/download/adopted/
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= Ubiquitous network traffic analysis tool - FreeBSD 7 version for FreeBSD 8
+
+PLIST_FILES= bin/tcpdump398
+MAN1= tcpdump398.1
+
+USE_BZIP2= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800000
+IGNORE= comes with the base OS, only applicable for 8.0 and higher
+.endif
+
+post-build:
+ ${GUNZIP_CMD} ${WRKSRC}/tcpdump.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tcpdump ${PREFIX}/bin/tcpdump398
+ ${INSTALL_MAN} ${WRKSRC}/tcpdump.1 ${MAN1PREFIX}/man/man1/tcpdump398.1
+
+.include <bsd.port.post.mk>
diff --git a/net/tcpdump398/distinfo b/net/tcpdump398/distinfo
new file mode 100644
index 000000000000..2464db8a941c
--- /dev/null
+++ b/net/tcpdump398/distinfo
@@ -0,0 +1,3 @@
+MD5 (tcpdump398-1.0.tar.bz2) = 1d0d5924baf7f2002dfa6415ae791705
+SHA256 (tcpdump398-1.0.tar.bz2) = d863b13a05b9153b556368c754839eb032fe778f5caedc3b47aeb012a657e57c
+SIZE (tcpdump398-1.0.tar.bz2) = 583024
diff --git a/net/tcpdump398/pkg-descr b/net/tcpdump398/pkg-descr
new file mode 100644
index 000000000000..1a8a03d86b9c
--- /dev/null
+++ b/net/tcpdump398/pkg-descr
@@ -0,0 +1,6 @@
+tcpdump is a ubiquitous network traffic capture tool available in a wide
+variety of BSD, Linux and UN*X distributions.
+
+This is the version 3.9.8 which is currently shipped with FreeBSD
+7. FreeBSD 8.0 is shipping with version 4.0.0 which gives a different
+output with some items missing.