aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2014-11-11 14:00:43 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2014-11-11 14:00:43 +0000
commitd8a48d8efbbde9ed75f7fd4e3747a49f7abe1a1d (patch)
treeac757f9f870e969c96f25798704a8dd4fc8bcb68 /net
parent42e01db0e2773bd90f429fb5777028fb1d0e3272 (diff)
downloadports-d8a48d8efbbde9ed75f7fd4e3747a49f7abe1a1d.tar.gz
ports-d8a48d8efbbde9ed75f7fd4e3747a49f7abe1a1d.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/asterisk/Makefile2
-rw-r--r--net/asterisk/distinfo4
-rw-r--r--net/asterisk/files/asterisk.in45
-rw-r--r--net/asterisk11/Makefile2
-rw-r--r--net/asterisk11/distinfo4
-rw-r--r--net/asterisk11/files/asterisk.in45
6 files changed, 64 insertions, 38 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 01782798e1f4..0dadab4ec855 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= asterisk
-PORTVERSION= 1.8.31.1
+PORTVERSION= 1.8.32.0
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
diff --git a/net/asterisk/distinfo b/net/asterisk/distinfo
index 80fb61c95b2b..5e09dd1f44c0 100644
--- a/net/asterisk/distinfo
+++ b/net/asterisk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (asterisk-1.8.31.1.tar.gz) = 430e095e937a29ec13e58c2cab6b8299caec5bbe7a6af0f396a9f29fbc926e7d
-SIZE (asterisk-1.8.31.1.tar.gz) = 29630590
+SHA256 (asterisk-1.8.32.0.tar.gz) = 37dee258431baf3ef726fb89f5d590b3e5498654f5080afed649697a0a227a8f
+SIZE (asterisk-1.8.32.0.tar.gz) = 29639709
diff --git a/net/asterisk/files/asterisk.in b/net/asterisk/files/asterisk.in
index 85dce3d6c84f..b8e24b5ee78b 100644
--- a/net/asterisk/files/asterisk.in
+++ b/net/asterisk/files/asterisk.in
@@ -9,35 +9,48 @@
#
# Add the following lines to /etc/rc.conf to enable asterisk:
#
-# asterisk_enable="YES"
+# asterisk_enable (bool): Set it to "YES" to enable asterisk
+# Default is "NO"
+# asterisk_user (string): User asterisk runs as
+# Default is %%ASTERISK_USER%%
+# asterisk_args (string): Extra argumeents to pass to asterisk at startup
+# Default is "-n"
+# asterisk_pidfile (string): Location of the asterisk pid file
+# Default is /var/run/asterisk/asterisk.pid
#
. /etc/rc.subr
name=asterisk
rcvar=asterisk_enable
+desc="Asterisk PBX server"
-extra_commands="reload"
+load_rc_config $name
+
+: ${asterisk_enable:=NO}
+: ${asterisk_user:=%%ASTERISK_USER%%}
+: ${asterisk_args=-n}
+: ${asterisk_pidfile:=/var/run/asterisk/asterisk.pid}
+
+extra_commands=reload
-stop_cmd="asterisk_stop"
-reload_cmd="asterisk_reload"
+stop_cmd=asterisk_stop
+reload_cmd=asterisk_reload
command="%%PREFIX%%/sbin/asterisk"
-command_args="-n -F -U %%ASTERISK_USER%%"
-pidfile=${asterisk_pidfile:-"/var/run/asterisk/asterisk.pid"}
+command_args="${asterisk_args} -F -U ${asterisk_user}"
+pidfile=${asterisk_pidfile}
-asterisk_stop() {
- echo 'Stopping asterisk'
- $command -nqrx 'core stop now'
+asterisk_stop()
+{
+ echo 'Stopping asterisk'
+ $command -nqrx 'core stop now'
}
-asterisk_reload() {
- echo 'Reloading asterisk'
- $command -nqrx 'reload'
+asterisk_reload()
+{
+ echo 'Reloading asterisk'
+ $command -nqrx 'reload'
}
-load_rc_config $name
-
-asterisk_enable=${asterisk_enable:-"NO"}
-
run_rc_command "$1"
diff --git a/net/asterisk11/Makefile b/net/asterisk11/Makefile
index 13098b86ad09..2d8df3e9d0d1 100644
--- a/net/asterisk11/Makefile
+++ b/net/asterisk11/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= asterisk
-PORTVERSION= 11.13.1
+PORTVERSION= 11.14.0
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
diff --git a/net/asterisk11/distinfo b/net/asterisk11/distinfo
index 32b1f882d64c..643b0e515957 100644
--- a/net/asterisk11/distinfo
+++ b/net/asterisk11/distinfo
@@ -1,2 +1,2 @@
-SHA256 (asterisk-11.13.1.tar.gz) = 382e914f3025f746d3a36cd218bc35f6a0f335b58226f35eaf4cc664b228d351
-SIZE (asterisk-11.13.1.tar.gz) = 34959077
+SHA256 (asterisk-11.14.0.tar.gz) = ad4710aba7f21c75bf1d16159a349034a04d3d36895243c262059a89f892098a
+SIZE (asterisk-11.14.0.tar.gz) = 34975152
diff --git a/net/asterisk11/files/asterisk.in b/net/asterisk11/files/asterisk.in
index 85dce3d6c84f..b8e24b5ee78b 100644
--- a/net/asterisk11/files/asterisk.in
+++ b/net/asterisk11/files/asterisk.in
@@ -9,35 +9,48 @@
#
# Add the following lines to /etc/rc.conf to enable asterisk:
#
-# asterisk_enable="YES"
+# asterisk_enable (bool): Set it to "YES" to enable asterisk
+# Default is "NO"
+# asterisk_user (string): User asterisk runs as
+# Default is %%ASTERISK_USER%%
+# asterisk_args (string): Extra argumeents to pass to asterisk at startup
+# Default is "-n"
+# asterisk_pidfile (string): Location of the asterisk pid file
+# Default is /var/run/asterisk/asterisk.pid
#
. /etc/rc.subr
name=asterisk
rcvar=asterisk_enable
+desc="Asterisk PBX server"
-extra_commands="reload"
+load_rc_config $name
+
+: ${asterisk_enable:=NO}
+: ${asterisk_user:=%%ASTERISK_USER%%}
+: ${asterisk_args=-n}
+: ${asterisk_pidfile:=/var/run/asterisk/asterisk.pid}
+
+extra_commands=reload
-stop_cmd="asterisk_stop"
-reload_cmd="asterisk_reload"
+stop_cmd=asterisk_stop
+reload_cmd=asterisk_reload
command="%%PREFIX%%/sbin/asterisk"
-command_args="-n -F -U %%ASTERISK_USER%%"
-pidfile=${asterisk_pidfile:-"/var/run/asterisk/asterisk.pid"}
+command_args="${asterisk_args} -F -U ${asterisk_user}"
+pidfile=${asterisk_pidfile}
-asterisk_stop() {
- echo 'Stopping asterisk'
- $command -nqrx 'core stop now'
+asterisk_stop()
+{
+ echo 'Stopping asterisk'
+ $command -nqrx 'core stop now'
}
-asterisk_reload() {
- echo 'Reloading asterisk'
- $command -nqrx 'reload'
+asterisk_reload()
+{
+ echo 'Reloading asterisk'
+ $command -nqrx 'reload'
}
-load_rc_config $name
-
-asterisk_enable=${asterisk_enable:-"NO"}
-
run_rc_command "$1"