aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2021-01-25 18:04:29 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2021-01-25 18:04:29 +0000
commit0430e830e666550924ecbb251f995bd21c80bd6c (patch)
tree02944717e89bdc818d2ff4a4f38e3912d655fc10 /net
parent9adb4239058a6dcd73b5cab053a7b8d3453297d2 (diff)
downloadports-0430e830e666550924ecbb251f995bd21c80bd6c.tar.gz
ports-0430e830e666550924ecbb251f995bd21c80bd6c.zip
MFH: r562593
- Add unconditional dependency on gcrypt and libgpg-error to ndpi and ntopng to ensure full feature set [1] - Patch ntopng to link correctly with libgcrypt - While here, update ntopng to latest upstream snapshot PR: 252935 [1] Submitted by: Franco Fichtner <franco@opnsense.org>
Notes
Notes: svn path=/branches/2021Q1/; revision=562594
Diffstat (limited to 'net')
-rw-r--r--net/ndpi/Makefile5
-rw-r--r--net/ntopng/Makefile8
-rw-r--r--net/ntopng/distinfo6
-rw-r--r--net/ntopng/files/patch-configure.seed11
4 files changed, 22 insertions, 8 deletions
diff --git a/net/ndpi/Makefile b/net/ndpi/Makefile
index 8552791d03cc..a4f6bd384984 100644
--- a/net/ndpi/Makefile
+++ b/net/ndpi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ndpi
PORTVERSION= 3.4.d20201222
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net
@@ -12,7 +13,9 @@ COMMENT= NTOP-maintained superset of the popular OpenDPI library
LICENSE= LGPL3+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libjson-c.so:devel/json-c
+LIB_DEPENDS= libjson-c.so:devel/json-c \
+ libgcrypt.so:security/libgcrypt \
+ libgpg-error.so:security/libgpg-error
USES= autoreconf compiler:c++11-lang libtool localbase:ldflags pathfix \
pkgconfig
diff --git a/net/ntopng/Makefile b/net/ntopng/Makefile
index dbb3cab2256c..e280a4c8247b 100644
--- a/net/ntopng/Makefile
+++ b/net/ntopng/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ntopng
-PORTVERSION= 4.2.d20201228
+PORTVERSION= 4.2.d20210122
PORTEPOCH= 1
CATEGORIES= net
@@ -20,7 +20,9 @@ LIB_DEPENDS= librrd.so:databases/rrdtool \
libsodium.so:security/libsodium \
libmaxminddb.so:net/libmaxminddb \
libexpat.so:textproc/expat2 \
- libzstd.so:archivers/zstd
+ libzstd.so:archivers/zstd \
+ libgcrypt.so:security/libgcrypt \
+ libgpg-error.so:security/libgpg-error
BUILD_DEPENDS= bash:shells/bash
USES= autoreconf compiler:c++11-lang cpe gmake libtool localbase \
@@ -38,7 +40,7 @@ PLIST_SUB= NTOPNGUSER="${USERS}" NTOPNGROUP="${GROUPS}"
USE_GITHUB= yes
GH_ACCOUNT= ntop
-GH_TAGNAME= d2f4f8f
+GH_TAGNAME= e91b1b5
CPE_VENDOR= ntop
diff --git a/net/ntopng/distinfo b/net/ntopng/distinfo
index 5e0bafe7bfd9..5b21b518b7be 100644
--- a/net/ntopng/distinfo
+++ b/net/ntopng/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1609190757
-SHA256 (ntop-ntopng-4.2.d20201228-d2f4f8f_GH0.tar.gz) = 041547feccd82237d3e8df0a75b163a9712248675a4d8117983719ffc5e61bd8
-SIZE (ntop-ntopng-4.2.d20201228-d2f4f8f_GH0.tar.gz) = 57560717
+TIMESTAMP = 1611571552
+SHA256 (ntop-ntopng-4.2.d20210122-e91b1b5_GH0.tar.gz) = cab743b41b2db631d3134e6745f8328261b13c0cb5cda3d9260fd26ae712f39e
+SIZE (ntop-ntopng-4.2.d20210122-e91b1b5_GH0.tar.gz) = 57562463
diff --git a/net/ntopng/files/patch-configure.seed b/net/ntopng/files/patch-configure.seed
index 37eb02b50e14..a5334077adce 100644
--- a/net/ntopng/files/patch-configure.seed
+++ b/net/ntopng/files/patch-configure.seed
@@ -1,4 +1,4 @@
---- configure.seed.orig 2020-11-02 21:27:19 UTC
+--- configure.seed.orig 2021-01-22 10:38:16 UTC
+++ configure.seed
@@ -4,7 +4,7 @@ dnl> Do not add anything above
@@ -44,6 +44,15 @@
SHORT_MACHINE=`uname -m | cut -b1-3`
GIT_RELEASE="@GIT_RELEASE@"
+@@ -233,7 +208,7 @@ else
+ fi
+ fi
+
+-AC_CHECK_LIB([gcrypt], [gcry_cipher_checktag], [LDFLAGS="${LDFLAGS} -lgcrypt"])
++AC_CHECK_LIB([gcrypt], [gcry_cipher_checktag], [LDFLAGS="${LDFLAGS} -lgcrypt -lgpg-error"])
+
+ AC_MSG_CHECKING(for ntopng professional edition)
+
@@ -678,16 +653,6 @@ AC_DEFINE_UNQUOTED(_CRT_SECURE_NO_WARNINGS, 1, [Disabl
GMAKE=`which gmake`
if test x$GMAKE = x; then