aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2004-04-05 02:29:43 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2004-04-05 02:29:43 +0000
commitf6eb47e159cf0632023f8246d62466c4602b1487 (patch)
tree1e8fbe12e03a2ca7919f2d69626f4fc37c6da46e /net
parente50209a594fc084075273bc1bda8b3a716bd9370 (diff)
downloadports-f6eb47e159cf0632023f8246d62466c4602b1487.tar.gz
ports-f6eb47e159cf0632023f8246d62466c4602b1487.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/pdtpd/Makefile26
-rw-r--r--net/pdtpd/distinfo2
-rw-r--r--net/pdtpd/pkg-descr8
-rw-r--r--net/pdtpd/pkg-plist6
5 files changed, 43 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 693eb5e1dd19..af3208fdbd43 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -476,6 +476,7 @@
SUBDIR += pbnc
SUBDIR += pchar
SUBDIR += pcnfsd
+ SUBDIR += pdtpd
SUBDIR += pear-Net_NNTP
SUBDIR += pear-Net_SMTP
SUBDIR += pear-Net_Sieve
diff --git a/net/pdtpd/Makefile b/net/pdtpd/Makefile
new file mode 100644
index 000000000000..fde789218ba4
--- /dev/null
+++ b/net/pdtpd/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: pdtpd
+# Date created: 5 Apr 2004
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdtpd
+PORTVERSION= 0.1.20040404
+CATEGORIES= net
+MASTER_SITES= http://people.FreeBSD.org/~kuriyama/distfiles/
+DISTNAME= ${PORTNAME}-20040404
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Server for the Peer Distributed Transfer Protocol (PDTP)
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+STRIP= # Keep empty for debugging.
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pdtpd/pdtpd ${PREFIX}/sbin/pdtpd
+ ${INSTALL_PROGRAM} ${WRKSRC}/pdtpss/pdtpss ${PREFIX}/sbin/pdtpss
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/net/pdtpd/distinfo b/net/pdtpd/distinfo
new file mode 100644
index 000000000000..39c3412f6006
--- /dev/null
+++ b/net/pdtpd/distinfo
@@ -0,0 +1,2 @@
+MD5 (pdtpd-20040404.tar.gz) = 7c33461859c056874869966b99d42552
+SIZE (pdtpd-20040404.tar.gz) = 70794
diff --git a/net/pdtpd/pkg-descr b/net/pdtpd/pkg-descr
new file mode 100644
index 000000000000..dc06ae2cb5d3
--- /dev/null
+++ b/net/pdtpd/pkg-descr
@@ -0,0 +1,8 @@
+pdtpd is a server for the Peer Distributed Transfer Protocol (PDTP),
+a BitTorrent-like protocol with stricter server control and support
+for exporting large, changing hierarchical filesystems (i.e. more akin
+to HTTP/FTP).
+
+For a more thorough description of PDTP, see http://www.pdtp.org/.
+
+WWW: http://pdtpd.sourceforge.net/
diff --git a/net/pdtpd/pkg-plist b/net/pdtpd/pkg-plist
new file mode 100644
index 000000000000..6abd75620e42
--- /dev/null
+++ b/net/pdtpd/pkg-plist
@@ -0,0 +1,6 @@
+sbin/pdtpd
+sbin/pdtpss
+%%DOCSDIR%%/protocol.txt
+%%DOCSDIR%%/transactions.txt
+%%DOCSDIR%%/transfer_specification.txt
+@dirrm %%DOCSDIR%%