aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2020-05-23 06:43:19 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2020-05-23 06:43:19 +0000
commit0cf68837cd2c3e97ce2f4167bbd856c91b419a43 (patch)
tree543c112748734d0c7a917c4a8f098d310ce26904 /net
parent7d2b3c7cc627a8e3a44639a39d8b2c7fc788cbb9 (diff)
downloadports-0cf68837cd2c3e97ce2f4167bbd856c91b419a43.tar.gz
ports-0cf68837cd2c3e97ce2f4167bbd856c91b419a43.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/pichi/Makefile28
-rw-r--r--net/pichi/distinfo4
-rw-r--r--net/pichi/files/patch-CMakeLists.txt17
-rw-r--r--net/pichi/files/patch-cmake_ProcessOptions.cmake8
-rw-r--r--net/pichi/files/patch-include_config.h.in11
-rw-r--r--net/pichi/files/patch-src_net_asio.cpp17
-rw-r--r--net/pichi/pkg-plist44
7 files changed, 56 insertions, 73 deletions
diff --git a/net/pichi/Makefile b/net/pichi/Makefile
index 46705b6071a2..e7d2f389a126 100644
--- a/net/pichi/Makefile
+++ b/net/pichi/Makefile
@@ -1,12 +1,11 @@
# $FreeBSD$
PORTNAME= pichi
-DISTVERSION= 1.2.0
-PORTREVISION= 1
+DISTVERSION= 1.3.0
CATEGORIES= net
MAINTAINER= pichi@elude.in
-COMMENT= Application Layer Proxy controlled via RESTful APIs
+COMMENT= Flexible rule-based proxy
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -22,20 +21,19 @@ USE_RC_SUBR= pichi
PLIST_SUB= DISTVERSION=${DISTVERSION}
CMAKE_BUILD_TYPE= MinSizeRel
-CMAKE_ARGS= -DVERSION=${DISTVERSION}
-CMAKE_ON= BUILD_SERVER BUILD_TEST
-CMAKE_OFF= INSTALL_HEADERS
-INSTALL_TARGET= install/strip
-TEST_TARGET= test
+CMAKE_ARGS= -DVERSION=${DISTVERSION}
+CMAKE_ON= BUILD_SERVER BUILD_TEST
+INSTALL_TARGET= install/strip
+TEST_TARGET= test
-OPTIONS_DEFINE= STATIC TLS
+OPTIONS_DEFINE= DEVEL STATIC TLS
OPTIONS_DEFAULT= TLS
OPTIONS_SUB= yes
TLS_DESC= Enable TLS support ( requiring OpenSSL )
TLS_CMAKE_BOOL= ENABLE_TLS
-STATIC_DESC= Build/Install static library
+STATIC_DESC= Static linking
STATIC_CMAKE_BOOL= STATIC_LINK
STATIC_BUILD_DEPENDS= boost-libs>=1.67.0:devel/boost-libs \
libmaxminddb>=1.3.0:net/libmaxminddb \
@@ -50,12 +48,12 @@ STATIC_LIB_DEPENDS_OFF= libboost_context.so:devel/boost-libs \
libmbedtls.so:security/mbedtls \
libmbedx509.so:security/mbedtls \
libsodium.so:security/libsodium
+STATIC_USE_OFF= LDCONFIG=yes
-.include <bsd.port.options.mk>
+DEVEL_DESC= Install development files
+DEVEL_CMAKE_BOOL= INSTALL_DEVEL
-.if ! ${PORT_OPTIONS:MSTATIC}
-USE_LDCONFIG= yes
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTLS}
.if ${PORT_OPTIONS:MSTATIC}
@@ -69,6 +67,8 @@ post-install:
${MKDIR} ${STAGEDIR}${ETCDIR}
${INSTALL_DATA} ${WRKSRC}/test/geo.mmdb ${STAGEDIR}${ETCDIR}/geo.mmdb
${INSTALL_DATA} ${WRKSRC}/server/pichi.json.default ${STAGEDIR}${ETCDIR}/pichi.json.sample
+
+post-install-DEVEL-on:
${MKDIR} ${STAGEDIR}${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/include/pichi.h ${STAGEDIR}${PREFIX}/include/pichi.h
diff --git a/net/pichi/distinfo b/net/pichi/distinfo
index 7042a8e4d793..2543ae176798 100644
--- a/net/pichi/distinfo
+++ b/net/pichi/distinfo
@@ -1,3 +1,3 @@
TIMESTAMP = 1554899633
-SHA256 (pichi-router-pichi-1.2.0_GH0.tar.gz) = 8965077371f2dbf49a63659d686470c191c2c21c47a32f44b3b8bb2d72968043
-SIZE (pichi-router-pichi-1.2.0_GH0.tar.gz) = 1841049
+SHA256 (pichi-router-pichi-1.3.0_GH0.tar.gz) = f5686a1e7c98d9c9eca88d88af53b85648ceeff9aa33bf2b1d95a09462d74d1c
+SIZE (pichi-router-pichi-1.3.0_GH0.tar.gz) = 2066723
diff --git a/net/pichi/files/patch-CMakeLists.txt b/net/pichi/files/patch-CMakeLists.txt
deleted file mode 100644
index 72d6d76b859c..000000000000
--- a/net/pichi/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,17 +0,0 @@
---- CMakeLists.txt.orig 2019-04-14 16:29:43 UTC
-+++ CMakeLists.txt
-@@ -19,6 +19,14 @@ find_package(MaxmindDB 1.3.0 REQUIRED)
- find_package(Rapidjson 1.1.0 REQUIRED)
- find_package(Threads REQUIRED)
-
-+if (Boost_VERSION_STRING VERSION_LESS "1.70.0")
-+ set(RESOLVER_CONSTRUCTED_FROM_EXECUTOR OFF)
-+else (Boost_VERSION_STRING VERSION_LESS "1.70.0")
-+ set(RESOLVER_CONSTRUCTED_FROM_EXECUTOR ON)
-+endif (Boost_VERSION_STRING VERSION_LESS "1.70.0")
-+
-+configure_file(${CMAKE_SOURCE_DIR}/include/config.h.in ${CMAKE_BINARY_DIR}/include/config.h)
-+
- include_directories(
- ${CMAKE_SOURCE_DIR}/include
- ${CMAKE_BINARY_DIR}/include
diff --git a/net/pichi/files/patch-cmake_ProcessOptions.cmake b/net/pichi/files/patch-cmake_ProcessOptions.cmake
deleted file mode 100644
index 7b52654906fd..000000000000
--- a/net/pichi/files/patch-cmake_ProcessOptions.cmake
+++ /dev/null
@@ -1,8 +0,0 @@
---- cmake/ProcessOptions.cmake.orig 2019-04-14 16:29:43 UTC
-+++ cmake/ProcessOptions.cmake
-@@ -83,5 +83,3 @@ if (BUILD_SERVER)
- check_function_exists("setsid" HAS_SETSID)
- check_function_exists("close" HAS_CLOSE)
- endif (BUILD_SERVER)
--
--configure_file(${CMAKE_SOURCE_DIR}/include/config.h.in ${CMAKE_BINARY_DIR}/include/config.h)
diff --git a/net/pichi/files/patch-include_config.h.in b/net/pichi/files/patch-include_config.h.in
deleted file mode 100644
index 44bbc0b849c8..000000000000
--- a/net/pichi/files/patch-include_config.h.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/config.h.in.orig 2019-04-14 16:29:43 UTC
-+++ include/config.h.in
-@@ -13,6 +13,8 @@
- #cmakedefine HAS_SETSID
- #cmakedefine HAS_CLOSE
-
-+#cmakedefine RESOLVER_CONSTRUCTED_FROM_EXECUTOR
-+
- #cmakedefine CMAKE_INSTALL_PREFIX "@CMAKE_INSTALL_PREFIX@"
-
- #ifdef CMAKE_INSTALL_PREFIX
diff --git a/net/pichi/files/patch-src_net_asio.cpp b/net/pichi/files/patch-src_net_asio.cpp
deleted file mode 100644
index 9d8a900c2df3..000000000000
--- a/net/pichi/files/patch-src_net_asio.cpp
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/net/asio.cpp.orig 2019-04-14 16:29:43 UTC
-+++ src/net/asio.cpp
-@@ -79,8 +79,12 @@ void connect(Endpoint const& endpoint, Socket& s, Yiel
- else
- #endif // BUILD_TEST
- asio::async_connect(s,
-- tcp::resolver{s.get_executor().context()}.async_resolve(
-- endpoint.host_, endpoint.port_, yield),
-+ tcp::resolver{s.get_executor()
-+#ifndef RESOLVER_CONSTRUCTED_FROM_EXECUTOR
-+ .context()
-+#endif // RESOLVER_CONSTRUCTED_FROM_EXECUTOR
-+ }
-+ .async_resolve(endpoint.host_, endpoint.port_, yield),
- yield);
- }
-
diff --git a/net/pichi/pkg-plist b/net/pichi/pkg-plist
index fb151fec72f3..a593cc3812be 100644
--- a/net/pichi/pkg-plist
+++ b/net/pichi/pkg-plist
@@ -1,7 +1,43 @@
bin/pichi
-include/pichi.h
-@sample etc/pichi/pichi.json.sample
-etc/pichi/geo.mmdb
+%%ETCDIR%%/geo.mmdb
+@sample %%ETCDIR%%/pichi.json.sample
%%NO_STATIC%%lib/libpichi.so.%%DISTVERSION%%
%%NO_STATIC%%lib/libpichi.so
-%%STATIC%%lib/libpichi.a
+%%STATIC%%%%DEVEL%%lib/libpichi.a
+%%DEVEL%%include/boost/asio/spawn2.hpp
+%%DEVEL%%include/pichi/api/balancer.hpp
+%%DEVEL%%include/pichi/api/egress_manager.hpp
+%%DEVEL%%include/pichi/api/ingress_holder.hpp
+%%DEVEL%%include/pichi/api/ingress_manager.hpp
+%%DEVEL%%include/pichi/api/iterator.hpp
+%%DEVEL%%include/pichi/api/rest.hpp
+%%DEVEL%%include/pichi/api/router.hpp
+%%DEVEL%%include/pichi/api/server.hpp
+%%DEVEL%%include/pichi/api/session.hpp
+%%DEVEL%%include/pichi/api/vos.hpp
+%%DEVEL%%include/pichi/asserts.hpp
+%%DEVEL%%include/pichi/buffer.hpp
+%%DEVEL%%include/pichi/common.hpp
+%%DEVEL%%include/pichi/config.hpp
+%%DEVEL%%include/pichi/crypto/aead.hpp
+%%DEVEL%%include/pichi/crypto/base64.hpp
+%%DEVEL%%include/pichi/crypto/hash.hpp
+%%DEVEL%%include/pichi/crypto/key.hpp
+%%DEVEL%%include/pichi/crypto/method.hpp
+%%DEVEL%%include/pichi/crypto/stream.hpp
+%%DEVEL%%include/pichi/exception.hpp
+%%DEVEL%%include/pichi/net/adapter.hpp
+%%DEVEL%%include/pichi/net/asio.hpp
+%%DEVEL%%include/pichi/net/common.hpp
+%%DEVEL%%include/pichi/net/direct.hpp
+%%DEVEL%%include/pichi/net/helpers.hpp
+%%DEVEL%%include/pichi/net/http.hpp
+%%DEVEL%%include/pichi/net/reject.hpp
+%%DEVEL%%include/pichi/net/socks5.hpp
+%%DEVEL%%include/pichi/net/spawn.hpp
+%%DEVEL%%include/pichi/net/ssaead.hpp
+%%DEVEL%%include/pichi/net/ssstream.hpp
+%%DEVEL%%include/pichi/net/tunnel.hpp
+%%DEVEL%%include/pichi/test/socket.hpp
+%%DEVEL%%include/pichi/uri.hpp
+%%DEVEL%%include/pichi.h