aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-05-22 13:15:13 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-05-22 13:15:13 +0000
commit8dcaabcd6e5bd17c58c938ffb4b9f2fd7847f70f (patch)
treec832b87b776a5db072088687b910601d961726da /net
parent28466ca6896a9f7861111b79fdc8dee8b166ba06 (diff)
downloadports-8dcaabcd6e5bd17c58c938ffb4b9f2fd7847f70f.tar.gz
ports-8dcaabcd6e5bd17c58c938ffb4b9f2fd7847f70f.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/dpdk/Makefile2
-rw-r--r--net/exabgp/Makefile2
-rw-r--r--net/google-cloud-sdk/Makefile2
-rw-r--r--net/kippo/Makefile6
-rw-r--r--net/ntop/Makefile2
-rw-r--r--net/py-kombu/Makefile2
-rw-r--r--net/rabbitmq-c-devel/Makefile2
-rw-r--r--net/rabbitmq-c/Makefile2
-rw-r--r--net/rabbitmq/Makefile2
-rw-r--r--net/scribe/Makefile2
10 files changed, 12 insertions, 12 deletions
diff --git a/net/dpdk/Makefile b/net/dpdk/Makefile
index 510bbe51e194..19ae3057b737 100644
--- a/net/dpdk/Makefile
+++ b/net/dpdk/Makefile
@@ -28,7 +28,7 @@ DEBUG_DESC= Debugging support (unoptimized build, impacts performance)
TOOLS_DESC= Install tool scripts
DEBUG_MAKE_ENV= EXTRA_CFLAGS='-O0 -g'
-TOOLS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyelftools>=0:devel/py-pyelftools
+TOOLS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyelftools>=0:devel/py-pyelftools@${PY_FLAVOR}
TOOLS_USES= python:2.7
# build up the list of files in the compiled directory that should be executable
diff --git a/net/exabgp/Makefile b/net/exabgp/Makefile
index 1f2e2397fd2f..b6857f0f6743 100644
--- a/net/exabgp/Makefile
+++ b/net/exabgp/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= GH \
MAINTAINER= zi@FreeBSD.org
COMMENT= BGP engine and route injector
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ipaddress>0:net/py-ipaddress
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ipaddress>0:net/py-ipaddress@${PY_FLAVOR}
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
diff --git a/net/google-cloud-sdk/Makefile b/net/google-cloud-sdk/Makefile
index 0bcc02463323..678e906c76df 100644
--- a/net/google-cloud-sdk/Makefile
+++ b/net/google-cloud-sdk/Makefile
@@ -16,7 +16,7 @@ WRKSRC= ${WRKDIR}/google-cloud-sdk
PLIST_FILES= bin/bq bin/gcloud bin/git-credential-gcloud.sh bin/gsutil
RUN_DEPENDS= python:lang/python \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
post-extract:
@${RM} -r \
diff --git a/net/kippo/Makefile b/net/kippo/Makefile
index 1f535e08a9c7..1af1e77a444a 100644
--- a/net/kippo/Makefile
+++ b/net/kippo/Makefile
@@ -12,9 +12,9 @@ COMMENT= Medium interaction ssh honeypot
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto \
- ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted \
- ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface@${PY_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_GITHUB= yes
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index 973bcf2a1a53..06e9b3e18054 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -65,7 +65,7 @@ XMLDUMP_CPPFLAGS= -I${LOCALBASE}/include/libxml2 \
# see http://www.cyberciti.biz/faq/freebsd-jumbo-frames-networking-configration/
JUMBO_FRAMES_CONFIGURE_ON= --enable-jumbo-frames
-MAKO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mako>0:textproc/py-mako
+MAKO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mako>0:textproc/py-mako@${PY_FLAVOR}
pre-configure:
@(cd ${WRKSRC} && ./autogen.sh --noconfig)
diff --git a/net/py-kombu/Makefile b/net/py-kombu/Makefile
index 544a20594e07..503d2c00b63f 100644
--- a/net/py-kombu/Makefile
+++ b/net/py-kombu/Makefile
@@ -26,7 +26,7 @@ ZMQ_DESC= Include ZMQ transport support
BEANSTALK_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beanstalkc>0:net/py-beanstalkc@${FLAVOR}
BOTO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto>=2.6.0:devel/py-boto@${FLAVOR}
-MONGODB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pymongo>0:databases/pymongo
+MONGODB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pymongo>0:databases/pymongo@${PY_FLAVOR}
REDIS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}redis>0:databases/py-redis@${FLAVOR}
SQLALCHEMY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>0:databases/py-sqlalchemy10@${FLAVOR}
ZMQ_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyzmq>=13.1.0:net/py-pyzmq@${FLAVOR}
diff --git a/net/rabbitmq-c-devel/Makefile b/net/rabbitmq-c-devel/Makefile
index cf05d7871e87..57215afbc85b 100644
--- a/net/rabbitmq-c-devel/Makefile
+++ b/net/rabbitmq-c-devel/Makefile
@@ -14,7 +14,7 @@ COMMENT= RabbitMQ C AMQP client library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE-MIT
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}simplejson>=2.0:devel/py-simplejson
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}simplejson>=2.0:devel/py-simplejson@${PY_FLAVOR}
CONFLICTS= rabbitmq-c-[0-9]*
diff --git a/net/rabbitmq-c/Makefile b/net/rabbitmq-c/Makefile
index d08b57830627..b4aa2a5defd4 100644
--- a/net/rabbitmq-c/Makefile
+++ b/net/rabbitmq-c/Makefile
@@ -12,7 +12,7 @@ COMMENT= RabbitMQ C AMQP client library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE-MIT
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}simplejson>=2.0:devel/py-simplejson
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}simplejson>=2.0:devel/py-simplejson@${PY_FLAVOR}
CONFLICTS= rabbitmq-c-devel-[0-9]*
diff --git a/net/rabbitmq/Makefile b/net/rabbitmq/Makefile
index c10f0d1efbc2..594b142e925b 100644
--- a/net/rabbitmq/Makefile
+++ b/net/rabbitmq/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE-MPL-RabbitMQ
BUILD_DEPENDS= erlang-runtime19>=19.3:lang/erlang-runtime19 \
elixir:lang/elixir \
- ${PYTHON_PKGNAMEPREFIX}simplejson>=2.0:devel/py-simplejson \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>=2.0:devel/py-simplejson@${PY_FLAVOR} \
xmlto:textproc/xmlto \
zip:archivers/zip \
rsync:net/rsync
diff --git a/net/scribe/Makefile b/net/scribe/Makefile
index 6dc17ba2945e..694284dd96aa 100644
--- a/net/scribe/Makefile
+++ b/net/scribe/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libthrift.so:devel/thrift-cpp
RUN_DEPENDS= p5-Class-Accessor>0:devel/p5-Class-Accessor \
p5-Thrift>0:devel/p5-Thrift \
- ${PYTHON_PKGNAMEPREFIX}thrift>0:devel/py-thrift
+ ${PYTHON_PKGNAMEPREFIX}thrift>0:devel/py-thrift@${PY_FLAVOR}
BROKEN_powerpc64= Does not build