aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-02-27 05:31:08 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-02-27 05:31:08 +0000
commit0100aac4d75e6041a989505bde82f68c18a2ca70 (patch)
tree354388d5f0132c6e5c6063edef2f175d6ae5fa3e /net
parentf6523edd2d03c2cf75c706983b0de8fb97eb3ff1 (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/libproxy-webkit/Makefile29
-rw-r--r--net/libproxy-webkit/pkg-descr7
-rw-r--r--net/libproxy-webkit/pkg-plist1
4 files changed, 38 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 7e622522a895..66f71292b17b 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -305,6 +305,7 @@
SUBDIR += libproxy-gnome
SUBDIR += libproxy-kde
SUBDIR += libproxy-mozjs
+ SUBDIR += libproxy-webkit
SUBDIR += librsync
SUBDIR += libsocket++
SUBDIR += libsocketcpp
diff --git a/net/libproxy-webkit/Makefile b/net/libproxy-webkit/Makefile
new file mode 100644
index 000000000000..178bc1e31958
--- /dev/null
+++ b/net/libproxy-webkit/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libproxy-webkit
+# Date created: 26 February 2009
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= net devel
+PKGNAMESUFFIX= -webkit
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= WebKit Javascript plug-in for libproxy
+
+LIB_DEPENDS= proxy.0:${PORTSDIR}/net/libproxy \
+ webkit-1.0.1:${PORTSDIR}/www/webkit-gtk2
+
+MASTERDIR= ${.CURDIR}/../libproxy
+BUILD_WRKSRC= ${WRKSRC}/src/plugins
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+CONFIGURE_ARGS=--without-gnome --without-kde --with-webkit \
+ --without-mozjs --without-networkmanager --without-python \
+ --without-envvar --without-file
+
+LIBPROXY_SLAVE= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/libproxy-webkit/pkg-descr b/net/libproxy-webkit/pkg-descr
new file mode 100644
index 000000000000..e9b912c767b3
--- /dev/null
+++ b/net/libproxy-webkit/pkg-descr
@@ -0,0 +1,7 @@
+Libproxy exists to answer the question: Given a network resource, how do I
+reach it? It handles all the details, enabling you to get back to
+programming.
+
+This plug-in allows the WebKit web browser to make use of libproxy.
+
+WWW: http://code.google.com/p/libproxy/
diff --git a/net/libproxy-webkit/pkg-plist b/net/libproxy-webkit/pkg-plist
new file mode 100644
index 000000000000..1032ea9e211c
--- /dev/null
+++ b/net/libproxy-webkit/pkg-plist
@@ -0,0 +1 @@
+lib/libproxy/%%VERSION%%/plugins/webkit.so