aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2017-12-23 02:16:57 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2017-12-23 02:16:57 +0000
commit179dc7c17a95c5acc22db21f34c57061b47e5d4b (patch)
treefc26a3a81aad823768bc0b234a24033796295ad2 /net
parent013d6ffcbaca6ae84e0a0fbb24dd778c5e7b566b (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/libstorj/Makefile30
-rw-r--r--net/libstorj/distinfo3
-rw-r--r--net/libstorj/pkg-descr3
-rw-r--r--net/libstorj/pkg-plist7
5 files changed, 44 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 6b5d48e58a0f..adebcb70224d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -376,6 +376,7 @@
SUBDIR += librsync2
SUBDIR += libsocket++
SUBDIR += libsrtp
+ SUBDIR += libstorj
SUBDIR += libtnl
SUBDIR += libtrace
SUBDIR += libunp
diff --git a/net/libstorj/Makefile b/net/libstorj/Makefile
new file mode 100644
index 000000000000..8a973409b92c
--- /dev/null
+++ b/net/libstorj/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= libstorj
+PORTVERSION= 1.0.2
+DISTVERSIONPREFIX= v
+CATEGORIES= net
+
+MAINTAINER= jhixson@gmail.com
+COMMENT= C library and CLI for encrypted file transfer on the Storj network
+
+LICENSE= LGPL21+
+
+LIB_DEPENDS= libjson-c.so:devel/json-c \
+ libuv.so:devel/libuv \
+ libcurl.so:ftp/curl \
+ libnettle.so:security/nettle \
+ libmicrohttpd.so:www/libmicrohttpd
+
+USE_GITHUB= yes
+GH_ACCOUNT= Storj
+
+USES= autoreconf gmake libtool localbase pkgconfig
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+#CFLAGS+= -I. -I${LOCALBASE}/include
+#LDFLAGS+= -L. -L${LOCALBASE}/lib
+
+.include <bsd.port.mk>
diff --git a/net/libstorj/distinfo b/net/libstorj/distinfo
new file mode 100644
index 000000000000..2e7b259b288d
--- /dev/null
+++ b/net/libstorj/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1513914316
+SHA256 (Storj-libstorj-v1.0.2_GH0.tar.gz) = 1d355f2663fd7701c49a5d696e38e1e9bfb48829fca314c47f043d8e3fa8468e
+SIZE (Storj-libstorj-v1.0.2_GH0.tar.gz) = 170883
diff --git a/net/libstorj/pkg-descr b/net/libstorj/pkg-descr
new file mode 100644
index 000000000000..6189741a0862
--- /dev/null
+++ b/net/libstorj/pkg-descr
@@ -0,0 +1,3 @@
+C library for encrypted file transfer on the Storj network
+
+WWW: https://github.com/Storj/libstorj
diff --git a/net/libstorj/pkg-plist b/net/libstorj/pkg-plist
new file mode 100644
index 000000000000..d11ac67fa53f
--- /dev/null
+++ b/net/libstorj/pkg-plist
@@ -0,0 +1,7 @@
+bin/storj
+include/storj.h
+lib/libstorj.a
+lib/libstorj.so
+lib/libstorj.so.0
+lib/libstorj.so.0.0.0
+libdata/pkgconfig/libstorj.pc