aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2007-04-16 08:40:15 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2007-04-16 08:40:15 +0000
commit19d165a76cfd7d6d232959e16084549577719832 (patch)
treedef94450a836d9ae6a174429c0e67f364859e7d5 /net
parent56bfe515b51b1e69a0344db210bfa4ef0d60a3a9 (diff)
downloadports-19d165a76cfd7d6d232959e16084549577719832.tar.gz
ports-19d165a76cfd7d6d232959e16084549577719832.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/asterisk/Makefile12
-rw-r--r--net/asterisk/files/patch-Makefile9
-rw-r--r--net/asterisk/pkg-plist2
-rw-r--r--net/asterisk10/Makefile12
-rw-r--r--net/asterisk10/files/patch-Makefile9
-rw-r--r--net/asterisk10/pkg-plist2
-rw-r--r--net/asterisk14/Makefile12
-rw-r--r--net/asterisk14/files/patch-Makefile9
-rw-r--r--net/asterisk14/pkg-plist2
-rw-r--r--net/asterisk16/Makefile12
-rw-r--r--net/asterisk16/files/patch-Makefile9
-rw-r--r--net/asterisk16/pkg-plist2
12 files changed, 88 insertions, 4 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 664a9fb2fef4..5c0fd913bed2 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -43,7 +43,8 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
POSTGRES "Enable PostgreSQL support" on \
RADIUS "Enable RADIUS accounting support" on \
SNMP "Enable SNMP support" on \
- H323 "Enable H.323 support" on
+ H323 "Enable H.323 support" on \
+ JABBER "Enable Jabber and Gtalk support" on
.include <bsd.port.pre.mk>
@@ -123,6 +124,15 @@ CONFIGURE_ARGS+= --with-netsnmp
LIB_DEPENDS+= netsnmp.10:${PORTSDIR}/net-mgmt/net-snmp
.endif
+.if defined(WITHOUT_JABBER)
+PLIST_SUB+= WITH_JABBER="@comment "
+CONFIGURE_ARGS+= --without-iksemel
+.else
+PLIST_SUB+= WITH_JABBER=""
+CONFIGURE_ARGS+= --with-iksemel
+LIB_DEPENDS+= iksemel.3:${PORTSDIR}/textproc/iksemel
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample
diff --git a/net/asterisk/files/patch-Makefile b/net/asterisk/files/patch-Makefile
index 62dd952d9e74..f145cb58e89b 100644
--- a/net/asterisk/files/patch-Makefile
+++ b/net/asterisk/files/patch-Makefile
@@ -3,6 +3,15 @@ $FreeBSD$
--- Makefile.orig
+++ Makefile
+@@ -207,7 +207,7 @@
+
+ ifeq ($(OSARCH),FreeBSD)
+ # -V is understood by BSD Make, not by GNU make.
+- BSDVERSION=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
++ BSDVERSION=$(OSVERSION)
+ ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
+ AST_LIBS+=$(shell if test $(BSDVERSION) -lt 502102 ; then echo "-lc_r"; else echo "-pthread"; fi)
+ endif
@@ -371,15 +371,15 @@
# Should static HTTP be installed during make samples or even with its own target ala
# webvoicemail? There are portions here that *could* be customized but might also be
diff --git a/net/asterisk/pkg-plist b/net/asterisk/pkg-plist
index d470c7f04247..4aa7407cadf9 100644
--- a/net/asterisk/pkg-plist
+++ b/net/asterisk/pkg-plist
@@ -281,6 +281,7 @@ lib/asterisk/modules/cdr_manager.so
%%WITH_RADIUS%%lib/asterisk/modules/cdr_radius.so
lib/asterisk/modules/chan_agent.so
lib/asterisk/modules/chan_features.so
+%%WITH_JABBER%%lib/asterisk/modules/chan_gtalk.so
lib/asterisk/modules/chan_iax2.so
lib/asterisk/modules/chan_local.so
lib/asterisk/modules/chan_mgcp.so
@@ -347,6 +348,7 @@ lib/asterisk/modules/res_convert.so
lib/asterisk/modules/res_crypto.so
lib/asterisk/modules/res_features.so
lib/asterisk/modules/res_indications.so
+%%WITH_JABBER%%lib/asterisk/modules/res_jabber.so
lib/asterisk/modules/res_monitor.so
lib/asterisk/modules/res_musiconhold.so
lib/asterisk/modules/res_smdi.so
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index 664a9fb2fef4..5c0fd913bed2 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -43,7 +43,8 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
POSTGRES "Enable PostgreSQL support" on \
RADIUS "Enable RADIUS accounting support" on \
SNMP "Enable SNMP support" on \
- H323 "Enable H.323 support" on
+ H323 "Enable H.323 support" on \
+ JABBER "Enable Jabber and Gtalk support" on
.include <bsd.port.pre.mk>
@@ -123,6 +124,15 @@ CONFIGURE_ARGS+= --with-netsnmp
LIB_DEPENDS+= netsnmp.10:${PORTSDIR}/net-mgmt/net-snmp
.endif
+.if defined(WITHOUT_JABBER)
+PLIST_SUB+= WITH_JABBER="@comment "
+CONFIGURE_ARGS+= --without-iksemel
+.else
+PLIST_SUB+= WITH_JABBER=""
+CONFIGURE_ARGS+= --with-iksemel
+LIB_DEPENDS+= iksemel.3:${PORTSDIR}/textproc/iksemel
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample
diff --git a/net/asterisk10/files/patch-Makefile b/net/asterisk10/files/patch-Makefile
index 62dd952d9e74..f145cb58e89b 100644
--- a/net/asterisk10/files/patch-Makefile
+++ b/net/asterisk10/files/patch-Makefile
@@ -3,6 +3,15 @@ $FreeBSD$
--- Makefile.orig
+++ Makefile
+@@ -207,7 +207,7 @@
+
+ ifeq ($(OSARCH),FreeBSD)
+ # -V is understood by BSD Make, not by GNU make.
+- BSDVERSION=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
++ BSDVERSION=$(OSVERSION)
+ ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
+ AST_LIBS+=$(shell if test $(BSDVERSION) -lt 502102 ; then echo "-lc_r"; else echo "-pthread"; fi)
+ endif
@@ -371,15 +371,15 @@
# Should static HTTP be installed during make samples or even with its own target ala
# webvoicemail? There are portions here that *could* be customized but might also be
diff --git a/net/asterisk10/pkg-plist b/net/asterisk10/pkg-plist
index d470c7f04247..4aa7407cadf9 100644
--- a/net/asterisk10/pkg-plist
+++ b/net/asterisk10/pkg-plist
@@ -281,6 +281,7 @@ lib/asterisk/modules/cdr_manager.so
%%WITH_RADIUS%%lib/asterisk/modules/cdr_radius.so
lib/asterisk/modules/chan_agent.so
lib/asterisk/modules/chan_features.so
+%%WITH_JABBER%%lib/asterisk/modules/chan_gtalk.so
lib/asterisk/modules/chan_iax2.so
lib/asterisk/modules/chan_local.so
lib/asterisk/modules/chan_mgcp.so
@@ -347,6 +348,7 @@ lib/asterisk/modules/res_convert.so
lib/asterisk/modules/res_crypto.so
lib/asterisk/modules/res_features.so
lib/asterisk/modules/res_indications.so
+%%WITH_JABBER%%lib/asterisk/modules/res_jabber.so
lib/asterisk/modules/res_monitor.so
lib/asterisk/modules/res_musiconhold.so
lib/asterisk/modules/res_smdi.so
diff --git a/net/asterisk14/Makefile b/net/asterisk14/Makefile
index 664a9fb2fef4..5c0fd913bed2 100644
--- a/net/asterisk14/Makefile
+++ b/net/asterisk14/Makefile
@@ -43,7 +43,8 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
POSTGRES "Enable PostgreSQL support" on \
RADIUS "Enable RADIUS accounting support" on \
SNMP "Enable SNMP support" on \
- H323 "Enable H.323 support" on
+ H323 "Enable H.323 support" on \
+ JABBER "Enable Jabber and Gtalk support" on
.include <bsd.port.pre.mk>
@@ -123,6 +124,15 @@ CONFIGURE_ARGS+= --with-netsnmp
LIB_DEPENDS+= netsnmp.10:${PORTSDIR}/net-mgmt/net-snmp
.endif
+.if defined(WITHOUT_JABBER)
+PLIST_SUB+= WITH_JABBER="@comment "
+CONFIGURE_ARGS+= --without-iksemel
+.else
+PLIST_SUB+= WITH_JABBER=""
+CONFIGURE_ARGS+= --with-iksemel
+LIB_DEPENDS+= iksemel.3:${PORTSDIR}/textproc/iksemel
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample
diff --git a/net/asterisk14/files/patch-Makefile b/net/asterisk14/files/patch-Makefile
index 62dd952d9e74..f145cb58e89b 100644
--- a/net/asterisk14/files/patch-Makefile
+++ b/net/asterisk14/files/patch-Makefile
@@ -3,6 +3,15 @@ $FreeBSD$
--- Makefile.orig
+++ Makefile
+@@ -207,7 +207,7 @@
+
+ ifeq ($(OSARCH),FreeBSD)
+ # -V is understood by BSD Make, not by GNU make.
+- BSDVERSION=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
++ BSDVERSION=$(OSVERSION)
+ ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
+ AST_LIBS+=$(shell if test $(BSDVERSION) -lt 502102 ; then echo "-lc_r"; else echo "-pthread"; fi)
+ endif
@@ -371,15 +371,15 @@
# Should static HTTP be installed during make samples or even with its own target ala
# webvoicemail? There are portions here that *could* be customized but might also be
diff --git a/net/asterisk14/pkg-plist b/net/asterisk14/pkg-plist
index d470c7f04247..4aa7407cadf9 100644
--- a/net/asterisk14/pkg-plist
+++ b/net/asterisk14/pkg-plist
@@ -281,6 +281,7 @@ lib/asterisk/modules/cdr_manager.so
%%WITH_RADIUS%%lib/asterisk/modules/cdr_radius.so
lib/asterisk/modules/chan_agent.so
lib/asterisk/modules/chan_features.so
+%%WITH_JABBER%%lib/asterisk/modules/chan_gtalk.so
lib/asterisk/modules/chan_iax2.so
lib/asterisk/modules/chan_local.so
lib/asterisk/modules/chan_mgcp.so
@@ -347,6 +348,7 @@ lib/asterisk/modules/res_convert.so
lib/asterisk/modules/res_crypto.so
lib/asterisk/modules/res_features.so
lib/asterisk/modules/res_indications.so
+%%WITH_JABBER%%lib/asterisk/modules/res_jabber.so
lib/asterisk/modules/res_monitor.so
lib/asterisk/modules/res_musiconhold.so
lib/asterisk/modules/res_smdi.so
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index 664a9fb2fef4..5c0fd913bed2 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -43,7 +43,8 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
POSTGRES "Enable PostgreSQL support" on \
RADIUS "Enable RADIUS accounting support" on \
SNMP "Enable SNMP support" on \
- H323 "Enable H.323 support" on
+ H323 "Enable H.323 support" on \
+ JABBER "Enable Jabber and Gtalk support" on
.include <bsd.port.pre.mk>
@@ -123,6 +124,15 @@ CONFIGURE_ARGS+= --with-netsnmp
LIB_DEPENDS+= netsnmp.10:${PORTSDIR}/net-mgmt/net-snmp
.endif
+.if defined(WITHOUT_JABBER)
+PLIST_SUB+= WITH_JABBER="@comment "
+CONFIGURE_ARGS+= --without-iksemel
+.else
+PLIST_SUB+= WITH_JABBER=""
+CONFIGURE_ARGS+= --with-iksemel
+LIB_DEPENDS+= iksemel.3:${PORTSDIR}/textproc/iksemel
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample
diff --git a/net/asterisk16/files/patch-Makefile b/net/asterisk16/files/patch-Makefile
index 62dd952d9e74..f145cb58e89b 100644
--- a/net/asterisk16/files/patch-Makefile
+++ b/net/asterisk16/files/patch-Makefile
@@ -3,6 +3,15 @@ $FreeBSD$
--- Makefile.orig
+++ Makefile
+@@ -207,7 +207,7 @@
+
+ ifeq ($(OSARCH),FreeBSD)
+ # -V is understood by BSD Make, not by GNU make.
+- BSDVERSION=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
++ BSDVERSION=$(OSVERSION)
+ ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
+ AST_LIBS+=$(shell if test $(BSDVERSION) -lt 502102 ; then echo "-lc_r"; else echo "-pthread"; fi)
+ endif
@@ -371,15 +371,15 @@
# Should static HTTP be installed during make samples or even with its own target ala
# webvoicemail? There are portions here that *could* be customized but might also be
diff --git a/net/asterisk16/pkg-plist b/net/asterisk16/pkg-plist
index d470c7f04247..4aa7407cadf9 100644
--- a/net/asterisk16/pkg-plist
+++ b/net/asterisk16/pkg-plist
@@ -281,6 +281,7 @@ lib/asterisk/modules/cdr_manager.so
%%WITH_RADIUS%%lib/asterisk/modules/cdr_radius.so
lib/asterisk/modules/chan_agent.so
lib/asterisk/modules/chan_features.so
+%%WITH_JABBER%%lib/asterisk/modules/chan_gtalk.so
lib/asterisk/modules/chan_iax2.so
lib/asterisk/modules/chan_local.so
lib/asterisk/modules/chan_mgcp.so
@@ -347,6 +348,7 @@ lib/asterisk/modules/res_convert.so
lib/asterisk/modules/res_crypto.so
lib/asterisk/modules/res_features.so
lib/asterisk/modules/res_indications.so
+%%WITH_JABBER%%lib/asterisk/modules/res_jabber.so
lib/asterisk/modules/res_monitor.so
lib/asterisk/modules/res_musiconhold.so
lib/asterisk/modules/res_smdi.so