aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorNick Sayer <nsayer@FreeBSD.org>2001-09-08 16:28:00 +0000
committerNick Sayer <nsayer@FreeBSD.org>2001-09-08 16:28:00 +0000
commit4a0cd50687ff0cac12358785aea4702112ed49eb (patch)
tree3ddc2dfeb8b6a76c9bd6fdaa4903f4e8e9934fa9 /net
parent4f028cfd2d24d0544cbe41d22f1e62b723ec8f66 (diff)
downloadports-4a0cd50687ff0cac12358785aea4702112ed49eb.tar.gz
ports-4a0cd50687ff0cac12358785aea4702112ed49eb.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/poptop/Makefile4
-rw-r--r--net/poptop/distinfo2
-rw-r--r--net/poptop/files/patch-ae18
3 files changed, 21 insertions, 3 deletions
diff --git a/net/poptop/Makefile b/net/poptop/Makefile
index b83f209e88f3..56eb839a0901 100644
--- a/net/poptop/Makefile
+++ b/net/poptop/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= poptop
-PORTVERSION= 1.0.1
+PORTVERSION= 1.1.2
CATEGORIES= net
MASTER_SITES= http://poptop.lineo.com/releases/
DISTNAME= pptpd-${PORTVERSION}
@@ -21,6 +21,6 @@ MAN8= pptpd.8 pptpctrl.8
post-install:
${INSTALL_DATA} ${WRKSRC}/samples/pptpd.conf ${PREFIX}/etc/pptpd.conf.sample
- ${INSTALL_DATA} ${FILESDIR}/pptpd.sh ${PREFIX}/etc/rc.d/pptpd.sh
+ ${INSTALL_SCRIPT} ${FILESDIR}/pptpd.sh ${PREFIX}/etc/rc.d/pptpd.sh
.include <bsd.port.mk>
diff --git a/net/poptop/distinfo b/net/poptop/distinfo
index 1e3787270e50..9cdcb50209a5 100644
--- a/net/poptop/distinfo
+++ b/net/poptop/distinfo
@@ -1 +1 @@
-MD5 (pptpd-1.0.1.tar.gz) = 67fbb621e1de325012feeb105846fe7d
+MD5 (pptpd-1.1.2.tar.gz) = 03f7106c6fd7f22bd904b5c66aedbe92
diff --git a/net/poptop/files/patch-ae b/net/poptop/files/patch-ae
new file mode 100644
index 000000000000..c0ab9ecc1129
--- /dev/null
+++ b/net/poptop/files/patch-ae
@@ -0,0 +1,18 @@
+--- pptpgre.c.orig Sat Sep 8 09:12:30 2001
++++ pptpgre.c Sat Sep 8 09:13:11 2001
+@@ -114,6 +114,7 @@
+ strerror (errno));
+ }
+
++#if 0
+ /* Tell kernel we do not want headers with our IP packets. I was
+ hoping this would eliminate the need to strip them from received
+ packets, but instead it appears to only affect transmission.
+@@ -131,6 +132,7 @@
+ syslog (LOG_ERR, "Couldn't set hdrincl to false");
+ }
+ }
++#endif
+
+ gre->pty_fd = pty_fd;
+ gre->call_id_pair = call_id_pair; /* network byte order */