aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2002-06-26 22:14:16 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2002-06-26 22:14:16 +0000
commit4df34b5c86bbfa4c0ce0798df6589e078db81061 (patch)
tree193196000e27c10554e7801035fef3a9ebf8d315 /net
parentde9d7ea0f90fb4ba0151846a054da3dc964c99a8 (diff)
downloadports-4df34b5c86bbfa4c0ce0798df6589e078db81061.tar.gz
ports-4df34b5c86bbfa4c0ce0798df6589e078db81061.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/krdesktop/Makefile34
-rw-r--r--net/krdesktop/distinfo1
-rw-r--r--net/krdesktop/pkg-comment1
-rw-r--r--net/krdesktop/pkg-descr5
-rw-r--r--net/krdesktop/pkg-plist1
6 files changed, 43 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 07204c3f63db..b4d3b432a398 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -218,6 +218,7 @@
SUBDIR += kmsn
SUBDIR += konverse
SUBDIR += kopete
+ SUBDIR += krdesktop
SUBDIR += kxicq2
SUBDIR += lam
SUBDIR += lambdamoo
diff --git a/net/krdesktop/Makefile b/net/krdesktop/Makefile
new file mode 100644
index 000000000000..c2edb621fff9
--- /dev/null
+++ b/net/krdesktop/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: krdesktop
+# Date created: 23 June 2002
+# Whom: Matt Douhan <matt@athame.co.uk>
+#
+# $FreeBSD$
+
+PORTNAME= krdesktop
+PORTVERSION= 1.0
+CATEGORIES= net kde
+MASTER_SITES= http://krazykiwi.homeip.net/netwizard/krdesktop/
+DISTNAME= ${PORTNAME:S/kr/KR/}-${PORTVERSION}
+
+MAINTAINER= matt@athame.co.uk
+
+RUN_DEPENDS= rdesktop:${PORTSDIR}/net/rdesktop-devel
+
+USE_KDELIBS_VER=3
+USE_REINPLACE= yes
+NO_WRKSUBDIR= yes
+REINPLACE_ARGS= -E -i.bak
+
+MAKE_ENV= QTDIR=${QT_PREFIX} \
+ KDEDIR=${LOCALBASE} \
+ MOC=${MOC}
+
+CONFIGURE_ARGS= --with-extra-includes=${LOCALBASE}/include \
+ --with-extra-libs=${LOCALBASE}/lib
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,^(CXX|MOC|CXXFLAGS)\+?=,\1?=,g' \
+ -e 's,(\$$\(CXX\) )(\$$\(CXXFLAGS),\1-c \2,g' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/net/krdesktop/distinfo b/net/krdesktop/distinfo
new file mode 100644
index 000000000000..a457942a7b61
--- /dev/null
+++ b/net/krdesktop/distinfo
@@ -0,0 +1 @@
+MD5 (KRdesktop-1.0.tar.gz) = dc0de52625d8351fe7e5990e8d8a2b36
diff --git a/net/krdesktop/pkg-comment b/net/krdesktop/pkg-comment
new file mode 100644
index 000000000000..f2fa1d164b91
--- /dev/null
+++ b/net/krdesktop/pkg-comment
@@ -0,0 +1 @@
+KDE Frontend for rdesktop
diff --git a/net/krdesktop/pkg-descr b/net/krdesktop/pkg-descr
new file mode 100644
index 000000000000..5b461d67ee24
--- /dev/null
+++ b/net/krdesktop/pkg-descr
@@ -0,0 +1,5 @@
+This is a cvs snapshot of krdesktop, a rdesktop GUI.
+
+WWW: http://krazykiwi.homeip.net/netwizard/krdesktop/
+
+- Matt Douhan et al. <matt@athame.co.uk>
diff --git a/net/krdesktop/pkg-plist b/net/krdesktop/pkg-plist
new file mode 100644
index 000000000000..3275c5e16067
--- /dev/null
+++ b/net/krdesktop/pkg-plist
@@ -0,0 +1 @@
+bin/krdesktop