aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-06-13 21:05:19 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-06-13 21:05:19 +0000
commit517612e0b119453bc41e8de3f49e9a45fa0c1161 (patch)
tree33fcda58a16f5e8e0ab717ca29cdb2f6e94315aa /net
parentf3b8ba988708b3d06ccb91f6c1c27eace32fa70b (diff)
downloadports-517612e0b119453bc41e8de3f49e9a45fa0c1161.tar.gz
ports-517612e0b119453bc41e8de3f49e9a45fa0c1161.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/prosearch/Makefile16
-rw-r--r--net/prosearch/distinfo4
-rw-r--r--net/prosearch/pkg-plist7
3 files changed, 20 insertions, 7 deletions
diff --git a/net/prosearch/Makefile b/net/prosearch/Makefile
index c04923330936..d1ff86b4cc6a 100644
--- a/net/prosearch/Makefile
+++ b/net/prosearch/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= prosearch
-PORTVERSION= 0.19.1
-PORTREVISION= 1
+PORTVERSION= 0.19.2
+#PORTREVISION= 1
CATEGORIES= net www
MASTER_SITES= http://pro.setun.net/search/download/ SF/pro-search/pro-search/${PORTVERSION}
@@ -54,13 +54,15 @@ ${SITE_PERL}/lib/abs.pm:${PORTSDIR}/devel/p5-lib-abs
.if defined(WITH_CRAWLER)
RUN_DEPENDS+=\
${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser \
nmap:${PORTSDIR}/security/nmap \
${SITE_PERL}/Net/DirectConnect.pm:${PORTSDIR}/net-p2p/p5-Net-DirectConnect
.endif
.if defined(WITH_SAMBA)
-RUN_DEPENDS+= smbclient:${PORTSDIR}/${SAMBA_PORT}
+RUN_DEPENDS+= smbclient:${PORTSDIR}/net/samba-smbclient
.endif
.if defined(WITH_RSYNC)
@@ -110,7 +112,12 @@ USE_MYSQL= server
.if defined(WITH_MARIA)
RUN_DEPENDS+=\
${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql \
-${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mariadb
+${LOCALBASE}bin/mysql:${PORTSDIR}/databases/mariadb-client
+.endif
+
+.if defined(WITH_DB) && defined(WITH_MARIA)
+RUN_DEPENDS+=\
+${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mariadb-server
.endif
.if defined(WITH_PGSQL)
@@ -125,6 +132,7 @@ ${SITE_PERL}/DBD/PgPP.pm:${PORTSDIR}/databases/p5-DBD-PgPP
.endif
.if (defined(WITH_PGSQL) || defined(WITH_PGPP)) && defined(WITH_DB)
+USE_PGSQL= yes
RUN_DEPENDS+=\
${LOCALBASE}/bin/postgres:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
.endif
diff --git a/net/prosearch/distinfo b/net/prosearch/distinfo
index 153bd4262c79..51fd690dcc1c 100644
--- a/net/prosearch/distinfo
+++ b/net/prosearch/distinfo
@@ -1,2 +1,2 @@
-SHA256 (prosearch-0.19.1.tar.bz2) = 41c9d635c9d3dc8cbd162e2110e2c4c97a43480b5666ec2c18b91c08fc9d66f1
-SIZE (prosearch-0.19.1.tar.bz2) = 313442
+SHA256 (prosearch-0.19.2.tar.bz2) = 3bf5b90a1f8d66a20cc699ed487708a719e31f6217aa1856f009565d33ffe9fb
+SIZE (prosearch-0.19.2.tar.bz2) = 400435
diff --git a/net/prosearch/pkg-plist b/net/prosearch/pkg-plist
index d0639032aada..6bee9187514c 100644
--- a/net/prosearch/pkg-plist
+++ b/net/prosearch/pkg-plist
@@ -4,13 +4,14 @@
%%SEARCHDIR%%/tools/prosearch/Makefile
%%SEARCHDIR%%/tools/tidy.pl
%%SEARCHDIR%%/tools/test
-%%SEARCHDIR%%/tools/onebyte
+%%SEARCHDIR%%/tools/rsync_password
%%SEARCHDIR%%/tools/test.zip
%%SEARCHDIR%%/tools/size.sh
%%SEARCHDIR%%/tools/grant.sql
%%SEARCHDIR%%/tools/search.conf
%%SEARCHDIR%%/tools/sphinx.conf
%%SEARCHDIR%%/tools/cp_auto_gen.pl
+%%SEARCHDIR%%/tools/nginx-fastcgi.conf
%%SEARCHDIR%%/doc/html2txt.pl
%%SEARCHDIR%%/doc/cuted.old
%%SEARCHDIR%%/doc/doc.txt
@@ -22,10 +23,12 @@
%%SEARCHDIR%%/lib/lib.js
%%SEARCHDIR%%/lib/search1.js
%%SEARCHDIR%%/lib/player.js
+%%SEARCHDIR%%/lib/jquery-1.7.1.min.js
%%SEARCHDIR%%/lib/psmisc.pm
%%SEARCHDIR%%/lib/psweb.pm
%%SEARCHDIR%%/lib/lib.css
%%SEARCHDIR%%/lib/pssql.pm
+%%SEARCHDIR%%/t/json.t
%%SEARCHDIR%%/WHATSNEW
%%SEARCHDIR%%/search.sh.dist
%%SEARCHDIR%%/config.pl.dist
@@ -77,6 +80,7 @@
%%SEARCHDIR%%/web/lib/lib.js
%%SEARCHDIR%%/web/lib/search1.js
%%SEARCHDIR%%/web/lib/player.js
+%%SEARCHDIR%%/web/lib/jquery-1.7.1.min.js
%%SEARCHDIR%%/web/lib/psmisc.pm
%%SEARCHDIR%%/web/lib/psweb.pm
%%SEARCHDIR%%/web/lib/lib.css
@@ -111,6 +115,7 @@
@dirrm %%SEARCHDIR%%/doc
@dirrm %%SEARCHDIR%%/example
@dirrm %%SEARCHDIR%%/lib
+@dirrm %%SEARCHDIR%%/t
@dirrmtry %%SEARCHDIR%%/tmp
@dirrmtry %%SEARCHDIR%%/var
@dirrmtry %%SEARCHDIR%%/web