aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2009-05-12 21:54:10 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2009-05-12 21:54:10 +0000
commit5492b03aec00ca292d7d231d229beefe05c3f442 (patch)
tree2fb3156ae3488b92db3d093843dfa5c0e3751aa1 /net
parent844b61a3512d4b6b097a1a709a098fafcebb43fe (diff)
downloadports-5492b03aec00ca292d7d231d229beefe05c3f442.tar.gz
ports-5492b03aec00ca292d7d231d229beefe05c3f442.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/asterisk/Makefile7
-rw-r--r--net/asterisk/files/patch-hangup_hang20
-rw-r--r--net/asterisk/files/patch-rtp_timeout25
-rw-r--r--net/asterisk10/Makefile7
-rw-r--r--net/asterisk10/files/patch-hangup_hang20
-rw-r--r--net/asterisk10/files/patch-rtp_timeout25
-rw-r--r--net/asterisk14/Makefile7
-rw-r--r--net/asterisk14/files/patch-hangup_hang20
-rw-r--r--net/asterisk14/files/patch-rtp_timeout25
9 files changed, 144 insertions, 12 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 2556b4ee3aec..1b41a4d3a73d 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -7,11 +7,10 @@
PORTNAME= asterisk
PORTVERSION= 1.4.24.1
+PORTREVISION= 1
CATEGORIES= net
-MASTER_SITES= http://downloads.digium.com/pub/asterisk/ \
- http://downloads.digium.com/pub/asterisk/old-releases/ \
- http://ftp.digium.com/pub/asterisk/ \
- http://ftp.digium.com/pub/asterisk/old-releases/
+MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
+ http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
MAINTAINER= sobomax@FreeBSD.org
COMMENT= An Open Source PBX and telephony toolkit
diff --git a/net/asterisk/files/patch-hangup_hang b/net/asterisk/files/patch-hangup_hang
new file mode 100644
index 000000000000..22e09d6a1be7
--- /dev/null
+++ b/net/asterisk/files/patch-hangup_hang
@@ -0,0 +1,20 @@
+Index: main/channel.c
+===================================================================
+--- main/channel.c (revision 188244)
++++ main/channel.c (working copy)
+@@ -2038,13 +2038,13 @@
+ return &ast_null_frame;
+ usleep(1);
+ }
+-
++/*
+ if (chan->fdno == -1) {
+ ast_log(LOG_ERROR, "ast_read() called with no recorded file descriptor.\n");
+ f = &ast_null_frame;
+ goto done;
+ }
+-
++*/
+ if (chan->masq) {
+ if (ast_do_masquerade(chan))
+ ast_log(LOG_WARNING, "Failed to perform masquerade\n");
diff --git a/net/asterisk/files/patch-rtp_timeout b/net/asterisk/files/patch-rtp_timeout
new file mode 100644
index 000000000000..6f60c74cff41
--- /dev/null
+++ b/net/asterisk/files/patch-rtp_timeout
@@ -0,0 +1,25 @@
+--- channels/chan_sip.c.orig 2009-04-14 08:58:13.000000000 +0100
++++ channels/chan_sip.c 2009-04-14 09:00:58.000000000 +0100
+@@ -16287,7 +16287,6 @@
+ restartsearch:
+ /* Check for interfaces needing to be killed */
+ ast_mutex_lock(&iflock);
+- t = time(NULL);
+ /* don't scan the interface list if it hasn't been a reasonable period
+ of time since the last time we did it (when MWI is being sent, we can
+ get back to this point every millisecond or less)
+@@ -16306,12 +16305,14 @@
+ (sip->owner->_state == AST_STATE_UP) &&
+ !sip->redirip.sin_addr.s_addr &&
+ sip->t38.state != T38_ENABLED) {
++ t = time(NULL);
+ if (sip->lastrtptx &&
+ ast_rtp_get_rtpkeepalive(sip->rtp) &&
+ (t > sip->lastrtptx + ast_rtp_get_rtpkeepalive(sip->rtp))) {
+ /* Need to send an empty RTP packet */
+ sip->lastrtptx = time(NULL);
+ ast_rtp_sendcng(sip->rtp, 0);
++ t = time(NULL);
+ }
+ if (sip->lastrtprx &&
+ (ast_rtp_get_rtptimeout(sip->rtp) || ast_rtp_get_rtpholdtimeout(sip->rtp)) &&
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index 2556b4ee3aec..1b41a4d3a73d 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -7,11 +7,10 @@
PORTNAME= asterisk
PORTVERSION= 1.4.24.1
+PORTREVISION= 1
CATEGORIES= net
-MASTER_SITES= http://downloads.digium.com/pub/asterisk/ \
- http://downloads.digium.com/pub/asterisk/old-releases/ \
- http://ftp.digium.com/pub/asterisk/ \
- http://ftp.digium.com/pub/asterisk/old-releases/
+MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
+ http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
MAINTAINER= sobomax@FreeBSD.org
COMMENT= An Open Source PBX and telephony toolkit
diff --git a/net/asterisk10/files/patch-hangup_hang b/net/asterisk10/files/patch-hangup_hang
new file mode 100644
index 000000000000..22e09d6a1be7
--- /dev/null
+++ b/net/asterisk10/files/patch-hangup_hang
@@ -0,0 +1,20 @@
+Index: main/channel.c
+===================================================================
+--- main/channel.c (revision 188244)
++++ main/channel.c (working copy)
+@@ -2038,13 +2038,13 @@
+ return &ast_null_frame;
+ usleep(1);
+ }
+-
++/*
+ if (chan->fdno == -1) {
+ ast_log(LOG_ERROR, "ast_read() called with no recorded file descriptor.\n");
+ f = &ast_null_frame;
+ goto done;
+ }
+-
++*/
+ if (chan->masq) {
+ if (ast_do_masquerade(chan))
+ ast_log(LOG_WARNING, "Failed to perform masquerade\n");
diff --git a/net/asterisk10/files/patch-rtp_timeout b/net/asterisk10/files/patch-rtp_timeout
new file mode 100644
index 000000000000..6f60c74cff41
--- /dev/null
+++ b/net/asterisk10/files/patch-rtp_timeout
@@ -0,0 +1,25 @@
+--- channels/chan_sip.c.orig 2009-04-14 08:58:13.000000000 +0100
++++ channels/chan_sip.c 2009-04-14 09:00:58.000000000 +0100
+@@ -16287,7 +16287,6 @@
+ restartsearch:
+ /* Check for interfaces needing to be killed */
+ ast_mutex_lock(&iflock);
+- t = time(NULL);
+ /* don't scan the interface list if it hasn't been a reasonable period
+ of time since the last time we did it (when MWI is being sent, we can
+ get back to this point every millisecond or less)
+@@ -16306,12 +16305,14 @@
+ (sip->owner->_state == AST_STATE_UP) &&
+ !sip->redirip.sin_addr.s_addr &&
+ sip->t38.state != T38_ENABLED) {
++ t = time(NULL);
+ if (sip->lastrtptx &&
+ ast_rtp_get_rtpkeepalive(sip->rtp) &&
+ (t > sip->lastrtptx + ast_rtp_get_rtpkeepalive(sip->rtp))) {
+ /* Need to send an empty RTP packet */
+ sip->lastrtptx = time(NULL);
+ ast_rtp_sendcng(sip->rtp, 0);
++ t = time(NULL);
+ }
+ if (sip->lastrtprx &&
+ (ast_rtp_get_rtptimeout(sip->rtp) || ast_rtp_get_rtpholdtimeout(sip->rtp)) &&
diff --git a/net/asterisk14/Makefile b/net/asterisk14/Makefile
index 2556b4ee3aec..1b41a4d3a73d 100644
--- a/net/asterisk14/Makefile
+++ b/net/asterisk14/Makefile
@@ -7,11 +7,10 @@
PORTNAME= asterisk
PORTVERSION= 1.4.24.1
+PORTREVISION= 1
CATEGORIES= net
-MASTER_SITES= http://downloads.digium.com/pub/asterisk/ \
- http://downloads.digium.com/pub/asterisk/old-releases/ \
- http://ftp.digium.com/pub/asterisk/ \
- http://ftp.digium.com/pub/asterisk/old-releases/
+MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
+ http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
MAINTAINER= sobomax@FreeBSD.org
COMMENT= An Open Source PBX and telephony toolkit
diff --git a/net/asterisk14/files/patch-hangup_hang b/net/asterisk14/files/patch-hangup_hang
new file mode 100644
index 000000000000..22e09d6a1be7
--- /dev/null
+++ b/net/asterisk14/files/patch-hangup_hang
@@ -0,0 +1,20 @@
+Index: main/channel.c
+===================================================================
+--- main/channel.c (revision 188244)
++++ main/channel.c (working copy)
+@@ -2038,13 +2038,13 @@
+ return &ast_null_frame;
+ usleep(1);
+ }
+-
++/*
+ if (chan->fdno == -1) {
+ ast_log(LOG_ERROR, "ast_read() called with no recorded file descriptor.\n");
+ f = &ast_null_frame;
+ goto done;
+ }
+-
++*/
+ if (chan->masq) {
+ if (ast_do_masquerade(chan))
+ ast_log(LOG_WARNING, "Failed to perform masquerade\n");
diff --git a/net/asterisk14/files/patch-rtp_timeout b/net/asterisk14/files/patch-rtp_timeout
new file mode 100644
index 000000000000..6f60c74cff41
--- /dev/null
+++ b/net/asterisk14/files/patch-rtp_timeout
@@ -0,0 +1,25 @@
+--- channels/chan_sip.c.orig 2009-04-14 08:58:13.000000000 +0100
++++ channels/chan_sip.c 2009-04-14 09:00:58.000000000 +0100
+@@ -16287,7 +16287,6 @@
+ restartsearch:
+ /* Check for interfaces needing to be killed */
+ ast_mutex_lock(&iflock);
+- t = time(NULL);
+ /* don't scan the interface list if it hasn't been a reasonable period
+ of time since the last time we did it (when MWI is being sent, we can
+ get back to this point every millisecond or less)
+@@ -16306,12 +16305,14 @@
+ (sip->owner->_state == AST_STATE_UP) &&
+ !sip->redirip.sin_addr.s_addr &&
+ sip->t38.state != T38_ENABLED) {
++ t = time(NULL);
+ if (sip->lastrtptx &&
+ ast_rtp_get_rtpkeepalive(sip->rtp) &&
+ (t > sip->lastrtptx + ast_rtp_get_rtpkeepalive(sip->rtp))) {
+ /* Need to send an empty RTP packet */
+ sip->lastrtptx = time(NULL);
+ ast_rtp_sendcng(sip->rtp, 0);
++ t = time(NULL);
+ }
+ if (sip->lastrtprx &&
+ (ast_rtp_get_rtptimeout(sip->rtp) || ast_rtp_get_rtpholdtimeout(sip->rtp)) &&