aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-22 20:29:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-22 20:29:32 +0000
commit7b3a022c0c2d034f427eb2cc495da67ebb4df16d (patch)
tree170c8483bc3a82023af28375a70740a8f17e2242 /net
parent5bc2b70b0402f170e149012d03555ad223ae2a50 (diff)
downloadports-7b3a022c0c2d034f427eb2cc495da67ebb4df16d.tar.gz
ports-7b3a022c0c2d034f427eb2cc495da67ebb4df16d.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p54u/Makefile37
-rw-r--r--net/p54u/distinfo3
-rw-r--r--net/p54u/pkg-descr4
-rw-r--r--net/p54u/pkg-message9
-rw-r--r--net/p54u/pkg-plist5
6 files changed, 59 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index fa81c968576a..67e96032ec60 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -428,6 +428,7 @@
SUBDIR += ortp
SUBDIR += osrtspproxy
SUBDIR += ossp-sa
+ SUBDIR += p54u
SUBDIR += p5-AddressBook
SUBDIR += p5-Archie
SUBDIR += p5-EasyTCP
diff --git a/net/p54u/Makefile b/net/p54u/Makefile
new file mode 100644
index 000000000000..89b638778097
--- /dev/null
+++ b/net/p54u/Makefile
@@ -0,0 +1,37 @@
+# Ports collection makefile for: p54u
+# Date created: 20 January 2006
+# Whom: Sebastien Bourdeauducq <lekernel@prism54.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= p54u
+PORTVERSION= 0.8
+CATEGORIES= net
+MASTER_SITES= http://www.prism54.org/p54u/releases/
+
+MAINTAINER= lekernel@prism54.org
+COMMENT= Driver for USB wireless devices with Conexant (Prism 54) chipsets
+
+NO_PACKAGE= Should be in sync with the kernel to work correctly
+
+USE_BZIP2= yes
+MANCOMPRESSED= yes
+
+MAN4= p54u.4
+MAN8= p54ctl.8 p54term.8
+
+.if !exists(/usr/src/sys/dev/usb/usb.h)
+IGNORE= requires kernel source (/usr/src/sys) to build
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+IGNORE= is not supported on FreeBSD 5.X and older
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/net/p54u/distinfo b/net/p54u/distinfo
new file mode 100644
index 000000000000..eb14e0bf1b1d
--- /dev/null
+++ b/net/p54u/distinfo
@@ -0,0 +1,3 @@
+MD5 (p54u-0.8.tar.bz2) = 8a35f1f5a0a5f86f008ffab13168be08
+SHA256 (p54u-0.8.tar.bz2) = ca2bfde01007e15a51cf9880217c670c7110859ce5a510d247c6997cc3ebb2d2
+SIZE (p54u-0.8.tar.bz2) = 53880
diff --git a/net/p54u/pkg-descr b/net/p54u/pkg-descr
new file mode 100644
index 000000000000..ec1927087bf4
--- /dev/null
+++ b/net/p54u/pkg-descr
@@ -0,0 +1,4 @@
+Driver for all USB wireless devices with Conexant chipsets (ISL3880,
+ISL3886, GW3887).
+
+WWW: http://www.prism54.org/
diff --git a/net/p54u/pkg-message b/net/p54u/pkg-message
new file mode 100644
index 000000000000..47044bf9c566
--- /dev/null
+++ b/net/p54u/pkg-message
@@ -0,0 +1,9 @@
+*****************************************************************************
+
+For this driver to work, you'll need firmware files that are not distributed
+in this port because of licensing restrictions.
+
+Please see http://www.prism54.org/ to get a firmware image and to find
+information about how to install it.
+
+*****************************************************************************
diff --git a/net/p54u/pkg-plist b/net/p54u/pkg-plist
new file mode 100644
index 000000000000..2620a226b5b6
--- /dev/null
+++ b/net/p54u/pkg-plist
@@ -0,0 +1,5 @@
+lib/p54u/p54u.ko
+lib/p54u/linker.hints
+bin/p54ctl
+bin/p54term
+@dirrm lib/p54u