aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2002-06-13 10:42:49 +0000
committerAnton Berezin <tobez@FreeBSD.org>2002-06-13 10:42:49 +0000
commit91176fb826137db9d1eccd90f40c183905b64f99 (patch)
treeef6ab9c3f5e8035018f634d750d9101fcebc8918 /net
parentf79f718185fd811dd3f8dd8fc14b7bf0844b09cf (diff)
downloadports-91176fb826137db9d1eccd90f40c183905b64f99.tar.gz
ports-91176fb826137db9d1eccd90f40c183905b64f99.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-IP/Makefile26
-rw-r--r--net/p5-Net-IP/distinfo1
-rw-r--r--net/p5-Net-IP/pkg-comment1
-rw-r--r--net/p5-Net-IP/pkg-descr11
-rw-r--r--net/p5-Net-IP/pkg-plist7
6 files changed, 47 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 6579c882132f..60778aebc616 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -328,6 +328,7 @@
SUBDIR += p5-Net-Daemon
SUBDIR += p5-Net-Google
SUBDIR += p5-Net-ICQ2000
+ SUBDIR += p5-Net-IP
SUBDIR += p5-Net-IPv4Addr
SUBDIR += p5-Net-IPv6Addr
SUBDIR += p5-Net-Jabber
diff --git a/net/p5-Net-IP/Makefile b/net/p5-Net-IP/Makefile
new file mode 100644
index 000000000000..514fa74016e0
--- /dev/null
+++ b/net/p5-Net-IP/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Net-IP
+# Date created: 30 May 2002
+# Whom: Kimura Fuyuki <fuyuki@hadaly.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-IP
+PORTVERSION= 1.11
+CATEGORIES= net perl5 ipv6
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fuyuki@hadaly.org
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Net::IP.3
+
+post-patch:
+ ${PERL} -pi -e 's,/usr/local/ncc/bin,${PREFIX}/bin,' ${WRKSRC}/Makefile.PL
+ ${PERL} -pi -e 's,/usr/local/bin/perl5.6.0,${PERL},' ${WRKSRC}/ipcount
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-IP/distinfo b/net/p5-Net-IP/distinfo
new file mode 100644
index 000000000000..991306b1f230
--- /dev/null
+++ b/net/p5-Net-IP/distinfo
@@ -0,0 +1 @@
+MD5 (Net-IP-1.11.tar.gz) = 8dfdb26c1847ee4b2cb97f2e58f95892
diff --git a/net/p5-Net-IP/pkg-comment b/net/p5-Net-IP/pkg-comment
new file mode 100644
index 000000000000..2499eef6d5a9
--- /dev/null
+++ b/net/p5-Net-IP/pkg-comment
@@ -0,0 +1 @@
+Perl extension for manipulating IPv4/IPv6 addresses
diff --git a/net/p5-Net-IP/pkg-descr b/net/p5-Net-IP/pkg-descr
new file mode 100644
index 000000000000..99b6c56a85a0
--- /dev/null
+++ b/net/p5-Net-IP/pkg-descr
@@ -0,0 +1,11 @@
+This module provides functions to deal with IPv4/IPv6 addresses. The
+module can be used as a class, allowing the user to instantiate IP
+objects, which can be single IP addresses, prefixes, or ranges of
+addresses. There is also a procedural way of accessing most of the
+functions. Most subroutines can take either IPv4 or IPv6 addresses
+transparently.
+
+WWW: http://search.cpan.org/search?dist=Net-IP
+
+- Kimura Fuyuki
+fuyuki@hadaly.org
diff --git a/net/p5-Net-IP/pkg-plist b/net/p5-Net-IP/pkg-plist
new file mode 100644
index 000000000000..ae134f1ba1a2
--- /dev/null
+++ b/net/p5-Net-IP/pkg-plist
@@ -0,0 +1,7 @@
+bin/iptab
+bin/ipcount
+lib/perl5/site_perl/%%PERL_VER%%/Net/IP.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/IP/.packlist
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/IP
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true