aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2006-09-27 12:50:34 +0000
committerPeter Pentchev <roam@FreeBSD.org>2006-09-27 12:50:34 +0000
commita9134efc3ccd54f9c31dfc9c50402f91f126958b (patch)
treeb15fb51a9df73d2b820d2930e2186b07322c11f1 /net
parent6f7d861afc6235b6061a292e38cdce04ccfab207 (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/libnids/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/net/libnids/Makefile b/net/libnids/Makefile
index 8a64167ed394..76103a1eb6e7 100644
--- a/net/libnids/Makefile
+++ b/net/libnids/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libnids
PORTVERSION= 1.21
+PORTREVISION= 1
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,6 +16,7 @@ MAINTAINER= roam@FreeBSD.org
COMMENT= Network monitoring library with TCP/IP reassembly
OPTIONS= LIBNET "Include code requiring libnet" ON \
+ LIBNET10 "Use the old libnet-1.0.x version" ON \
GLIB2 "Use GLIB2 for multiprocessing support" ON
GNU_CONFIGURE= yes
@@ -27,8 +29,11 @@ MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_LIBNET)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
-RUN_DEPENDS+= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+.if !defined(WITHOUT_LIBNET10)
+BUILD_DEPENDS+= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+.else
+BUILD_DEPENDS+= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet
+.endif
.else
CONFIGURE_ARGS+= --disable-libnet
.endif