aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-05-18 16:06:35 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-05-18 16:06:35 +0000
commitb2d2533776fe5876b5082aff7e16195978eb7c56 (patch)
tree8f0941e718369cfc209808f4d099efb4e8821fe5 /net
parent4e99c2647dd194428edd760f4e5c1bf62bbb5f98 (diff)
downloadports-b2d2533776fe5876b5082aff7e16195978eb7c56.tar.gz
ports-b2d2533776fe5876b5082aff7e16195978eb7c56.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/vnc/Makefile6
-rw-r--r--net/vnc/distinfo6
-rw-r--r--net/vnc/files/patch-fix_Xvnc_no_valid_address10
3 files changed, 16 insertions, 6 deletions
diff --git a/net/vnc/Makefile b/net/vnc/Makefile
index 9bfd46e2d4f3..35ba7880679f 100644
--- a/net/vnc/Makefile
+++ b/net/vnc/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= vnc
-PORTVERSION= 4.1.1
+PORTVERSION= 4.1.2
CATEGORIES= net ipv6
MASTER_SITES= http://www.realvnc.com/:vnc
-DISTNAME= vnc-4_1_1-unixsrc
+DISTNAME= vnc-4_1_2-unixsrc
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:vnc
DIST_SUBDIR= xc
@@ -64,7 +64,7 @@ PLIST_SUB+= SERVER="@comment "
# No direct URL for VNC -- have to pseudo-submit their webform.
pre-fetch:
@${MKDIR} ${DISTDIR}/${DIST_SUBDIR} && cd ${DISTDIR}/${DIST_SUBDIR} && \
- ${FETCH_CMD} -o ${DISTNAME}.tar.gz 'http://www.realvnc.com/cgi-bin/download.cgi?product=free4/src/unix&acceptLicense=1&filever=4.1.1&filetype=tar_gz&haveDetails=1'
+ ${FETCH_CMD} -o ${DISTNAME}.tar.gz 'http://www.realvnc.com/cgi-bin/download.cgi?product=free4/src/unix&acceptLicense=1&haveDetails=1&filetype=tar_gz'
post-extract:
.if !defined(WITHOUT_SERVER)
diff --git a/net/vnc/distinfo b/net/vnc/distinfo
index bee5d8369978..58f2bf7117ae 100644
--- a/net/vnc/distinfo
+++ b/net/vnc/distinfo
@@ -1,6 +1,6 @@
-MD5 (xc/vnc-4_1_1-unixsrc.tar.gz) = 2ddf091a8be9f03bb991a553427d7b89
-SHA256 (xc/vnc-4_1_1-unixsrc.tar.gz) = 1f38a3074bd4089ae805675b447f7541e8e6705c3651eed540972cd0035cf5de
-SIZE (xc/vnc-4_1_1-unixsrc.tar.gz) = 529894
+MD5 (xc/vnc-4_1_2-unixsrc.tar.gz) = cf9a6fe8f592286b5e0fdde686504ffb
+SHA256 (xc/vnc-4_1_2-unixsrc.tar.gz) = ed73cd1abf4c4044032929fa2dd023d851f5fe37f88009523d3b08b7d836d542
+SIZE (xc/vnc-4_1_2-unixsrc.tar.gz) = 537713
MD5 (xc/X430src-1.tgz) = 4f241a4f867363f40efa2b00dca292af
SHA256 (xc/X430src-1.tgz) = 5276b045e154948fce7abba7d686406c65862d90b43b50f2546b33e38378f0d7
SIZE (xc/X430src-1.tgz) = 10993622
diff --git a/net/vnc/files/patch-fix_Xvnc_no_valid_address b/net/vnc/files/patch-fix_Xvnc_no_valid_address
new file mode 100644
index 000000000000..ebff974509f6
--- /dev/null
+++ b/net/vnc/files/patch-fix_Xvnc_no_valid_address
@@ -0,0 +1,10 @@
+--- xc/programs/Xserver/os/access.c.orig Fri Jan 27 16:23:17 2006
++++ xc/programs/Xserver/os/access.c Fri Jan 27 16:22:32 2006
+@@ -730,6 +730,7 @@
+ if (ifr->ifa_addr.sa_family == AF_DECnet)
+ continue;
+ #endif /* DNETCONN */
++ len = sizeof(*(ifr->ifa_addr));
+ family = ConvertAddr(ifr->ifa_addr, &len, (pointer *)&addr);
+ if (family == -1 || family == FamilyLocal)
+ continue;