aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-08-13 14:55:58 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-08-13 14:55:58 +0000
commitb72a7d7ddd59ba89b6dd736aeaf5b1c21ca01787 (patch)
treea49edfa3d1c82868bf547c6dcb3251fdf6dbdf14 /net
parentc216e0e34f22d56f8c065a425289ad826f92438c (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-miniupnpc/Makefile26
-rw-r--r--net/py-miniupnpc/pkg-plist1
3 files changed, 28 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 9d6df99a9e5b..6f0acce3173d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -772,6 +772,7 @@
SUBDIR += py-libdnet
SUBDIR += py-libnet
SUBDIR += py-medusa
+ SUBDIR += py-miniupnpc
SUBDIR += py-mp-random
SUBDIR += py-netaddr
SUBDIR += py-netifaces
diff --git a/net/py-miniupnpc/Makefile b/net/py-miniupnpc/Makefile
new file mode 100644
index 000000000000..2f7eaf5b12cc
--- /dev/null
+++ b/net/py-miniupnpc/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: py-miniupnpc
+# Date created: 9 Aug 2009
+# Whom: Anonymous
+#
+# $FreeBSD$
+#
+
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+COMMENT= Python module for miniupnpc
+
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/miniupnpc:build
+
+MASTERDIR= ${.CURDIR}/../miniupnpc
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+WRKDIR= ${WRKDIRPREFIX}${MASTERDIR}/work
+PLIST= ${.CURDIR}/pkg-plist
+
+.if exists(${.CURDIR}/Makefile.local)
+.include "${.CURDIR}/Makefile.local"
+.endif
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/py-miniupnpc/pkg-plist b/net/py-miniupnpc/pkg-plist
new file mode 100644
index 000000000000..fd5ba6564707
--- /dev/null
+++ b/net/py-miniupnpc/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/miniupnpc.so