aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-06-18 13:49:02 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-06-18 13:49:02 +0000
commitb93bdbe2d6803d6f19ea9973ab9d54f7b17e95bc (patch)
treecb7a0ada1fdd2f94e8d58a566a456bccdef69c6a /net
parent3d129c12f3f2f38eb9c628fc4fec1a491eca754f (diff)
downloadports-b93bdbe2d6803d6f19ea9973ab9d54f7b17e95bc.tar.gz
ports-b93bdbe2d6803d6f19ea9973ab9d54f7b17e95bc.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/httpry/Makefile3
-rw-r--r--net/p5-AnyEvent-Twitter/Makefile8
-rw-r--r--net/p5-Geo-IPfree/Makefile9
-rw-r--r--net/p5-Net-Google-Spreadsheets/Makefile8
-rw-r--r--net/p5-Net-GrowlClient/Makefile9
-rw-r--r--net/p5-Net-OAuth/Makefile9
-rw-r--r--net/p5-Net-Todoist/Makefile8
-rw-r--r--net/p5-RPC-XML/Makefile8
-rw-r--r--net/p5-Socket-GetAddrInfo/Makefile4
-rw-r--r--net/p5-Socket-Multicast6/Makefile10
-rw-r--r--net/p5-URI-Query/Makefile8
-rw-r--r--net/p5-URI-SmartURI/Makefile8
-rw-r--r--net/radiator/Makefile5
13 files changed, 11 insertions, 86 deletions
diff --git a/net/httpry/Makefile b/net/httpry/Makefile
index 5fe4cf5af3e7..52633d3a0e8e 100644
--- a/net/httpry/Makefile
+++ b/net/httpry/Makefile
@@ -22,9 +22,6 @@ EXTRASCRIPTS_DESC= Install additional scripts
PLIST_SUB= EXTRASCRIPTS=""
USE_PERL5_RUN= yes
RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
-. if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-. endif
.else
PLIST_SUB= EXTRASCRIPTS="@comment "
.endif
diff --git a/net/p5-AnyEvent-Twitter/Makefile b/net/p5-AnyEvent-Twitter/Makefile
index c3d3f4ce720d..d053772e59dd 100644
--- a/net/p5-AnyEvent-Twitter/Makefile
+++ b/net/p5-AnyEvent-Twitter/Makefile
@@ -26,10 +26,4 @@ PERL_CONFIGURE= yes
MAN3= AnyEvent::Twitter.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Geo-IPfree/Makefile b/net/p5-Geo-IPfree/Makefile
index 8dc3c7ca6bd0..5064e78d48a8 100644
--- a/net/p5-Geo-IPfree/Makefile
+++ b/net/p5-Geo-IPfree/Makefile
@@ -16,11 +16,4 @@ PERL_CONFIGURE= yes
MAN3= Geo::IPfree.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501200
-BUILD_DEPENDS+= p5-Memoize>=0:${PORTSDIR}/devel/p5-Memoize
-RUN_DEPENDS+= p5-Memoize>=0:${PORTSDIR}/devel/p5-Memoize
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Google-Spreadsheets/Makefile b/net/p5-Net-Google-Spreadsheets/Makefile
index 71e31ca66f9e..1422ace12dd8 100644
--- a/net/p5-Net-Google-Spreadsheets/Makefile
+++ b/net/p5-Net-Google-Spreadsheets/Makefile
@@ -37,10 +37,4 @@ MAN3= Net::Google::Spreadsheets.3 \
Net::Google::Spreadsheets::Table.3 \
Net::Google::Spreadsheets::Worksheet.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-GrowlClient/Makefile b/net/p5-Net-GrowlClient/Makefile
index 5a6acb014bc1..38e1c03879fd 100644
--- a/net/p5-Net-GrowlClient/Makefile
+++ b/net/p5-Net-GrowlClient/Makefile
@@ -20,11 +20,4 @@ PERL_CONFIGURE= yes
MAN3= Net::GrowlClient.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
-BUILD_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-OAuth/Makefile b/net/p5-Net-OAuth/Makefile
index d67f12c2383d..d21eaff28bbe 100644
--- a/net/p5-Net-OAuth/Makefile
+++ b/net/p5-Net-OAuth/Makefile
@@ -49,11 +49,4 @@ MAN3= Net::OAuth.3 \
Net::OAuth::XauthAccessTokenRequest.3 \
Net::OAuth::YahooAccessTokenRefreshRequest.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-Encode>=2.35:${PORTSDIR}/converters/p5-Encode
-RUN_DEPENDS+= p5-Encode>=2.35:${PORTSDIR}/converters/p5-Encode
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Todoist/Makefile b/net/p5-Net-Todoist/Makefile
index d3f69ac1cd2d..a9c7234f6952 100644
--- a/net/p5-Net-Todoist/Makefile
+++ b/net/p5-Net-Todoist/Makefile
@@ -21,10 +21,4 @@ PERL_CONFIGURE= yes
MAN3= Net::Todoist.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-BUILD_DEPENDS+= p5-ExtUtils-MakeMaker>=6.31:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-RPC-XML/Makefile b/net/p5-RPC-XML/Makefile
index d4395ad7b65f..3b5a573e9d8d 100644
--- a/net/p5-RPC-XML/Makefile
+++ b/net/p5-RPC-XML/Makefile
@@ -35,10 +35,4 @@ MAN3= Apache::RPC::Server.3 \
RPC::XML::Procedure.3 \
RPC::XML::Server.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501200
-TEST_DEPENDS+= p5-Test-Simple>=0.94:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Socket-GetAddrInfo/Makefile b/net/p5-Socket-GetAddrInfo/Makefile
index 19119929d706..f0c6501fcf18 100644
--- a/net/p5-Socket-GetAddrInfo/Makefile
+++ b/net/p5-Socket-GetAddrInfo/Makefile
@@ -27,10 +27,6 @@ PERL_CONFIGURE= yes
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= p5-Module-Build>=0:${PORTSDIR}/devel/p5-Module-Build
-.endif
-
.if ${PERL_LEVEL} < 501400
PLIST_SUB+= OLD_PERL="" NEW_PERL="@comment "
.else
diff --git a/net/p5-Socket-Multicast6/Makefile b/net/p5-Socket-Multicast6/Makefile
index a3b4f825a5bc..5404c19cac8b 100644
--- a/net/p5-Socket-Multicast6/Makefile
+++ b/net/p5-Socket-Multicast6/Makefile
@@ -11,7 +11,7 @@ CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Constructors and constants for IPv4/IPv6 multicast socket operations
RUN_DEPENDS= p5-Socket6>=0.19:${PORTSDIR}/net/p5-Socket6
@@ -20,10 +20,4 @@ PERL_MODBUILD= yes
MAN3= Socket::Multicast6.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-BUILD_DEPENDS+= p5-ExtUtils-CBuilder>=0:${PORTSDIR}/devel/p5-ExtUtils-CBuilder
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-URI-Query/Makefile b/net/p5-URI-Query/Makefile
index 8f5b96776dae..e35d7a933273 100644
--- a/net/p5-URI-Query/Makefile
+++ b/net/p5-URI-Query/Makefile
@@ -24,10 +24,4 @@ PERL_CONFIGURE= yes
MAN3= URI::Query.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-URI-SmartURI/Makefile b/net/p5-URI-SmartURI/Makefile
index 608754c10db6..745cda01577e 100644
--- a/net/p5-URI-SmartURI/Makefile
+++ b/net/p5-URI-SmartURI/Makefile
@@ -32,10 +32,4 @@ PERL_CONFIGURE= yes
MAN3= URI::SmartURI.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501200
-TEST_DEPENDS+= p5-Test-Simple>=0.94:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/radiator/Makefile b/net/radiator/Makefile
index 9d5ceae7fb28..95118e85b612 100644
--- a/net/radiator/Makefile
+++ b/net/radiator/Makefile
@@ -21,11 +21,6 @@ RESTRICTED= Commercial software
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
-BUILD_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
-.endif
-
.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTFILES})
IGNORE= will not be automatically fetched due to licensing\
restrictions. You MUST manually fetch the UNIX version after\