aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-05-12 16:17:50 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-05-12 16:17:50 +0000
commiteef97b97cfffac00cc54ba5d08e4c6c9e77a66e3 (patch)
treec8146e8c81fb1c94942b75e37edd297123379edd /net
parent31af44656c7e117f271792f9a1ea0c6e29e2c52b (diff)
downloadports-eef97b97cfffac00cc54ba5d08e4c6c9e77a66e3.tar.gz
ports-eef97b97cfffac00cc54ba5d08e4c6c9e77a66e3.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/pmacct/Makefile32
-rw-r--r--net/pmacct/distinfo1
-rw-r--r--net/pmacct/pkg-descr10
-rw-r--r--net/pmacct/pkg-plist2
5 files changed, 46 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index bf7d3d6f5f28..fc5ae0ee17e3 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -500,6 +500,7 @@
SUBDIR += pim6sd
SUBDIR += pipsecd
SUBDIR += plb
+ SUBDIR += pmacct
SUBDIR += pmf
SUBDIR += poink
SUBDIR += poptop
diff --git a/net/pmacct/Makefile b/net/pmacct/Makefile
new file mode 100644
index 000000000000..a5b2e19aea4c
--- /dev/null
+++ b/net/pmacct/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: pmacct
+# Date created: Thu May 8 16:03:11 CEST 2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pmacct
+PORTVERSION= 0.4.1
+CATEGORIES= net
+MASTER_SITES= http://www.ba.cnr.it/~paolo/pmacct/
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= Network tool to gather IP traffic information
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+
+.if defined(WITH_MYSQL)
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+CONFIGURE_ARGS+=--with-mysql-lib=${LOCALBASE}/lib/mysql \
+ --with-mysql-includes=${LOCALBASE}/include/mysql \
+ --enable-mysql
+.else
+CONFIGURE_ARGS+= --disable-mysql
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/pmacct/distinfo b/net/pmacct/distinfo
new file mode 100644
index 000000000000..14dd38bd545c
--- /dev/null
+++ b/net/pmacct/distinfo
@@ -0,0 +1 @@
+MD5 (pmacct-0.4.1.tar.gz) = 67c786bde193b027be6083348e43f901
diff --git a/net/pmacct/pkg-descr b/net/pmacct/pkg-descr
new file mode 100644
index 000000000000..38ca49b26874
--- /dev/null
+++ b/net/pmacct/pkg-descr
@@ -0,0 +1,10 @@
+pmacct is a network tool to gather IP traffic information (bytes counter and
+number of packets). Aggregation of statistics is done either by looking at
+destination, source, both source and destination, or unidirectional IP flows.
+Data is stored in an in-memory table or using an SQL database (currently only
+MySQL). The content of these tables can be later retrieved by a client program
+via a local stream-oriented connection (for simple output or export to MRTG) or
+via an SQL client. Gathering packets off the wire is done with the pcap library
+and promiscuous mode of one or more network interfaces.
+
+WWW: http://www.ba.cnr.it/~paolo/pmacct/
diff --git a/net/pmacct/pkg-plist b/net/pmacct/pkg-plist
new file mode 100644
index 000000000000..e7872b7a40ab
--- /dev/null
+++ b/net/pmacct/pkg-plist
@@ -0,0 +1,2 @@
+bin/pmacct
+bin/pmacctd