aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2013-04-18 17:16:06 +0000
committerFrederic Culot <culot@FreeBSD.org>2013-04-18 17:16:06 +0000
commit1ef71c605a92530840c688966641d38962ad91f2 (patch)
treeeedf9ff41ff0b20a72c637730a4fdb786dc80799 /net
parent3a09b6b8df9617a094a3872ac9934b915bc6527b (diff)
downloadports-1ef71c605a92530840c688966641d38962ad91f2.tar.gz
ports-1ef71c605a92530840c688966641d38962ad91f2.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/p5-perl-ldap/Makefile18
-rw-r--r--net/p5-perl-ldap/distinfo4
-rw-r--r--net/p5-perl-ldap/pkg-plist12
3 files changed, 21 insertions, 13 deletions
diff --git a/net/p5-perl-ldap/Makefile b/net/p5-perl-ldap/Makefile
index b8d0260a2e43..8fc15f671c80 100644
--- a/net/p5-perl-ldap/Makefile
+++ b/net/p5-perl-ldap/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= perl-ldap
-PORTVERSION= 0.4400
+PORTVERSION= 0.5400
CATEGORIES= net perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:MARSCHAP
@@ -13,19 +13,19 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Client interface to LDAP (includes Net::LDAP)
BUILD_DEPENDS= p5-Authen-SASL>=2.00:${PORTSDIR}/security/p5-Authen-SASL \
- p5-Convert-ASN1>=0.07:${PORTSDIR}/converters/p5-Convert-ASN1 \
+ p5-Convert-ASN1>=0.20:${PORTSDIR}/converters/p5-Convert-ASN1 \
p5-IO-Socket-SSL>=1.26:${PORTSDIR}/security/p5-IO-Socket-SSL \
p5-URI>=1.10:${PORTSDIR}/net/p5-URI \
- p5-XML-SAX-Writer>=0:${PORTSDIR}/textproc/p5-XML-SAX-Writer
-RUN_DEPENDS= p5-Authen-SASL>=2.00:${PORTSDIR}/security/p5-Authen-SASL \
- p5-Convert-ASN1>=0.07:${PORTSDIR}/converters/p5-Convert-ASN1 \
- p5-IO-Socket-SSL>=1.26:${PORTSDIR}/security/p5-IO-Socket-SSL \
- p5-URI>=1.10:${PORTSDIR}/net/p5-URI \
- p5-XML-SAX-Writer>=0:${PORTSDIR}/textproc/p5-XML-SAX-Writer
+ p5-XML-SAX-Base>0:${PORTSDIR}/textproc/p5-XML-SAX-Base \
+ p5-XML-SAX-Writer>0:${PORTSDIR}/textproc/p5-XML-SAX-Writer
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= Bundle::Net::LDAP.3 \
+ LWP::Protocol::ldap.3 \
+ LWP::Protocol::ldapi.3 \
+ LWP::Protocol::ldaps.3 \
Net::LDAP.3 \
Net::LDAP::Constant.3 \
Net::LDAP::Control.3 \
@@ -54,6 +54,8 @@ MAN3= Bundle::Net::LDAP.3 \
Net::LDAP::Extension::SetPassword.3 \
Net::LDAP::Extension::WhoAmI.3 \
Net::LDAP::Extra.3 \
+ Net::LDAP::Extra::eDirectory.3 \
+ Net::LDAP::Extra::AD.3 \
Net::LDAP::FAQ.3 \
Net::LDAP::Filter.3 \
Net::LDAP::FilterMatch.3 \
diff --git a/net/p5-perl-ldap/distinfo b/net/p5-perl-ldap/distinfo
index 3acb0df14411..ac1b6fcbc228 100644
--- a/net/p5-perl-ldap/distinfo
+++ b/net/p5-perl-ldap/distinfo
@@ -1,2 +1,2 @@
-SHA256 (perl-ldap-0.44.tar.gz) = 6c398f32bf598ee139d111b5fd91cda1e77ca0fb3a57e9616909efdec5d4cacb
-SIZE (perl-ldap-0.44.tar.gz) = 262973
+SHA256 (perl-ldap-0.54.tar.gz) = 1a99d9ff56dbb8c26ce7ace5476892db6ee345d77a519235b130e8b0d1ed1876
+SIZE (perl-ldap-0.54.tar.gz) = 299693
diff --git a/net/p5-perl-ldap/pkg-plist b/net/p5-perl-ldap/pkg-plist
index d45dae44dedc..a970f32e6786 100644
--- a/net/p5-perl-ldap/pkg-plist
+++ b/net/p5-perl-ldap/pkg-plist
@@ -1,5 +1,6 @@
%%SITE_PERL%%/Bundle/Net/LDAP.pm
%%SITE_PERL%%/LWP/Protocol/ldap.pm
+%%SITE_PERL%%/LWP/Protocol/ldapi.pm
%%SITE_PERL%%/LWP/Protocol/ldaps.pm
%%SITE_PERL%%/Net/LDAP.pm
%%SITE_PERL%%/Net/LDAP.pod
@@ -34,6 +35,8 @@
%%SITE_PERL%%/Net/LDAP/Extension/SetPassword.pm
%%SITE_PERL%%/Net/LDAP/Extension/WhoAmI.pm
%%SITE_PERL%%/Net/LDAP/Extra.pm
+%%SITE_PERL%%/Net/LDAP/Extra/AD.pm
+%%SITE_PERL%%/Net/LDAP/Extra/eDirectory.pm
%%SITE_PERL%%/Net/LDAP/FAQ.pod
%%SITE_PERL%%/Net/LDAP/Filter.pm
%%SITE_PERL%%/Net/LDAP/Filter.pod
@@ -55,10 +58,13 @@
%%SITE_PERL%%/Net/LDAP/Util.pm
%%SITE_PERL%%/Net/LDAPI.pm
%%SITE_PERL%%/Net/LDAPS.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/LDAP/.packlist
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/LDAP
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+%%SITE_PERL%%/mach/auto/Net/LDAP/.packlist
+@dirrmtry %%SITE_PERL%%/mach/auto/Net/LDAP
+@dirrmtry %%SITE_PERL%%/mach/auto/Net
+@dirrmtry %%SITE_PERL%%/mach/auto
+@dirrmtry %%SITE_PERL%%/mach
@dirrmtry %%SITE_PERL%%/Net/LDAP/Intermediate
+@dirrmtry %%SITE_PERL%%/Net/LDAP/Extra
@dirrmtry %%SITE_PERL%%/Net/LDAP/Extension
@dirrmtry %%SITE_PERL%%/Net/LDAP/Control
@dirrmtry %%SITE_PERL%%/Net/LDAP