aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-06 16:11:30 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-06 16:11:30 +0000
commit3d017a688622e8dfbc020a020058de1a277f526b (patch)
tree4a51b775a74e2a77d74eded4714f5fdb1a9d89ac /net
parent8a4b4aeb1fa6e5fafdf1da900295b2e652520e89 (diff)
downloadports-3d017a688622e8dfbc020a020058de1a277f526b.tar.gz
ports-3d017a688622e8dfbc020a020058de1a277f526b.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/entitymib/Makefile3
-rw-r--r--net/lla/Makefile2
-rw-r--r--net/p5-Net-FTP-AutoReconnect/Makefile3
-rw-r--r--net/p5-Net-Google-Calendar/Makefile3
-rw-r--r--net/p5-Net-Google-DataAPI/Makefile3
-rw-r--r--net/p5-Net-LDAP-posixGroup/Makefile3
-rw-r--r--net/p5-Net-LimeLight-Purge/Makefile3
-rw-r--r--net/p5-Net-Nessus-XMLRPC/Makefile3
-rw-r--r--net/p5-Net-Ping/Makefile3
-rw-r--r--net/p5-Net-Syslog/Makefile3
-rw-r--r--net/p5-Net-TcpDumpLog/Makefile3
-rw-r--r--net/p5-Net-Twitter-Lite/Makefile3
-rw-r--r--net/p5-NetPacket/Makefile3
-rw-r--r--net/p5-POE-Component-Client-Ident/Makefile3
-rw-r--r--net/p5-RPC-EPC-Service/Makefile3
-rw-r--r--net/p5-Socket6/Makefile3
-rw-r--r--net/p5-ZConf-Bookmarks/Makefile3
-rw-r--r--net/rude/Makefile2
-rw-r--r--net/sip_scenario/Makefile3
19 files changed, 36 insertions, 19 deletions
diff --git a/net/entitymib/Makefile b/net/entitymib/Makefile
index 78c276ba7b0f..161a9cba174b 100644
--- a/net/entitymib/Makefile
+++ b/net/entitymib/Makefile
@@ -21,7 +21,8 @@ COMMENT=Display the Entity MIB of an SNMP agent
RUN_DEPENDS= p5-Tree-DAG_Node>=0:${PORTSDIR}/devel/p5-Tree-DAG_Node \
net-snmp>=0:${PORTSDIR}/net-mgmt/net-snmp
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
MAN1= entitymib.1
NO_BUILD= nope
diff --git a/net/lla/Makefile b/net/lla/Makefile
index 5a8906b2e20e..2c1f8d2d88c8 100644
--- a/net/lla/Makefile
+++ b/net/lla/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc \
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_PERL5= yes
+USES= perl5
PLIST_FILES= bin/lla
EXTRACT_CMD= ${CP}
diff --git a/net/p5-Net-FTP-AutoReconnect/Makefile b/net/p5-Net-FTP-AutoReconnect/Makefile
index e185a4005d93..7d1601c5cf18 100644
--- a/net/p5-Net-FTP-AutoReconnect/Makefile
+++ b/net/p5-Net-FTP-AutoReconnect/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jase@FreeBSD.org
COMMENT= A Perl5 FTP client class with automatic reconnect on failure
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::FTP::AutoReconnect.3
diff --git a/net/p5-Net-Google-Calendar/Makefile b/net/p5-Net-Google-Calendar/Makefile
index 679f84388e8a..dbab079327fa 100644
--- a/net/p5-Net-Google-Calendar/Makefile
+++ b/net/p5-Net-Google-Calendar/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-XML-Atom>=0.37:${PORTSDIR}/textproc/p5-XML-Atom \
p5-Net-Google-AuthSub>=0:${PORTSDIR}/net/p5-Net-Google-AuthSub
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Net::Google::Calendar.3 Net::Google::Calendar::Base.3 \
Net::Google::Calendar::Calendar.3 Net::Google::Calendar::Comments.3 \
diff --git a/net/p5-Net-Google-DataAPI/Makefile b/net/p5-Net-Google-DataAPI/Makefile
index 217c556414c7..11f83aeb09b1 100644
--- a/net/p5-Net-Google-DataAPI/Makefile
+++ b/net/p5-Net-Google-DataAPI/Makefile
@@ -35,7 +35,8 @@ TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-MockObject>=0:${PORTSDIR}/devel/p5-Test-MockObject \
p5-Test-Warn>=0:${PORTSDIR}/devel/p5-Test-Warn
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Google::DataAPI.3 \
Net::Google::DataAPI::Auth::ClientLogin::Multiple.3 \
diff --git a/net/p5-Net-LDAP-posixGroup/Makefile b/net/p5-Net-LDAP-posixGroup/Makefile
index 170b41014b7a..0ebf5f861e8a 100644
--- a/net/p5-Net-LDAP-posixGroup/Makefile
+++ b/net/p5-Net-LDAP-posixGroup/Makefile
@@ -17,7 +17,8 @@ COMMENT= Creates new Net::LDAP::Entry objects for a posixGroup entry
RUN_DEPENDS= p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::LDAP::posixGroup.3
diff --git a/net/p5-Net-LimeLight-Purge/Makefile b/net/p5-Net-LimeLight-Purge/Makefile
index 97983c655947..91a4e0169ee1 100644
--- a/net/p5-Net-LimeLight-Purge/Makefile
+++ b/net/p5-Net-LimeLight-Purge/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-DateTime-Format-ISO8601>=0.06:${PORTSDIR}/devel/p5-DateTime-Form
p5-MooseX-AttributeHelpers>=0.14:${PORTSDIR}/devel/p5-MooseX-AttributeHelpers \
p5-SOAP-Lite>=0.710.08:${PORTSDIR}/net/p5-SOAP-Lite
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::LimeLight::Purge.3 \
Net::LimeLight::Purge::Request.3 \
diff --git a/net/p5-Net-Nessus-XMLRPC/Makefile b/net/p5-Net-Nessus-XMLRPC/Makefile
index e68e0a0d07bb..267bc7f3afe6 100644
--- a/net/p5-Net-Nessus-XMLRPC/Makefile
+++ b/net/p5-Net-Nessus-XMLRPC/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Nessus::XMLRPC.3
diff --git a/net/p5-Net-Ping/Makefile b/net/p5-Net-Ping/Makefile
index 42afbb2ccf5b..fd638802c203 100644
--- a/net/p5-Net-Ping/Makefile
+++ b/net/p5-Net-Ping/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sem@FreeBSD.org
COMMENT= A perl module to check a remote host for reachability
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Ping.3
diff --git a/net/p5-Net-Syslog/Makefile b/net/p5-Net-Syslog/Makefile
index ca088a5755ce..c7e9ffe620e9 100644
--- a/net/p5-Net-Syslog/Makefile
+++ b/net/p5-Net-Syslog/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sobomax@FreeBSD.org
COMMENT= Perl extension for sending syslog messages to a remote syslogd
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Syslog.3
diff --git a/net/p5-Net-TcpDumpLog/Makefile b/net/p5-Net-TcpDumpLog/Makefile
index 9c648f729909..c9c565c6baf8 100644
--- a/net/p5-Net-TcpDumpLog/Makefile
+++ b/net/p5-Net-TcpDumpLog/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Read tcpdump/libpcap network packet logs
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::TcpDumpLog.3
diff --git a/net/p5-Net-Twitter-Lite/Makefile b/net/p5-Net-Twitter-Lite/Makefile
index 4f2659591870..55dae4ab6ed8 100644
--- a/net/p5-Net-Twitter-Lite/Makefile
+++ b/net/p5-Net-Twitter-Lite/Makefile
@@ -30,7 +30,8 @@ RUN_DEPENDS= p5-JSON>=2.02:${PORTSDIR}/converters/p5-JSON \
p5-Net-OAuth>=0.25:${PORTSDIR}/net/p5-Net-OAuth \
p5-Crypt-SSLeay>=0.5:${PORTSDIR}/security/p5-Crypt-SSLeay
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Twitter::Lite.3 Net::Twitter::Lite::API::V1.3 \
Net::Twitter::Lite::API::V1_1.3 Net::Twitter::Lite::Error.3 \
Net::Twitter::Lite::WithAPIv1_1.3
diff --git a/net/p5-NetPacket/Makefile b/net/p5-NetPacket/Makefile
index 95ee82fb2712..1345df4cb534 100644
--- a/net/p5-NetPacket/Makefile
+++ b/net/p5-NetPacket/Makefile
@@ -16,7 +16,8 @@ COMMENT= Modules to assemble/disassemble network packets at the protocol level
LICENSE= ART20
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= NetPacket.3 NetPacket::ARP.3 NetPacket::Ethernet.3 \
NetPacket::ICMP.3 NetPacket::IGMP.3 NetPacket::UDP.3\
diff --git a/net/p5-POE-Component-Client-Ident/Makefile b/net/p5-POE-Component-Client-Ident/Makefile
index df6ad35cdc08..524615da4ec6 100644
--- a/net/p5-POE-Component-Client-Ident/Makefile
+++ b/net/p5-POE-Component-Client-Ident/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-POE>=0.9999:${PORTSDIR}/devel/p5-POE
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-POE-Server-TCP>=0:${PORTSDIR}/devel/p5-Test-POE-Server-TCP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Component::Client::Ident.3 \
POE::Component::Client::Ident::Agent.3 \
diff --git a/net/p5-RPC-EPC-Service/Makefile b/net/p5-RPC-EPC-Service/Makefile
index 96abad63d0d1..d5ec53f6d253 100644
--- a/net/p5-RPC-EPC-Service/Makefile
+++ b/net/p5-RPC-EPC-Service/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= \
p5-Data-SExpression>=0.41:${PORTSDIR}/devel/p5-Data-SExpression
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= RPC::EPC::Service.3
diff --git a/net/p5-Socket6/Makefile b/net/p5-Socket6/Makefile
index b5a1f1e992c6..1d106016e826 100644
--- a/net/p5-Socket6/Makefile
+++ b/net/p5-Socket6/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ume@FreeBSD.org
COMMENT= IPv6 related part of the C socket.h defines and structure manipulators
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ENV+= CC="${CC}" CFLAGS="${CFLAGS}"
PLIST_FILES= %%SITE_PERL%%/%%PERL_ARCH%%/Socket6.pm \
diff --git a/net/p5-ZConf-Bookmarks/Makefile b/net/p5-ZConf-Bookmarks/Makefile
index e3e7f8e8b9f3..3ad357745542 100644
--- a/net/p5-ZConf-Bookmarks/Makefile
+++ b/net/p5-ZConf-Bookmarks/Makefile
@@ -17,7 +17,8 @@ COMMENT= A system for bookmarking URIs using ZConf
RUN_DEPENDS= p5-ZConf>=0:${PORTSDIR}/net/p5-ZConf
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ZConf::Bookmarks.3
diff --git a/net/rude/Makefile b/net/rude/Makefile
index 3625a98a3b7c..ffac83e39e62 100644
--- a/net/rude/Makefile
+++ b/net/rude/Makefile
@@ -14,7 +14,7 @@ RUN_DEPENDS= p5-Tk>=0:${PORTSDIR}/x11-toolkits/p5-Tk
HAS_CONFIGURE= yes
CONFIGURE_ENV= --with-debug-lvl=3
-USE_PERL5= yes
+USES= perl5
WRKSRC= ${WRKDIR}/${PORTNAME}
MAN8= rude.8 crude.8
diff --git a/net/sip_scenario/Makefile b/net/sip_scenario/Makefile
index 37c6cf1d0d6e..77d36cb3d0c1 100644
--- a/net/sip_scenario/Makefile
+++ b/net/sip_scenario/Makefile
@@ -13,7 +13,8 @@ COMMENT= SIP call flow creator (HTML format)
LICENSE= AL2
USE_ZIP= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
WRKSRC= ${WRKDIR}