aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>1999-06-16 16:47:38 +0000
committerBill Fumerola <billf@FreeBSD.org>1999-06-16 16:47:38 +0000
commit659b107e5bff77df45078459583a11fc8d9f1c77 (patch)
treeaea115061e1cc7c8e18b075f4ffea24ad280d4cf /net
parent906080c6cee3dc99b904e679b5f8038a015ea921 (diff)
downloadports-659b107e5bff77df45078459583a11fc8d9f1c77.tar.gz
ports-659b107e5bff77df45078459583a11fc8d9f1c77.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/rtsp_proxy/Makefile40
-rw-r--r--net/rtsp_proxy/distinfo1
-rw-r--r--net/rtsp_proxy/files/patch-aa21
-rw-r--r--net/rtsp_proxy/files/patch-ab11
-rw-r--r--net/rtsp_proxy/files/rtsp_proxy.sh5
-rw-r--r--net/rtsp_proxy/pkg-comment1
-rw-r--r--net/rtsp_proxy/pkg-descr17
-rw-r--r--net/rtsp_proxy/pkg-message3
-rw-r--r--net/rtsp_proxy/pkg-plist3
9 files changed, 102 insertions, 0 deletions
diff --git a/net/rtsp_proxy/Makefile b/net/rtsp_proxy/Makefile
new file mode 100644
index 000000000000..1f474d96eea8
--- /dev/null
+++ b/net/rtsp_proxy/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: rtsp_proxy
+# Version required: 1.0
+# Date created: 8 June 1999
+# Whom: Richard Kiss <richard@homemail.com>
+#
+# $Id: $
+#
+
+DISTNAME= rtsp_proxy
+PKGNAME= ${DISTNAME}-1.0
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.apple.com/Quicktime/developers/
+EXTRACT_SUFX= .src.sh
+
+MAINTAINER= richard@homemail.com
+
+NO_CDROM= "Apple has a complex license for this software."
+WRKSRC= ${WRKDIR}/${DISTNAME}/proxy_unix
+ALL_TARGET=
+
+proxyunix = ${WRKSRC}/proxy_unix.c
+
+post-patch:
+ @ ${MV} ${proxyunix} ${proxyunix}.bak
+ @ ${SED} -e 's#/etc#${PREFIX}/etc#' < ${proxyunix}.bak > ${proxyunix}
+
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ @cd ${WRKDIR} && yes "I AGREE" | ${SH} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/rtsp_proxy ${PREFIX}/sbin
+ @ ${INSTALL_SCRIPT} ${FILESDIR}/rtsp_proxy.sh ${PREFIX}/etc/rc.d
+ @ ${INSTALL_DATA} ${WRKSRC}/../qts_proxy.conf ${PREFIX}/etc/
+
+post-install:
+ @ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net/rtsp_proxy/distinfo b/net/rtsp_proxy/distinfo
new file mode 100644
index 000000000000..973965b9bcbe
--- /dev/null
+++ b/net/rtsp_proxy/distinfo
@@ -0,0 +1 @@
+MD5 (rtsp_proxy.src.sh) = 53e444080fe967f055b549460f0c4b51
diff --git a/net/rtsp_proxy/files/patch-aa b/net/rtsp_proxy/files/patch-aa
new file mode 100644
index 000000000000..6cc8020ee4dd
--- /dev/null
+++ b/net/rtsp_proxy/files/patch-aa
@@ -0,0 +1,21 @@
+--- Makefile Wed Apr 21 15:45:50 1999
++++ Makefile Tue Jun 8 01:54:44 1999
+@@ -1,6 +1,7 @@
+ NAME=rtsp_proxy
+ OPT=-g
+ FLAGS=$(OPT) -Dunix -I..
++BSDFLAGS=-DUSE_THREAD=1 -I..
+ SGIFLAGS=-signed -Xcpluscomm -DUSE_THREAD=1
+ SUNFLAGS=-xCC -DUSE_THREAD=1
+ LINUXFLAGS=-DUSE_THREAD=0
+@@ -22,6 +23,10 @@
+ $(MAINDIR)util.h \
+ $(MAINDIR)shared_udp.h \
+ $(MAINDIR)getopt.h
++
++freebsd: $(NAME)
++$(NAME): $(SRC) $(HDR)
++ $(CC) $(CFLAGS) $(BSDFLAGS) $(SRC) -o $(NAME) -lc_r
+
+ sgi: $(NAME).sgi
+ $(NAME).sgi: $(SRC) $(HDR)
diff --git a/net/rtsp_proxy/files/patch-ab b/net/rtsp_proxy/files/patch-ab
new file mode 100644
index 000000000000..a23231dab8b6
--- /dev/null
+++ b/net/rtsp_proxy/files/patch-ab
@@ -0,0 +1,11 @@
+--- ../qts_proxy.conf Wed Apr 21 15:45:50 1999
++++ ../qts_proxy.conf Tue Jun 8 01:51:04 1999
+@@ -7,7 +7,7 @@
+ # NOTE: lack of this line allows connections from any IP address
+ # It is best to limit incoming connections to your internal network.
+ #
+-allow 17.0.0.0/8
++allow 10.0.0.0/8
+
+ #
+ # users specifies the maximum number of simultaneous users
diff --git a/net/rtsp_proxy/files/rtsp_proxy.sh b/net/rtsp_proxy/files/rtsp_proxy.sh
new file mode 100644
index 000000000000..2d3bebe4f5c0
--- /dev/null
+++ b/net/rtsp_proxy/files/rtsp_proxy.sh
@@ -0,0 +1,5 @@
+--- rtsp_proxy.sh Wed Dec 31 16:00:00 1969
++++ rtsp_proxy.sh Tue Jun 8 22:54:49 1999
+@@ -0,0 +1,2 @@
++#!/bin/sh
++[ -x /usr/local/sbin/rtsp_proxy ] && /usr/local/sbin/rtsp_proxy > /dev/null & && echo $! > /var/run/rtsp_proxy.pid && echo -n ' rtsp_proxy'
diff --git a/net/rtsp_proxy/pkg-comment b/net/rtsp_proxy/pkg-comment
new file mode 100644
index 000000000000..e8c99bb3c658
--- /dev/null
+++ b/net/rtsp_proxy/pkg-comment
@@ -0,0 +1 @@
+Apple Computer's open source RTP/RTSP streaming Quicktime proxy.
diff --git a/net/rtsp_proxy/pkg-descr b/net/rtsp_proxy/pkg-descr
new file mode 100644
index 000000000000..4f6c17a5a4d7
--- /dev/null
+++ b/net/rtsp_proxy/pkg-descr
@@ -0,0 +1,17 @@
+This is a port of Apple Computer's open source rtsp_proxy.
+
+QuickTime streaming uses RTP/RTSP protocols
+
+Recommendations for Firewall Administrators:
+QuickTime follows the conventions of the RTP and RTSP internet standards
+to stream media over the web. To enable QuickTime 4 to work properly
+inside your firewall, please follow the following IETF recommendation:
+
+- Open port 554 for RTSP/TCP data.
+- Open ports 6970 through 6999 (inclusive) for RTP/UDP data.
+
+For more information on the RTP and RTSP internet standards:
+- RTSP: http://info.internet.isi.edu:80/in-notes/rfc/files/rfc2326.txt
+- RTP: http://info.internet.isi.edu:80/in-notes/rfc/files/rfc1889.txt
+
+WWW: http://www.apple.com/quicktime/developers/rtsproxy.html
diff --git a/net/rtsp_proxy/pkg-message b/net/rtsp_proxy/pkg-message
new file mode 100644
index 000000000000..62b88671440b
--- /dev/null
+++ b/net/rtsp_proxy/pkg-message
@@ -0,0 +1,3 @@
+**************************************************************************
+You may need to adjust the configuration in ${PREFIX}/etc/qts_proxy.conf.
+**************************************************************************
diff --git a/net/rtsp_proxy/pkg-plist b/net/rtsp_proxy/pkg-plist
new file mode 100644
index 000000000000..33790821c996
--- /dev/null
+++ b/net/rtsp_proxy/pkg-plist
@@ -0,0 +1,3 @@
+etc/qts_proxy.conf
+etc/rc.d/rtsp_proxy.sh
+sbin/rtsp_proxy