aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-04-17 20:52:00 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-04-17 20:52:00 +0000
commit69a89a6bd150ad356047238271a0adce0d344dea (patch)
tree1df64e639f66e59c4102080cb1afc1c9cdf73bb1 /net
parent313cdd2fced068955799cb873bbe7922e75a1d94 (diff)
downloadports-69a89a6bd150ad356047238271a0adce0d344dea.tar.gz
ports-69a89a6bd150ad356047238271a0adce0d344dea.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/httping/Makefile15
-rw-r--r--net/httping/distinfo4
-rw-r--r--net/httping/files/patch-Makefile32
3 files changed, 42 insertions, 9 deletions
diff --git a/net/httping/Makefile b/net/httping/Makefile
index 7e279709ea17..5ecb5a09ec7d 100644
--- a/net/httping/Makefile
+++ b/net/httping/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= httping
-PORTVERSION= 2.1
+PORTVERSION= 2.2
CATEGORIES= net
MASTER_SITES= http://www.vanheusden.com/httping/ \
CRITICAL
@@ -17,6 +17,19 @@ MAKE_JOBS_SAFE= yes
MAN1= httping.1
PLIST_FILES= bin/httping
+OPTIONS_DEFINE= NCURSES
+
+NCURSES_DESC= ncurses support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNCURSES}
+LIB_DEPENDS+= fftw3:${PORTSDIR}/math/fftw3
+MAKE_ENV+= SSL=yes NC=yes FW=yes
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
diff --git a/net/httping/distinfo b/net/httping/distinfo
index 7bcd50b4d65f..cf1596b0066b 100644
--- a/net/httping/distinfo
+++ b/net/httping/distinfo
@@ -1,2 +1,2 @@
-SHA256 (httping-2.1.tgz) = 8b2eabbd480e38b55711f8aac264defef59a9a21c537166e17e9032e86c5e3a8
-SIZE (httping-2.1.tgz) = 24121
+SHA256 (httping-2.2.tgz) = 157125fb1394651854840ca5be2f346be527130f9410372011064a181ec61b49
+SIZE (httping-2.2.tgz) = 32645
diff --git a/net/httping/files/patch-Makefile b/net/httping/files/patch-Makefile
index 6b1eca32b2f9..7823ad35d1cf 100644
--- a/net/httping/files/patch-Makefile
+++ b/net/httping/files/patch-Makefile
@@ -1,12 +1,22 @@
---- ./Makefile.orig 2013-03-19 20:10:16.000000000 +0100
-+++ ./Makefile 2013-03-20 11:56:23.000000000 +0100
-@@ -18,12 +18,11 @@
+--- ./Makefile.orig 2013-04-04 21:46:48.000000000 +0200
++++ ./Makefile 2013-04-17 21:50:18.735645308 +0200
+@@ -12,8 +12,6 @@
+ # version. If you delete this exception statement from all source
+ # files in the program, then also delete it here.
+
+--include makefile.inc
+-
+ # *** configure script ***
+ # support for tcp fast open?
+ #TFO=yes
+@@ -32,12 +30,11 @@
DEBUG=yes
WFLAGS=-Wall -W
-OFLAGS=-O3
CFLAGS+=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\"
- LDFLAGS=-lm
+-LDFLAGS=-lm
++LDFLAGS+=-lm
PACKAGE=$(TARGET)-$(VERSION)
-PREFIX=/usr
@@ -14,8 +24,8 @@
BINDIR=$(PREFIX)/bin
MANDIR=$(PREFIX)/share/man
DOCDIR=$(PREFIX)/share/doc/$(TARGET)
-@@ -59,11 +58,6 @@
- CFLAGS+=-DTCP_TFO
+@@ -82,11 +79,6 @@
+ LDFLAGS+=-lfftw3
endif
-ifeq ($(DEBUG),yes)
@@ -26,3 +36,13 @@
ifeq ($(ARM),yes)
CC=arm-linux-gcc
endif
+@@ -109,9 +101,6 @@
+ $(STRIP) $(DESTDIR)/$(BINDIR)/$(TARGET)
+ endif
+
+-makefile.inc:
+- ./configure
+-
+ clean:
+ $(RMDIR) $(OBJS) $(TARGET) makefile.inc *~ core cov-int
+