aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-02-16 03:01:42 +0000
committerSteve Wills <swills@FreeBSD.org>2018-02-16 03:01:42 +0000
commitac5a06dfa26b80584349692292197aa95bc75a00 (patch)
tree212a1a9566dbe91ba057380e59ec1fa0b01267a3 /net
parentc9bdaaa7be7fbefe3e2154650f9df241a6f810c8 (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/goreplay/Makefile34
-rw-r--r--net/goreplay/distinfo13
-rw-r--r--net/goreplay/pkg-descr6
4 files changed, 54 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 3536a4d61027..2fc476611438 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -196,6 +196,7 @@
SUBDIR += google-startup-scripts
SUBDIR += googlecl
SUBDIR += gopher
+ SUBDIR += goreplay
SUBDIR += gotthard
SUBDIR += gq
SUBDIR += grdesktop
diff --git a/net/goreplay/Makefile b/net/goreplay/Makefile
new file mode 100644
index 000000000000..d50ad76b6179
--- /dev/null
+++ b/net/goreplay/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= goreplay
+PORTVERSION= 0.16.1
+DISTVERSIONPREFIX= v
+CATEGORIES= net
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Tool for capturing and replaying live HTTP traffic
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/go:lang/go
+
+USE_GITHUB= yes
+GH_ACCOUNT= buger
+GH_TUPLE= google:gopacket:b09bf40:gopacket/vendor/github.com/google/gopacket \
+ Shopify:sarama:0fb560e:sarama/vendor/github.com/Shopify/sarama \
+ mattbaird:elastigo:34c4c4d:elastigo/vendor/github.com/mattbaird/elastigo \
+ bitly:go-hostpool:d0e59c2:hostpool/vendor/github.com/bitly/go-hostpool \
+ araddon:gou:50a94aa:gou/vendor/github.com/araddon/gou
+GH_SUBDIR= src/github.com/buger/goreplay
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-build:
+ @cd ${WRKSRC}/${GH_SUBDIR} ; ${SETENV} GOPATH=${WRKSRC} go build
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/goreplay \
+ ${STAGEDIR}${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/net/goreplay/distinfo b/net/goreplay/distinfo
new file mode 100644
index 000000000000..964efd3d40f9
--- /dev/null
+++ b/net/goreplay/distinfo
@@ -0,0 +1,13 @@
+TIMESTAMP = 1518020132
+SHA256 (buger-goreplay-v0.16.1_GH0.tar.gz) = 99c9fec2bd84bbec9c7a550c7b5afbdbda7e596f40b544ff7fd6f24066385234
+SIZE (buger-goreplay-v0.16.1_GH0.tar.gz) = 880631
+SHA256 (google-gopacket-b09bf40_GH0.tar.gz) = 0d8e50fd37700adf2608ea7ac5317e629d4763b14546a8ecbbcdd8affde31da5
+SIZE (google-gopacket-b09bf40_GH0.tar.gz) = 639525
+SHA256 (Shopify-sarama-0fb560e_GH0.tar.gz) = f3ef96805a7c9e85313c658de1ccd1889ddec9c11a3b64c1bc4db91c6b00d744
+SIZE (Shopify-sarama-0fb560e_GH0.tar.gz) = 123942
+SHA256 (mattbaird-elastigo-34c4c4d_GH0.tar.gz) = 0616589706db3924b978685fb67bac82dea2882d00d262391a97788107ead329
+SIZE (mattbaird-elastigo-34c4c4d_GH0.tar.gz) = 76583
+SHA256 (bitly-go-hostpool-d0e59c2_GH0.tar.gz) = 1439213bab2a32731d948f37f126bdfd9d21fce32417b0b00deceb6000044c9f
+SIZE (bitly-go-hostpool-d0e59c2_GH0.tar.gz) = 6784
+SHA256 (araddon-gou-50a94aa_GH0.tar.gz) = 028a10bbaaf93e340c4c3b3d4415c81fab8756d20d0bf9067bf03a0b0c76594a
+SIZE (araddon-gou-50a94aa_GH0.tar.gz) = 16191
diff --git a/net/goreplay/pkg-descr b/net/goreplay/pkg-descr
new file mode 100644
index 000000000000..79a511e34bf3
--- /dev/null
+++ b/net/goreplay/pkg-descr
@@ -0,0 +1,6 @@
+GoReplay is an open-source tool for capturing and replaying live HTTP traffic
+into a test environment in order to continuously test your system with real
+data. It can be used to increase confidence in code deployments, configuration
+changes and infrastructure changes.
+
+WWW: https://goreplay.org/