aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-15 18:18:34 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-15 18:18:34 +0000
commitce6685b10354eb2e52ca1de0250ec1590fbd6729 (patch)
tree6599a9eb0f33f86616d3ec4ee177e520525c5ca3 /net
parent421863db25099229300c2162660536e4497878c5 (diff)
downloadports-ce6685b10354eb2e52ca1de0250ec1590fbd6729.tar.gz
ports-ce6685b10354eb2e52ca1de0250ec1590fbd6729.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/silc-client/Makefile33
-rw-r--r--net/silc-client/distinfo6
-rw-r--r--net/silc-irssi-plugin/Makefile1
3 files changed, 16 insertions, 24 deletions
diff --git a/net/silc-client/Makefile b/net/silc-client/Makefile
index f5396d2ac298..fc029df99daf 100644
--- a/net/silc-client/Makefile
+++ b/net/silc-client/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= silc
-PORTVERSION= 1.1.2
+PORTVERSION= 1.1.3
CATEGORIES= net ipv6 security
MASTER_SITES= http://www.silcnet.org/download/%SUBDIR%/ \
http://ftp.silcnet.org/%SUBDIR%/ \
@@ -36,11 +36,9 @@ CONFIGURE_ARGS= --docdir=${DOCSDIR} \
--with-perl=no \
--without-libtoolfix
-.ifndef(WITH_PTHREADS)
-CONFIGURE_ARGS+= --without-pthreads
-.else
-CONFIGURE_ENV+= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} ${PTHREAD_LIBS}"
-.endif
+OPTIONS= PTHREADS "Enable pthreads support" off \
+ IPV6 "Enable IPv6 support" on \
+ OPTIMIZED_ASM "Use assembler optimizations (i386 only)" on
.ifdef(IRSSI_PLUGIN)
CONFIGURE_ARGS+= --with-silc-plugin=${PREFIX}/lib/irssi \
@@ -53,17 +51,6 @@ EXTRA_PATCHES= ${FILESDIR}/extra-patch-apps__irssi__Makefile.in
MAN1= silc.1
.endif
-pre-everything::
-.ifndef(WITHOUT_IPV6)
- @${ECHO_MSG} '===> Define WITHOUT_IPV6 to disable IPv6 support'
-.endif
-.ifndef(WITHOUT_OPTIMIZED_ASM)
- @${ECHO_MSG} '===> Define WITHOUT_OPTIMIZED_ASM to disable assembler optimizations'
-.endif
-.ifndef(WITH_PTHREADS)
- @${ECHO_MSG} '===> Define WITH_PTHREADS to enable pthreads support'
-.endif
-
post-patch:
# install neither documentation nor silc server, we have ports for those
@${REINPLACE_CMD} -e 's/-D_THREAD_SAFE//' ${WRKSRC}/${CONFIGURE_SCRIPT}
@@ -89,12 +76,18 @@ post-install:
WITHOUT_OPTIMIZED_ASM= yes
.endif
-.ifndef(WITHOUT_IPV6)
-CONFIGURE_ARGS+= --enable-ipv6
+.if defined(WITHOUT_IPV6)
+CONFIGURE_ARGS+= --disable-ipv6
.endif
-.ifdef(WITHOUT_OPTIMIZED_ASM)
+.if defined(WITHOUT_OPTIMIZED_ASM)
CONFIGURE_ARGS+= --disable-asm
.endif
+.if defined(WITH_PTHREADS)
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} ${PTHREAD_LIBS}"
+.else
+CONFIGURE_ARGS+= --without-pthreads
+.endif
+
.include <bsd.port.post.mk>
diff --git a/net/silc-client/distinfo b/net/silc-client/distinfo
index 10e8573b7b46..d01dcf2918ef 100644
--- a/net/silc-client/distinfo
+++ b/net/silc-client/distinfo
@@ -1,3 +1,3 @@
-MD5 (silc-client-1.1.2.tar.bz2) = 6e440bbfd9a746cf33c020c31ab95a30
-SHA256 (silc-client-1.1.2.tar.bz2) = 6c03bf28c87eef31c2058acfa132542cc088ae819f2233d520b042eb916d89f4
-SIZE (silc-client-1.1.2.tar.bz2) = 1622496
+MD5 (silc-client-1.1.3.tar.bz2) = e34d0af3c795ba0167d465904b9ba120
+SHA256 (silc-client-1.1.3.tar.bz2) = efc9ae70250f8e06c88e5b0416a9c38dca9476dc8955ee917c7a9366e2390ea8
+SIZE (silc-client-1.1.3.tar.bz2) = 1626208
diff --git a/net/silc-irssi-plugin/Makefile b/net/silc-irssi-plugin/Makefile
index fd43f0bae021..33efd6401105 100644
--- a/net/silc-irssi-plugin/Makefile
+++ b/net/silc-irssi-plugin/Makefile
@@ -5,7 +5,6 @@
# $FreeBSD$
#
-PORTREVISION= 1
CATEGORIES= net irc
COMMENT= SILC plugin for IRSSI