aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-12-17 17:24:58 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-12-17 17:24:58 +0000
commitd11936114f4a6fa2a85717456d4f2663888a02e7 (patch)
tree437b41d8f6c20bf61b0a4ad8b6604f0f615def26 /net
parent289ced7fc41f01609afaad71a0f8671ca1e70467 (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/tcping/Makefile29
-rw-r--r--net/tcping/distinfo1
-rw-r--r--net/tcping/pkg-descr11
-rw-r--r--net/tcping/pkg-plist4
5 files changed, 46 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index c5777da9f27d..182dffd4b27f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -675,6 +675,7 @@
SUBDIR += tcpdump
SUBDIR += tcpflow
SUBDIR += tcpillust
+ SUBDIR += tcping
SUBDIR += tcpmssd
SUBDIR += tcpreen
SUBDIR += tcpreplay
diff --git a/net/tcping/Makefile b/net/tcping/Makefile
new file mode 100644
index 000000000000..b0106cf6c073
--- /dev/null
+++ b/net/tcping/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: tcping
+# Date created: 2003-12-16
+# Whom: Dryice Liu
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcping
+PORTVERSION= 1.3.3
+CATEGORIES= net
+MASTER_SITES= http://stud.fh-heilbronn.de/~kirchner/tcping/
+
+MAINTAINER= dryice@liu.com.cn
+COMMENT= Do a TCP connect to the given ip/port combination
+
+DOCS= README
+
+do-build:
+ cd ${WRKSRC} && \
+ ${CC} ${CFLAGS} -DHAVE_HSTRERROR -o tcping tcping.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tcping ${PREFIX}/bin/tcping
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/tcping/distinfo b/net/tcping/distinfo
new file mode 100644
index 000000000000..ad64f4fb8596
--- /dev/null
+++ b/net/tcping/distinfo
@@ -0,0 +1 @@
+MD5 (tcping-1.3.3.tar.gz) = 93621ec0a5d460ca22828d67178ec908
diff --git a/net/tcping/pkg-descr b/net/tcping/pkg-descr
new file mode 100644
index 000000000000..19eef0a7b662
--- /dev/null
+++ b/net/tcping/pkg-descr
@@ -0,0 +1,11 @@
+tcping does a TCP connect to the given ip/port combination.
+The user can specify a timeout in seconds.
+This is useful in shell scripts running in firewalled environments.
+Often SYNs are just being dropped by firewalls,
+thus connection establishment will be retried several times
+(for minutes) until a TCP timeout is reached.
+With tcping it is possible to check first if the desired port
+is reachable and then start connection establishment.
+
+Author: Marc Kirchner <mail(at)marc(dash)kirchner(dot)de>
+WWW: http://stud.fh-heilbronn.de/~kirchner/tcping/tcping.html
diff --git a/net/tcping/pkg-plist b/net/tcping/pkg-plist
new file mode 100644
index 000000000000..b7f6d403973c
--- /dev/null
+++ b/net/tcping/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+bin/tcping
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%