aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
commitfe61bf1eb4f2758636a3c065686a833eb412df25 (patch)
tree1474457ea487adcafec2ab29e99ab61897a3e479 /net
parent5732783897145621b6af3ab08fba8d9af40f338b (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/ekiga3/Makefile4
-rw-r--r--net/ekiga3/files/patch-lib_engine_components_libnotify_libnotify-main.cpp13
-rw-r--r--net/ekiga3/files/patch-src_gui_main.cpp16
-rw-r--r--net/liferea/Makefile2
-rw-r--r--net/twitux/Makefile4
-rw-r--r--net/twitux/files/patch-src_twitux-app.c12
-rw-r--r--net/vino/Makefile4
7 files changed, 46 insertions, 9 deletions
diff --git a/net/ekiga3/Makefile b/net/ekiga3/Makefile
index 7346c4d340bb..6a00dbf8b701 100644
--- a/net/ekiga3/Makefile
+++ b/net/ekiga3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ekiga3
PORTVERSION= 3.2.6
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net
MASTER_SITES= http://www.ekiga.org/admin/downloads/latest/sources/ekiga_${PORTVERSION}/
DISTNAME= ekiga-${PORTVERSION}
@@ -88,7 +88,7 @@ CONFIGURE_ARGS+= --disable-h323
.endif
.if defined(WITH_NOTIFY)
-LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+= --enable-notify
.else
CONFIGURE_ARGS+= --disable-notify
diff --git a/net/ekiga3/files/patch-lib_engine_components_libnotify_libnotify-main.cpp b/net/ekiga3/files/patch-lib_engine_components_libnotify_libnotify-main.cpp
index a6ac603c4ef4..5b5f5c23b63e 100644
--- a/net/ekiga3/files/patch-lib_engine_components_libnotify_libnotify-main.cpp
+++ b/net/ekiga3/files/patch-lib_engine_components_libnotify_libnotify-main.cpp
@@ -1,5 +1,5 @@
---- lib/engine/components/libnotify/libnotify-main.cpp.orig 2010-08-28 15:04:11.000000000 -0400
-+++ lib/engine/components/libnotify/libnotify-main.cpp 2010-08-28 15:01:22.000000000 -0400
+--- lib/engine/components/libnotify/libnotify-main.cpp.orig 2009-09-22 16:27:35.000000000 +0200
++++ lib/engine/components/libnotify/libnotify-main.cpp 2011-03-08 22:11:18.000000000 +0100
@@ -38,6 +38,7 @@
#include <map>
#include <tr1/memory>
@@ -8,3 +8,12 @@
#include <libnotify/notify.h>
#include "services.h"
+@@ -158,7 +159,7 @@ LibNotify::on_notification_added (gmref_
+
+ notif = notify_notification_new (notification->get_title ().c_str (),
+ notification->get_body ().c_str (),
+- urgency, NULL);
++ urgency);
+
+ g_signal_connect (notif, "closed",
+ G_CALLBACK (on_notif_closed), notification.get ());
diff --git a/net/ekiga3/files/patch-src_gui_main.cpp b/net/ekiga3/files/patch-src_gui_main.cpp
new file mode 100644
index 000000000000..3982ef64fb96
--- /dev/null
+++ b/net/ekiga3/files/patch-src_gui_main.cpp
@@ -0,0 +1,16 @@
+--- src/gui/main.cpp.orig 2011-03-08 22:31:52.000000000 +0100
++++ src/gui/main.cpp 2011-03-08 22:47:35.000000000 +0100
+@@ -2807,12 +2807,11 @@ ekiga_main_window_incoming_call_notify (
+
+ body = g_strdup_printf ("%s\n%s\n%s", uri, app, account);
+
+- notify = notify_notification_new (title, body, GM_ICON_LOGO, NULL);
++ notify = notify_notification_new (title, body, GM_ICON_LOGO);
+ notify_notification_add_action (notify, "accept", _("Accept"), notify_action_cb, mw, NULL);
+ notify_notification_add_action (notify, "reject", _("Reject"), notify_action_cb, mw, NULL);
+ notify_notification_set_timeout (notify, NOTIFY_EXPIRES_NEVER);
+ notify_notification_set_urgency (notify, NOTIFY_URGENCY_CRITICAL);
+- notify_notification_attach_to_status_icon (notify, statusicon);
+ if (!notify_notification_show (notify, NULL)) {
+ ekiga_main_window_incoming_call_dialog_show (mw, call);
+ }
diff --git a/net/liferea/Makefile b/net/liferea/Makefile
index 463f9d37dadc..b596d8608ece 100644
--- a/net/liferea/Makefile
+++ b/net/liferea/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= pav@FreeBSD.org
COMMENT= Simple RSS/RDF feed reader
LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3 \
- webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2
+ webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2
USE_GNOME= gnomeprefix gnomehack libglade2 gconf2
USE_GMAKE= yes
diff --git a/net/twitux/Makefile b/net/twitux/Makefile
index f4be6b91fe13..99fe516205c2 100644
--- a/net/twitux/Makefile
+++ b/net/twitux/Makefile
@@ -7,7 +7,7 @@
PORTNAME= twitux
PORTVERSION= 0.69
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net
MASTER_SITES= SF
@@ -16,7 +16,7 @@ COMMENT= GNOME client for Twitter
LIB_DEPENDS= soup-2.4.1:${PORTSDIR}/devel/libsoup \
sexy.2:${PORTSDIR}/x11-toolkits/libsexy \
- notify.1:${PORTSDIR}/devel/libnotify \
+ notify.4:${PORTSDIR}/devel/libnotify \
canberra:${PORTSDIR}/audio/libcanberra
USE_XORG= x11
diff --git a/net/twitux/files/patch-src_twitux-app.c b/net/twitux/files/patch-src_twitux-app.c
new file mode 100644
index 000000000000..588eddf8b73f
--- /dev/null
+++ b/net/twitux/files/patch-src_twitux-app.c
@@ -0,0 +1,12 @@
+--- src/twitux-app.c.orig 2011-08-16 15:27:29.000000000 +0200
++++ src/twitux-app.c 2011-08-16 15:27:54.000000000 +0200
+@@ -1446,8 +1446,7 @@ twitux_app_notify (gchar *msg)
+
+ notification = notify_notification_new (PACKAGE_NAME,
+ msg,
+- "twitux",
+- NULL);
++ "twitux");
+
+ notify_notification_set_timeout (notification, 8 * 1000);
+ notify_notification_show (notification, &error);
diff --git a/net/vino/Makefile b/net/vino/Makefile
index 0015cdc47cd0..c4d2501f1abc 100644
--- a/net/vino/Makefile
+++ b/net/vino/Makefile
@@ -8,7 +8,7 @@
PORTNAME= vino
PORTVERSION= 2.32.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -34,7 +34,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GCONF_SCHEMAS= vino-server.schemas
.if !defined(WITHOUT_NOTIFY)
-LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+=--enable-libnotify=yes
.else
CONFIGURE_ARGS+=--enable-libnotify=no